aboutsummaryrefslogtreecommitdiff
path: root/security/p5-Nmap-Parser/Makefile
diff options
context:
space:
mode:
authorCheng-Lung Sung <clsung@FreeBSD.org>2006-06-06 08:49:36 +0000
committerCheng-Lung Sung <clsung@FreeBSD.org>2006-06-06 08:49:36 +0000
commit6aa8cb1880757143354056a148ccd9a0fb27a0ed (patch)
tree1662d6cbdcf16fe20d76b2b3e2f8092cba98b0cf /security/p5-Nmap-Parser/Makefile
parentc6a842e8122d991e5bd648f9524b565436797d48 (diff)
downloadports-6aa8cb1880757143354056a148ccd9a0fb27a0ed.tar.gz
ports-6aa8cb1880757143354056a148ccd9a0fb27a0ed.zip
Notes
Diffstat (limited to 'security/p5-Nmap-Parser/Makefile')
-rw-r--r--security/p5-Nmap-Parser/Makefile29
1 files changed, 29 insertions, 0 deletions
diff --git a/security/p5-Nmap-Parser/Makefile b/security/p5-Nmap-Parser/Makefile
new file mode 100644
index 000000000000..88a6d0ac2b15
--- /dev/null
+++ b/security/p5-Nmap-Parser/Makefile
@@ -0,0 +1,29 @@
+# New ports collection makefile for: p5-Nmap-Parser
+# Date created: June 3 2006
+# Whom: Joshua D. Abraham <jabra@ccs.neu.edu>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Nmap-Parser
+PORTVERSION= 1.05
+CATEGORIES= security perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= ../../authors/id/A/AP/APERSAUD
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= jabra@ccs.neu.edu
+COMMENT= Parse nmap scan data with perl
+
+BUILD_DEPENDS= ${SITE_PERL}/XML/Twig.pm:${PORTSDIR}/textproc/p5-XML-Twig
+RUN_DEPENDS= ${BUILD_DEPENDS} \
+ nmap:${PORTSDIR}/security/nmap
+
+PERL_CONFIGURE= yes
+
+MAN3= Nmap::Parser.3
+
+post-configure:
+ @${PERL} -pi -e 's/^(POD2MAN_EXE.*)$$/\1 --lax/;' ${WRKSRC}/Makefile
+
+.include <bsd.port.mk>