aboutsummaryrefslogtreecommitdiff
path: root/security/p5-OpenCA-REQ
diff options
context:
space:
mode:
authorSergey Skvortsov <skv@FreeBSD.org>2003-11-15 17:06:25 +0000
committerSergey Skvortsov <skv@FreeBSD.org>2003-11-15 17:06:25 +0000
commit3eb21f2f44ee33739b71c737dddee403f53d742d (patch)
tree2df3e03edddd48615e574705588febcd78c14dfa /security/p5-OpenCA-REQ
parent2ba67fee1421afa34611023c84c702df53cac8a9 (diff)
downloadports-3eb21f2f44ee33739b71c737dddee403f53d742d.tar.gz
ports-3eb21f2f44ee33739b71c737dddee403f53d742d.zip
Notes
Diffstat (limited to 'security/p5-OpenCA-REQ')
-rw-r--r--security/p5-OpenCA-REQ/Makefile34
-rw-r--r--security/p5-OpenCA-REQ/distinfo1
-rw-r--r--security/p5-OpenCA-REQ/pkg-descr6
-rw-r--r--security/p5-OpenCA-REQ/pkg-plist5
4 files changed, 46 insertions, 0 deletions
diff --git a/security/p5-OpenCA-REQ/Makefile b/security/p5-OpenCA-REQ/Makefile
new file mode 100644
index 000000000000..62e7574322d8
--- /dev/null
+++ b/security/p5-OpenCA-REQ/Makefile
@@ -0,0 +1,34 @@
+# New ports collection makefile for: OpenCA-REQ
+# Date created: 02 June 2002
+# Whom: Sergey Skvortsov <skv@protey.ru>
+#
+# $FreeBSD$
+#
+
+PORTNAME= OpenCA-REQ
+PORTVERSION= 0.9.52
+CATEGORIES= security perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= OpenCA
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= skv@FreeBSD.org
+COMMENT= Perl extension to easily manage Cert REQUESTs
+
+BUILD_DEPENDS= ${SITE_PERL}/X500/DN.pm:${PORTSDIR}/net/p5-X500-DN
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN3= OpenCA::REQ.3
+
+.include <bsd.port.pre.mk>
+
+post-patch:
+.if ${PERL_LEVEL} < 500600
+ @${PERL} -pi -e 's!^our \((.*?)(?=\);)!join("","use vars qw(",split(/,/,$$1))!e' \
+ ${WRKSRC}/*.pm
+.endif
+ @${MV} ${WRKSRC}/prova.pl ${WRKSRC}/prova.pl.sample
+
+.include <bsd.port.post.mk>
diff --git a/security/p5-OpenCA-REQ/distinfo b/security/p5-OpenCA-REQ/distinfo
new file mode 100644
index 000000000000..db3c12c2c2b9
--- /dev/null
+++ b/security/p5-OpenCA-REQ/distinfo
@@ -0,0 +1 @@
+MD5 (OpenCA-REQ-0.9.52.tar.gz) = 048f30201f20a5f722e7f7d0e80918a9
diff --git a/security/p5-OpenCA-REQ/pkg-descr b/security/p5-OpenCA-REQ/pkg-descr
new file mode 100644
index 000000000000..221d9a9d12b5
--- /dev/null
+++ b/security/p5-OpenCA-REQ/pkg-descr
@@ -0,0 +1,6 @@
+This module is intended for easily manage Cert REQUESTs.
+
+WWW: http://search.cpan.org/dist/OpenCA-REQ/
+
+-- Sergey Skvortsov
+skv@FreeBSD.org
diff --git a/security/p5-OpenCA-REQ/pkg-plist b/security/p5-OpenCA-REQ/pkg-plist
new file mode 100644
index 000000000000..002de9fc3097
--- /dev/null
+++ b/security/p5-OpenCA-REQ/pkg-plist
@@ -0,0 +1,5 @@
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/OpenCA/REQ/.packlist
+%%SITE_PERL%%/OpenCA/REQ.pm
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/OpenCA/REQ
+@unexec rmdir %D/%%SITE_PERL%%/OpenCA 2>/dev/null || true
+@unexec rmdir %D/%%SITE_PERL%%/%%PERL_ARCH%%/auto/OpenCA 2>/dev/null || true