aboutsummaryrefslogtreecommitdiff
path: root/security/p5-PGP-Sign
diff options
context:
space:
mode:
authorSteve Wills <swills@FreeBSD.org>2012-03-08 15:40:53 +0000
committerSteve Wills <swills@FreeBSD.org>2012-03-08 15:40:53 +0000
commit414c2f580610e551f1d8cf3e6d8aafaabcd1fbe7 (patch)
treebf0bd0d2abd3573923e107546cce16cf1d7ff9d5 /security/p5-PGP-Sign
parentb7bffd6e3ab3ce1ab8d97d328ec1a5303916d74a (diff)
downloadports-414c2f580610e551f1d8cf3e6d8aafaabcd1fbe7.tar.gz
ports-414c2f580610e551f1d8cf3e6d8aafaabcd1fbe7.zip
Notes
Diffstat (limited to 'security/p5-PGP-Sign')
-rw-r--r--security/p5-PGP-Sign/Makefile6
1 files changed, 5 insertions, 1 deletions
diff --git a/security/p5-PGP-Sign/Makefile b/security/p5-PGP-Sign/Makefile
index c320ef61d233..df339ada2d87 100644
--- a/security/p5-PGP-Sign/Makefile
+++ b/security/p5-PGP-Sign/Makefile
@@ -7,6 +7,7 @@
PORTNAME= PGP-Sign
PORTVERSION= 0.20
+PORTREVISION= 1
CATEGORIES= security perl5
MASTER_SITES= CPAN
PKGNAMEPREFIX= p5-
@@ -29,16 +30,18 @@ MAN3= PGP::Sign.3
# GPG - Gnu Privacy Guard
.ifndef DEFAULTPGP
-DEFAULTPGP= PGP2
+DEFAULTPGP= GPG
.endif
.if (${DEFAULTPGP} == PGP2 )
+BUILD_DEPENDS= pgp:${PORTSDIR}/security/pgp
RUN_DEPENDS= pgp:${PORTSDIR}/security/pgp
PGPSTYLE?= PGP2
.ifndef PGP
PGP!= which pgp || ${ECHO} ${PREFIX}/bin/pgp
.endif
.elif (${DEFAULTPGP} == PGP5 )
+BUILD_DEPENDS= pgps:${PORTSDIR}/security/pgp5
RUN_DEPENDS= pgps:${PORTSDIR}/security/pgp5
PGPSTYLE?= PGP5
.ifndef PGPS
@@ -51,6 +54,7 @@ PGPV!= which pgpv || ${ECHO} ${PREFIX}/bin/pgpv
PGP!= which pgp || ${ECHO} ${PREFIX}/bin/pgp
.endif
.elif (${DEFAULTPGP} == GPG)
+BUILD_DEPENDS= gpg:${PORTSDIR}/security/gnupg
RUN_DEPENDS= gpg:${PORTSDIR}/security/gnupg
PGPSTYLE?= GPG
.ifndef PGP