aboutsummaryrefslogtreecommitdiff
path: root/security/p5-SAVI-Perl
diff options
context:
space:
mode:
authorNiels Heinen <niels@FreeBSD.org>2005-01-14 14:04:38 +0000
committerNiels Heinen <niels@FreeBSD.org>2005-01-14 14:04:38 +0000
commitc3129ccd66fdca017369594d04090f8debdd2943 (patch)
tree8dfe639baa05f7ab06a7726e9adb894866942e52 /security/p5-SAVI-Perl
parentcec82227a1603a1363166550df8f5601275f7d5f (diff)
downloadports-c3129ccd66fdca017369594d04090f8debdd2943.tar.gz
ports-c3129ccd66fdca017369594d04090f8debdd2943.zip
Notes
Diffstat (limited to 'security/p5-SAVI-Perl')
-rw-r--r--security/p5-SAVI-Perl/Makefile13
1 files changed, 13 insertions, 0 deletions
diff --git a/security/p5-SAVI-Perl/Makefile b/security/p5-SAVI-Perl/Makefile
index 60b03fb7d3de..756e342abead 100644
--- a/security/p5-SAVI-Perl/Makefile
+++ b/security/p5-SAVI-Perl/Makefile
@@ -6,6 +6,7 @@
PORTNAME= SAVI-Perl
PORTVERSION= 0.30
+PORTREVISION= 1
CATEGORIES= security perl5
MASTER_SITES= http://www.csupomona.edu/~henson/www/projects/SAVI-Perl/dist/
MASTER_SITE_SUBDIR= security
@@ -17,6 +18,7 @@ COMMENT= Perl5 module interface to Sophos AntiVirus
MAN= SAVI.3
PERL_CONFIGURE= yes
+ONLY_FOR_ARCHS= i386
.include <bsd.port.pre.mk>
@@ -26,4 +28,15 @@ IGNORE= Port requires perl 5.6 or newer. Upgrade your perl and try again. \
yet.
.endif
+.if exists(${PREFIX}/lib/libsavi.so.3) && !exists(${PREFIX}/lib/libsavi.so)
+FAKELIBDIR=${WRKDIR}/lib
+CONFIGURE_ARGS+= LDDLFLAGS='-shared -L ${FAKELIBDIR}'
+.endif
+
+.if defined(FAKELIBDIR)
+pre-configure:
+ ${MKDIR} ${FAKELIBDIR}
+ ${LN} -s ${PREFIX}/lib/libsavi.so.3 ${FAKELIBDIR}/libsavi.so
+.endif
+
.include <bsd.port.post.mk>