aboutsummaryrefslogtreecommitdiff
path: root/security/p5-Sudo/Makefile
diff options
context:
space:
mode:
authorCheng-Lung Sung <clsung@FreeBSD.org>2007-07-02 01:00:27 +0000
committerCheng-Lung Sung <clsung@FreeBSD.org>2007-07-02 01:00:27 +0000
commitb399e0595ad5a123562574ca94e686bd7148d97c (patch)
tree227c43a30f67f66dd1b030bcbe1a4504c9fadb77 /security/p5-Sudo/Makefile
parentc94ba61603f7e6aa7fbbb8f7b4aca58cf5e646b9 (diff)
Notes
Diffstat (limited to 'security/p5-Sudo/Makefile')
-rw-r--r--security/p5-Sudo/Makefile33
1 files changed, 33 insertions, 0 deletions
diff --git a/security/p5-Sudo/Makefile b/security/p5-Sudo/Makefile
new file mode 100644
index 000000000000..9fe0624b0931
--- /dev/null
+++ b/security/p5-Sudo/Makefile
@@ -0,0 +1,33 @@
+# New ports collection makefile for: p5-Sudo
+# Date created: 2007-05-27
+# Whom: Gea-Suan Lin <gslin@gslin.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Sudo
+PORTVERSION= 0.31
+CATEGORIES= security perl5
+MASTER_SITES= CPAN
+MASTER_SITE_SUBDIR= ../../authors/id/L/LA/LANDMAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= gslin@gslin.org
+COMMENT= Perl extension for running a command line sudo
+
+RUN_DEPENDS= ${SITE_PERL}/Term/ReadPassword.pm:${PORTSDIR}/devel/p5-Term-ReadPassword \
+ ${SITE_PERL}/Class/Accessor.pm:${PORTSDIR}/devel/p5-Class-Accessor \
+ ${SITE_PERL}/IPC/Run.pm:${PORTSDIR}/devel/p5-IPC-Run
+BUILD_DEPENDS= ${RUN_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN3= Sudo.3
+
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500801
+IGNORE= requires Perl >= 5.8.1. Install lang/perl5.8 and try again
+.endif
+
+.include <bsd.port.post.mk>