aboutsummaryrefslogtreecommitdiff
path: root/security/p5-openxpki-deployment/Makefile
diff options
context:
space:
mode:
authorRong-En Fan <rafan@FreeBSD.org>2006-10-07 12:32:19 +0000
committerRong-En Fan <rafan@FreeBSD.org>2006-10-07 12:32:19 +0000
commit243c063a6a768a867466c82c4ac9cc81aeb09d06 (patch)
treed2dda0b9adc9534de9e52f1e0b95e6dae9fdd538 /security/p5-openxpki-deployment/Makefile
parent0ffdd411b17e9c84cd4cf1c3cb580848eaaa63be (diff)
Notes
Diffstat (limited to 'security/p5-openxpki-deployment/Makefile')
-rw-r--r--security/p5-openxpki-deployment/Makefile35
1 files changed, 35 insertions, 0 deletions
diff --git a/security/p5-openxpki-deployment/Makefile b/security/p5-openxpki-deployment/Makefile
new file mode 100644
index 000000000000..c004df8a0f37
--- /dev/null
+++ b/security/p5-openxpki-deployment/Makefile
@@ -0,0 +1,35 @@
+# New ports collection makefile for: p5-openxpki-deployment
+# Date created: 03 Oct 2006
+# Whom: svysh
+#
+# $FreeBSD$
+#
+
+PORTNAME= openxpki-deployment
+PORTVERSION= 0.9.543
+CATEGORIES= security perl5
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= openxpki
+PKGNAMEPREFIX= p5-
+DIST_SUBDIR= openxpki
+
+MAINTAINER= svysh@cryptocom.ru
+COMMENT= Perl based enterprise class trustcenter software for PKI
+
+BUILD_DEPENDS= \
+ ${SITE_PERL}/OpenXPKI/Client.pm:${PORTSDIR}/security/p5-openxpki-client \
+ ${SITE_PERL}/Config/Std.pm:${PORTSDIR}/devel/p5-Config-Std \
+ ${SITE_PERL}/IO/Prompt.pm:${PORTSDIR}/devel/p5-IO-Prompt \
+ ${SITE_PERL}/${PERL_ARCH}/Template.pm:${PORTSDIR}/www/p5-Template-Toolkit
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+MAN1= openxpki-configure.1 \
+ openxpki-metaconf.1 \
+ openxpkiadm.1 \
+ openxpkictl.1
+USE_PERL5= yes
+USE_GMAKE= yes
+HAS_CONFIGURE= yes
+CONFIGURE_ARGS= --prefix ${PREFIX}
+
+.include <bsd.port.mk>