aboutsummaryrefslogtreecommitdiff
path: root/security/p5-openxpki-deployment
diff options
context:
space:
mode:
authorRong-En Fan <rafan@FreeBSD.org>2006-10-07 12:32:19 +0000
committerRong-En Fan <rafan@FreeBSD.org>2006-10-07 12:32:19 +0000
commit243c063a6a768a867466c82c4ac9cc81aeb09d06 (patch)
treed2dda0b9adc9534de9e52f1e0b95e6dae9fdd538 /security/p5-openxpki-deployment
parent0ffdd411b17e9c84cd4cf1c3cb580848eaaa63be (diff)
downloadports-243c063a6a768a867466c82c4ac9cc81aeb09d06.tar.gz
ports-243c063a6a768a867466c82c4ac9cc81aeb09d06.zip
Notes
Diffstat (limited to 'security/p5-openxpki-deployment')
-rw-r--r--security/p5-openxpki-deployment/Makefile35
-rw-r--r--security/p5-openxpki-deployment/distinfo3
-rw-r--r--security/p5-openxpki-deployment/pkg-descr24
-rw-r--r--security/p5-openxpki-deployment/pkg-plist34
4 files changed, 96 insertions, 0 deletions
diff --git a/security/p5-openxpki-deployment/Makefile b/security/p5-openxpki-deployment/Makefile
new file mode 100644
index 000000000000..c004df8a0f37
--- /dev/null
+++ b/security/p5-openxpki-deployment/Makefile
@@ -0,0 +1,35 @@
+# New ports collection makefile for: p5-openxpki-deployment
+# Date created: 03 Oct 2006
+# Whom: svysh
+#
+# $FreeBSD$
+#
+
+PORTNAME= openxpki-deployment
+PORTVERSION= 0.9.543
+CATEGORIES= security perl5
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= openxpki
+PKGNAMEPREFIX= p5-
+DIST_SUBDIR= openxpki
+
+MAINTAINER= svysh@cryptocom.ru
+COMMENT= Perl based enterprise class trustcenter software for PKI
+
+BUILD_DEPENDS= \
+ ${SITE_PERL}/OpenXPKI/Client.pm:${PORTSDIR}/security/p5-openxpki-client \
+ ${SITE_PERL}/Config/Std.pm:${PORTSDIR}/devel/p5-Config-Std \
+ ${SITE_PERL}/IO/Prompt.pm:${PORTSDIR}/devel/p5-IO-Prompt \
+ ${SITE_PERL}/${PERL_ARCH}/Template.pm:${PORTSDIR}/www/p5-Template-Toolkit
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+MAN1= openxpki-configure.1 \
+ openxpki-metaconf.1 \
+ openxpkiadm.1 \
+ openxpkictl.1
+USE_PERL5= yes
+USE_GMAKE= yes
+HAS_CONFIGURE= yes
+CONFIGURE_ARGS= --prefix ${PREFIX}
+
+.include <bsd.port.mk>
diff --git a/security/p5-openxpki-deployment/distinfo b/security/p5-openxpki-deployment/distinfo
new file mode 100644
index 000000000000..7316fc81ec40
--- /dev/null
+++ b/security/p5-openxpki-deployment/distinfo
@@ -0,0 +1,3 @@
+MD5 (openxpki/openxpki-deployment-0.9.543.tar.gz) = 8a5975feca7510f88456595a42baaf5c
+SHA256 (openxpki/openxpki-deployment-0.9.543.tar.gz) = 8e724c345cec8d4f20898f40496e3b996ad9edfa68d59eed7bcd4775c898fc8e
+SIZE (openxpki/openxpki-deployment-0.9.543.tar.gz) = 42323
diff --git a/security/p5-openxpki-deployment/pkg-descr b/security/p5-openxpki-deployment/pkg-descr
new file mode 100644
index 000000000000..dccf2ae39cd6
--- /dev/null
+++ b/security/p5-openxpki-deployment/pkg-descr
@@ -0,0 +1,24 @@
+A collection of ports for the OpenXPKI suite - Perl based trustcenter
+software for PKI: server and client parts along with deployment tools.
+
+p5-openxpki: core for server part
+p5-openxpki-client: base class for actual clients
+p5-openxpki-i18n: internationalization of the user interface
+p5-openxpki-client-cli: command line interface to local OpenXPKI daemon
+p5-openxpki-client-html-mason: web interface to local OpenXPKI daemon
+p5-openxpki-client-scep: set of SCEP tools
+p5-openxpki-client-soap-lite: set of SOAP-Lite tools
+p5-openxpki-deployment: set or deployment tools
+
+Dependencies of OpenXPKI ports ("A --> B" means that port B depends on port A):
+
+ p5-openxpki-client <-- p5-openxpki (server) --> p5-openxpki-i18n
+ \
+ \ | p5-openxpki-client-cli, p5-openxpki-client-html-mason,
+ \--> | p5-openxpki-client-scep, p5-openxpki-client-soap-lite,
+ | p5-openxpki-deployment.
+Notes:
+I18n is needed for the English interface too. For effective use of deployment,
+it is recommended to install at least one of the clients: ...-cli or ...-mason.
+
+WWW: http://www.openxpki.org/
diff --git a/security/p5-openxpki-deployment/pkg-plist b/security/p5-openxpki-deployment/pkg-plist
new file mode 100644
index 000000000000..eee428f85612
--- /dev/null
+++ b/security/p5-openxpki-deployment/pkg-plist
@@ -0,0 +1,34 @@
+bin/openxpki-configure
+bin/openxpki-metaconf
+bin/openxpkiadm
+bin/openxpkictl
+share/nls/POSIX
+share/nls/en_US.US-ASCII
+share/openxpki/templates/default/acl.xml
+share/openxpki/templates/default/auth.xml
+share/openxpki/templates/default/config.xml
+share/openxpki/templates/default/database.xml
+share/openxpki/templates/default/log.conf
+share/openxpki/templates/default/openxpki.conf
+share/openxpki/templates/default/profile.xml
+share/openxpki/templates/default/token.xml
+share/openxpki/templates/default/workflow.xml
+share/openxpki/templates/default/workflow_activity.xml
+share/openxpki/templates/default/workflow_activity_certificate_issuance.xml
+share/openxpki/templates/default/workflow_activity_certificate_signing_request.xml
+share/openxpki/templates/default/workflow_activity_crl_issuance.xml
+share/openxpki/templates/default/workflow_activity_dataexchange.xml
+share/openxpki/templates/default/workflow_activity_null.xml
+share/openxpki/templates/default/workflow_condition.xml
+share/openxpki/templates/default/workflow_def_certificate_issuance.xml
+share/openxpki/templates/default/workflow_def_certificate_signing_request.xml
+share/openxpki/templates/default/workflow_def_certificate_signing_request_dataonly.xml
+share/openxpki/templates/default/workflow_def_certificate_signing_request_offline.xml
+share/openxpki/templates/default/workflow_def_certificate_signing_request_online.xml
+share/openxpki/templates/default/workflow_def_crl_issuance.xml
+share/openxpki/templates/default/workflow_def_dataexchange_export.xml
+share/openxpki/templates/default/workflow_def_dataexchange_import.xml
+share/openxpki/templates/default/workflow_validator_certificate_signing_request.xml
+@dirrm share/openxpki/templates/default
+@dirrm share/openxpki/templates
+@dirrm share/openxpki