aboutsummaryrefslogtreecommitdiff
path: root/security/pam-pgsql/Makefile
diff options
context:
space:
mode:
authorMikhail Teterin <mi@FreeBSD.org>2001-02-26 23:09:21 +0000
committerMikhail Teterin <mi@FreeBSD.org>2001-02-26 23:09:21 +0000
commit6b65c45f49ea31cbc77b634cd2c400d754ea444f (patch)
tree32eca49f7480331c98df57d09af01e3b4002d81d /security/pam-pgsql/Makefile
parent0b5608f2dfbd71a8f878a2d0fd968189ce960d13 (diff)
Notes
Diffstat (limited to 'security/pam-pgsql/Makefile')
-rw-r--r--security/pam-pgsql/Makefile40
1 files changed, 40 insertions, 0 deletions
diff --git a/security/pam-pgsql/Makefile b/security/pam-pgsql/Makefile
new file mode 100644
index 000000000000..3f9f9e040729
--- /dev/null
+++ b/security/pam-pgsql/Makefile
@@ -0,0 +1,40 @@
+# New ports collection makefile for: pam-pgsql
+# Date created: Nov 16, 2000
+# Whom: Mikhail Teterin <mi@aldan.algebra.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= pam-pgsql
+PORTVERSION= 0.3
+CATEGORIES= security databases
+# When the family of Debian mirrors is added to bsd.port.mk,
+# this will suddenly start making sense:
+MASTER_SITES= http://ftp.debian.org/debian/${MASTER_SITE_SUBDIR}/ \
+ ftp://ftp.bora.net/pub/linux/debian/${MASTER_SITE_SUBDIR}/ \
+ ${MASTER_SITE_DEBIAN}
+MASTER_SITE_SUBDIR= dists/woody/main/source/admin
+DISTFILES= ${PORTNAME}_${PORTVERSION}${EXTRACT_SUFX}
+
+MAINTAINER= mi@aldan.algebra.com
+
+LIB_DEPENDS= pq:${PORTSDIR}/databases/postgresql7
+
+MAKEFILE= ${FILESDIR}/Makefile.bsd
+MAKE_ARGS+= -j 2
+
+post-install:
+ ${CAT} ${PKGMESSAGE}
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${DOCDIR}
+ @${INSTALL_DATA} ${WRKSRC}/README ${WRKSRC}/debian/changelog \
+ ${WRKSRC}/debian/copyright ${DOCDIR}
+
+PLIST_SUB+= DOC=''
+DOCDIR= ${LOCALBASE}/share/doc/pam-pgsql
+
+.else
+PLIST_SUB+= DOC='@comment '
+.endif
+
+.include <bsd.port.mk>