aboutsummaryrefslogtreecommitdiff
path: root/security/pam_bsdbioapi
diff options
context:
space:
mode:
authorBaptiste Daroussin <bapt@FreeBSD.org>2013-04-28 21:02:39 +0000
committerBaptiste Daroussin <bapt@FreeBSD.org>2013-04-28 21:02:39 +0000
commit0b881b0ecebc9440a559f1c2b27758488a1188fa (patch)
tree933fd11da647dda8c169bc24693094174bdc0355 /security/pam_bsdbioapi
parent928d434bd206738b7213dd9b5802c680794a9b10 (diff)
downloadports-0b881b0ecebc9440a559f1c2b27758488a1188fa.tar.gz
ports-0b881b0ecebc9440a559f1c2b27758488a1188fa.zip
Notes
Diffstat (limited to 'security/pam_bsdbioapi')
-rw-r--r--security/pam_bsdbioapi/Makefile19
1 files changed, 8 insertions, 11 deletions
diff --git a/security/pam_bsdbioapi/Makefile b/security/pam_bsdbioapi/Makefile
index f2013f61c480..840ca6ce8bed 100644
--- a/security/pam_bsdbioapi/Makefile
+++ b/security/pam_bsdbioapi/Makefile
@@ -1,9 +1,5 @@
-# Ports collection makefile for: pam_bsdbioapi
-# Date created: 13 January 2006
-# Whom: Fredrik Lindberg <fli@shapeshifter.se>
-#
+# Created by: Fredrik Lindberg <fli@shapeshifter.se>
# $FreeBSD$
-#
PORTNAME= pam_bsdbioapi
PORTVERSION= 1.5.1
@@ -21,24 +17,25 @@ MAN8= pam_bsdbioapi.8
MAN3= libbirdb.3
MAN1= bbdm.1
-OPTIONS= FILEDB "Filebacked database backend" on \
- MYSQL "MySQL backend" off \
- PLAIN "Plain ASCII backend" on
+OPTIONS_DEFINE= FILEDB MYSQL PLAIN
+OPTIONS_DEFAULT= FILEDB PLAIN
+FILEDB_DESC= Filebacked database backend
+PLAIN_DESC= Plain ASCII backend
.include <bsd.port.pre.mk>
PLIST_FILES= etc/birdb.conf.sample
BACKENDS=
-.if defined(WITH_FILEDB)
+.if ${PORT_OPTIONS:MFILEDB}
BACKENDS+= filedb
PLIST_FILES+= share/birdb/birdb_filedb.so
.endif
-.if defined(WITH_MYSQL)
+.if ${PORT_OPTIONS:MMYSQL}
USE_MYSQL= yes
BACKENDS+= mysql
PLIST_FILES+= share/birdb/birdb_mysql.so
.endif
-.if defined(WITH_PLAIN)
+.if ${PORT_OPTIONS:MPLAIN}
BACKENDS+= plain
PLIST_FILES+= share/birdb/birdb_plain.so
.endif