aboutsummaryrefslogtreecommitdiff
path: root/security/pam_fprint/Makefile
diff options
context:
space:
mode:
authorSimon Barner <barner@FreeBSD.org>2008-04-15 21:15:09 +0000
committerSimon Barner <barner@FreeBSD.org>2008-04-15 21:15:09 +0000
commitaca903d33450930e5f974fe0aaafd538ee198e16 (patch)
tree430aeec59d010c784a42a31108bb181ff74b9805 /security/pam_fprint/Makefile
parent0d3f3d0c946e6bce28bc3fe068f50a453f649793 (diff)
Notes
Diffstat (limited to 'security/pam_fprint/Makefile')
-rw-r--r--security/pam_fprint/Makefile40
1 files changed, 40 insertions, 0 deletions
diff --git a/security/pam_fprint/Makefile b/security/pam_fprint/Makefile
new file mode 100644
index 000000000000..a6dad668f920
--- /dev/null
+++ b/security/pam_fprint/Makefile
@@ -0,0 +1,40 @@
+# New ports collection makefile for: pam_fprint
+# Date created: April 12 2008
+# Whom: barner
+#
+# $FreeBSD$
+#
+
+PORTNAME= pam_fprint
+PORTVERSION= 0.2
+CATEGORIES= security
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= fprint
+
+MAINTAINER= barner@FreeBSD.org
+COMMENT= PAM module offering finger print authentication using libfprint
+
+LIB_DEPENDS= fprint:${PORTSDIR}/security/libfprint
+
+CONFIGURE_ENV+= FPRINT_CFLAGS=-I${LOCALBASE}/include
+GNU_CONFIGURE= yes
+
+USE_BZIP2= yes
+USE_GNOME= pkgconfig
+
+PLIST_FILES+= bin/pam_fprint_enroll \
+ lib/pam_fprint.so
+
+SUB_FILES= pkg-message
+PKGMESSAGE= ${WRKDIR}/pkg-message
+
+post-install:
+ @${ECHO}
+ @${ECHO} =========================================================================
+ @${ECHO}
+ @${CAT} ${PKGMESSAGE}
+ @${ECHO}
+ @${ECHO} =========================================================================
+ @${ECHO}
+
+.include <bsd.port.mk>