aboutsummaryrefslogtreecommitdiff
path: root/security/pam_krb5-rh/Makefile
diff options
context:
space:
mode:
authorRyan Steinmetz <zi@FreeBSD.org>2012-12-15 03:35:59 +0000
committerRyan Steinmetz <zi@FreeBSD.org>2012-12-15 03:35:59 +0000
commitee3da01aeb606f4eea605299a41df19922524200 (patch)
tree755319b9f3a3289ab7443c97d1840f37205d9583 /security/pam_krb5-rh/Makefile
parent3bc981f862daf26eea9576f10292d9b8acb415b9 (diff)
Notes
Diffstat (limited to 'security/pam_krb5-rh/Makefile')
-rw-r--r--security/pam_krb5-rh/Makefile14
1 files changed, 10 insertions, 4 deletions
diff --git a/security/pam_krb5-rh/Makefile b/security/pam_krb5-rh/Makefile
index 4d6d0b65e3b9..257f42465136 100644
--- a/security/pam_krb5-rh/Makefile
+++ b/security/pam_krb5-rh/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= pam_krb5
-DISTVERSION= 2.3.13-1
+DISTVERSION= 2.4.1
CATEGORIES= security
MASTER_SITES= https://fedorahosted.org/released/${PORTNAME}/ \
http://mirrors.rit.edu/zi/
@@ -25,10 +25,10 @@ GNU_CONFIGURE= yes
CONFIGURE_ARGS+=--with-libiconv-prefix=${LOCALBASE} --without-afs \
--with-libintl-prefix=${LOCALBASE} --with-krb4=no \
--without-keyutils
-LDFLAGS= -L${LOCALBASE}/lib
+LDFLAGS+= -L${LOCALBASE}/lib
MAN5= pam_krb5.5
-MAN8= pam_krb5.8 pam_krb5_storetmp.8
+MAN8= pam_krb5.8 pam_krb5_cchelper.8
.if defined(WITHOUT_NLS)
PLIST_SUB+= NLS="@comment "
@@ -39,6 +39,12 @@ LDFLAGS+= -lintl
USE_GETTEXT= yes
.endif
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} < 800000
+BROKEN= does not build on FreeBSD 7.x
+.endif
+
post-patch:
@${REINPLACE_CMD} -e 's|libdir)/security|libdir)|g' ${WRKSRC}/src/Makefile.in
@${REINPLACE_CMD} -e 's|/lib64/security|${LOCALBASE}/lib|g' \
@@ -48,4 +54,4 @@ post-patch:
@${REINPLACE_CMD} -e 's|PAM_AUTHTOK_RECOVER_ERR|PAM_AUTHTOK_RECOVERY_ERR|g' \
${WRKSRC}/src/password.c
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>