aboutsummaryrefslogtreecommitdiff
path: root/security/pam_krb5
diff options
context:
space:
mode:
authorCy Schubert <cy@FreeBSD.org>2014-06-27 05:49:31 +0000
committerCy Schubert <cy@FreeBSD.org>2014-06-27 05:49:31 +0000
commit7a7383a8e59952f1dcad05cbae4e3cb1959f5bb7 (patch)
treefe65487abd6a33383fd474b76beb2455debc184f /security/pam_krb5
parent83e7f765ee8081e4c7fa055d9c2046ed10f0fc27 (diff)
downloadports-7a7383a8e59952f1dcad05cbae4e3cb1959f5bb7.tar.gz
ports-7a7383a8e59952f1dcad05cbae4e3cb1959f5bb7.zip
Notes
Diffstat (limited to 'security/pam_krb5')
-rw-r--r--security/pam_krb5/Makefile15
1 files changed, 11 insertions, 4 deletions
diff --git a/security/pam_krb5/Makefile b/security/pam_krb5/Makefile
index ba4cba866f1d..92c2cad58829 100644
--- a/security/pam_krb5/Makefile
+++ b/security/pam_krb5/Makefile
@@ -16,11 +16,19 @@ CONFLICTS= pam_krb5-rh-2.*
USES= perl5 gmake
GNU_CONFIGURE= yes
-.if defined(KRB5_IMPL) && ${KRB5_IMPL} == heimdal
+OPTIONS_SINGLE= LINK
+OPTIONS_SINGLE_LINK= MIT HEIMDAL
+OPTIONS_DEFAULT= MIT
+MIT_DESC= Link against MIT Kerberos
+HEIMDAL_DESC= Link against Heimdal Kerberos
+
+.include <bsd.port.pre.mk>
+
+.if ${PORT_OPTIONS:MHEIMDAL}
.if defined(HEIMDAL_HOME)
KRB5_DIR?= ${HEIMDAL_HOME}
.endif
-.elif defined(KRB5_IMPL) && ${KRB5_IMPL} == mit
+.elif ${PORT_OPTIONS:MMIT}
LIB_DEPENDS= libkrb5.so:${PORTSDIR}/security/krb5
.if defined(KRB5_HOME)
KRB5_DIR?= ${KRB5_HOME}
@@ -30,11 +38,10 @@ IGNORE= you must define KRB5_IMPL to be "mit" or "heimdal"
.endif
MANDIR= ${STAGEDIR}${MANPREFIX}/man
-MANDIR= ${STAGEDIR}${PREFIX}/share/man
KRB5_DIR?= ${LOCALBASE}
CONFIGURE_ARGS= --with-krb5="${KRB5_DIR}"
post-install:
cd ${WRKSRC} && ${MAKE_CMD} install-man DESTDIR=${STAGEDIR}
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>