aboutsummaryrefslogtreecommitdiff
path: root/security/pam_ldap/Makefile
diff options
context:
space:
mode:
authorPete Fritchman <petef@FreeBSD.org>2002-03-29 07:46:57 +0000
committerPete Fritchman <petef@FreeBSD.org>2002-03-29 07:46:57 +0000
commit55726ef2895c615ed75be3906c90385dbe8d3970 (patch)
tree3d47db9e9e4ab53d65842d7c650af26fe422e339 /security/pam_ldap/Makefile
parent04214af6c3314007319fad3e88c56768561951f8 (diff)
downloadports-55726ef2895c615ed75be3906c90385dbe8d3970.tar.gz
ports-55726ef2895c615ed75be3906c90385dbe8d3970.zip
Notes
Diffstat (limited to 'security/pam_ldap/Makefile')
-rw-r--r--security/pam_ldap/Makefile10
1 files changed, 8 insertions, 2 deletions
diff --git a/security/pam_ldap/Makefile b/security/pam_ldap/Makefile
index 5b5afd097829..4be9a62109e1 100644
--- a/security/pam_ldap/Makefile
+++ b/security/pam_ldap/Makefile
@@ -14,6 +14,12 @@ DISTNAME= pam_ldap-${PORTVERSION:S/.//g}
MAINTAINER= marcus@marcuscom.com
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} > 500030
+BROKEN= "Does not work correctly with OpenPAM"
+.endif
+
.if defined(WITH_LDAP_V3)
LIB_DEPENDS= ldap.2:${PORTSDIR}/net/openldap2 \
lber.2:${PORTSDIR}/net/openldap2
@@ -34,7 +40,7 @@ USE_GMAKE= yes
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION:S/.//g}
post-extract:
- @find ${WRKSRC} -type f | xargs touch -f
+ @find ${WRKSRC} -type f | xargs ${TOUCH} -f
post-install:
@${ECHO} "================================================================================"
@@ -46,4 +52,4 @@ post-install:
@${ECHO} "login auth sufficient ${PREFIX}/lib/pam_ldap.so"
@${ECHO} "================================================================================"
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>