aboutsummaryrefslogtreecommitdiff
path: root/security/pam_ldap
diff options
context:
space:
mode:
authorJoe Marcus Clarke <marcus@FreeBSD.org>2010-01-10 23:39:04 +0000
committerJoe Marcus Clarke <marcus@FreeBSD.org>2010-01-10 23:39:04 +0000
commit8c9eae59d5e24920dc543027c795c5a7dbb4d00b (patch)
treeb68a9f121ce524c7b38adeb23683b8377828864e /security/pam_ldap
parentbbf76ee42361b8e542b5782965e637dae6aa6920 (diff)
downloadports-8c9eae59d5e24920dc543027c795c5a7dbb4d00b.tar.gz
ports-8c9eae59d5e24920dc543027c795c5a7dbb4d00b.zip
Notes
Diffstat (limited to 'security/pam_ldap')
-rw-r--r--security/pam_ldap/Makefile6
-rw-r--r--security/pam_ldap/distinfo6
-rw-r--r--security/pam_ldap/files/patch-aa20
3 files changed, 20 insertions, 12 deletions
diff --git a/security/pam_ldap/Makefile b/security/pam_ldap/Makefile
index 123f03fab9bd..a252694575c2 100644
--- a/security/pam_ldap/Makefile
+++ b/security/pam_ldap/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= pam_ldap
-PORTVERSION= 1.8.4
-PORTREVISION= 1
+PORTVERSION= 1.8.5
CATEGORIES= security net
MASTER_SITES= http://www.padl.com/download/ \
ftp://ftp.padl.com/pub/
@@ -20,9 +19,10 @@ USE_GMAKE= yes
GNU_CONFIGURE= yes
USE_OPENLDAP= yes
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION:S/.//g}
+PAM_LDAP_CONF?= ldap.conf
CONFIGURE_ARGS= --with-ldap-lib=openldap \
--with-ldap-dir=${LOCALBASE} \
- --with-ldap-conf-file=${PREFIX}/etc/ldap.conf \
+ --with-ldap-conf-file=${PREFIX}/etc/${PAM_LDAP_CONF} \
--with-ldap-secret-file=${PREFIX}/etc/ldap.secret
PKGMESSAGE= ${WRKDIR}/pkg-message
diff --git a/security/pam_ldap/distinfo b/security/pam_ldap/distinfo
index 191ef3da1bbb..39de7c20fe31 100644
--- a/security/pam_ldap/distinfo
+++ b/security/pam_ldap/distinfo
@@ -1,3 +1,3 @@
-MD5 (pam_ldap-184.tar.gz) = 1b381b5f1ce67fe0a885d9a7c69b93af
-SHA256 (pam_ldap-184.tar.gz) = 2dd4df6bfddd80580af599dbfb631f907d796df478c22949af4552eaf750c6f3
-SIZE (pam_ldap-184.tar.gz) = 128053
+MD5 (pam_ldap-185.tar.gz) = 639260f0c81d57a6fcbd1cb47dd6c5e7
+SHA256 (pam_ldap-185.tar.gz) = 5f4dfca68d33e4a99a17da9632c6abb782c9af8bcbc4953e4d2c40e2e5b32304
+SIZE (pam_ldap-185.tar.gz) = 163467
diff --git a/security/pam_ldap/files/patch-aa b/security/pam_ldap/files/patch-aa
index ce0f1a5b5452..7deee3ff34a0 100644
--- a/security/pam_ldap/files/patch-aa
+++ b/security/pam_ldap/files/patch-aa
@@ -1,14 +1,14 @@
---- Makefile.in.orig Sat Aug 20 18:44:27 2005
-+++ Makefile.in Sat Aug 20 18:45:57 2005
-@@ -434,17 +434,13 @@
+--- Makefile.in.orig 2010-01-08 12:09:42.124679000 +0000
++++ Makefile.in 2010-01-08 12:16:10.000000000 +0000
+@@ -594,24 +594,20 @@
install-exec-local: pam_ldap.so
@$(NORMAL_INSTALL)
- $(mkinstalldirs) $(DESTDIR)$(libdir)/security
-@EXTENSION_SO_TRUE@ $(INSTALL_PROGRAM) -o root -g root pam_ldap.so $(DESTDIR)$(libdir)/security/pam_ldap.so
--@EXTENSION_SO_FALSE@@EXTENSION_1_TRUE@ $(INSTALL_PROGRAM) -o root -g root pam_ldap.so $(DESTDIR)$(libdir)/security/libpam_ldap.1
--@EXTENSION_SO_FALSE@@EXTENSION_1_FALSE@ $(INSTALL_PROGRAM) -o root -g root pam_ldap.so $(DESTDIR)$(libdir)/security/pam_ldap.so.1
--@EXTENSION_SO_FALSE@@EXTENSION_1_FALSE@ (cd $(DESTDIR)$(libdir)/security; rm -f pam_ldap.so; ln -s pam_ldap.so.1 pam_ldap.so)
+-@EXTENSION_1_TRUE@@EXTENSION_SO_FALSE@ $(INSTALL_PROGRAM) -o root -g root pam_ldap.so $(DESTDIR)$(libdir)/security/libpam_ldap.1
+-@EXTENSION_1_FALSE@@EXTENSION_SO_FALSE@ $(INSTALL_PROGRAM) -o root -g root pam_ldap.so $(DESTDIR)$(libdir)/security/pam_ldap.so.1
+-@EXTENSION_1_FALSE@@EXTENSION_SO_FALSE@ (cd $(DESTDIR)$(libdir)/security; rm -f pam_ldap.so; ln -s pam_ldap.so.1 pam_ldap.so)
+ $(INSTALL_PROGRAM) -o root -g wheel pam_ldap.so $(DESTDIR)$(libdir)/pam_ldap.so
install-data-local:
@@ -21,3 +21,11 @@
fi
uninstall-local:
+ @$(NORMAL_UNINSTALL)
+
+ vers.c: $(top_srcdir)/CVSVersionInfo.txt
+- CVSVERSIONDIR=$(top_srcdir) vers_string -v
++ CVSVERSIONDIR=$(top_srcdir) $(top_srcdir)/vers_string -v
+ # Tell versions [3.59,3.63) of GNU make to not export all variables.
+ # Otherwise a system limit (for SysV at least) may be exceeded.
+ .NOEXPORT: