aboutsummaryrefslogtreecommitdiff
path: root/security/pam_ldap
diff options
context:
space:
mode:
authorJoe Marcus Clarke <marcus@FreeBSD.org>2010-12-17 19:39:41 +0000
committerJoe Marcus Clarke <marcus@FreeBSD.org>2010-12-17 19:39:41 +0000
commit1f40097037192a9d48783e40044693260c207344 (patch)
tree2422aee946cc350ed8a6820bfd395ce4c1405302 /security/pam_ldap
parentdbcdee59a1ba28daf602941a220da49fb94492fc (diff)
Notes
Diffstat (limited to 'security/pam_ldap')
-rw-r--r--security/pam_ldap/Makefile2
-rw-r--r--security/pam_ldap/distinfo5
-rw-r--r--security/pam_ldap/files/patch-aa14
-rw-r--r--security/pam_ldap/files/patch-ab94
4 files changed, 13 insertions, 102 deletions
diff --git a/security/pam_ldap/Makefile b/security/pam_ldap/Makefile
index eb0a054b9963..8c176108d84f 100644
--- a/security/pam_ldap/Makefile
+++ b/security/pam_ldap/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= pam_ldap
-PORTVERSION= 1.8.5
+PORTVERSION= 1.8.6
CATEGORIES= security net
MASTER_SITES= http://www.padl.com/download/ \
ftp://ftp.padl.com/pub/
diff --git a/security/pam_ldap/distinfo b/security/pam_ldap/distinfo
index 39de7c20fe31..b2617907712b 100644
--- a/security/pam_ldap/distinfo
+++ b/security/pam_ldap/distinfo
@@ -1,3 +1,2 @@
-MD5 (pam_ldap-185.tar.gz) = 639260f0c81d57a6fcbd1cb47dd6c5e7
-SHA256 (pam_ldap-185.tar.gz) = 5f4dfca68d33e4a99a17da9632c6abb782c9af8bcbc4953e4d2c40e2e5b32304
-SIZE (pam_ldap-185.tar.gz) = 163467
+SHA256 (pam_ldap-186.tar.gz) = c8fe22d559d5a3f528b24eb97175085f188c0f11ade337a868590ac0e0716453
+SIZE (pam_ldap-186.tar.gz) = 163437
diff --git a/security/pam_ldap/files/patch-aa b/security/pam_ldap/files/patch-aa
index 7deee3ff34a0..3b54f9d9549b 100644
--- a/security/pam_ldap/files/patch-aa
+++ b/security/pam_ldap/files/patch-aa
@@ -1,6 +1,6 @@
---- Makefile.in.orig 2010-01-08 12:09:42.124679000 +0000
-+++ Makefile.in 2010-01-08 12:16:10.000000000 +0000
-@@ -594,24 +594,20 @@
+--- Makefile.in.orig 2010-12-17 14:34:23.708132000 -0500
++++ Makefile.in 2010-12-17 14:35:48.000000000 -0500
+@@ -594,17 +594,13 @@ uninstall-man: uninstall-man5
install-exec-local: pam_ldap.so
@$(NORMAL_INSTALL)
@@ -21,11 +21,3 @@
fi
uninstall-local:
- @$(NORMAL_UNINSTALL)
-
- vers.c: $(top_srcdir)/CVSVersionInfo.txt
-- CVSVERSIONDIR=$(top_srcdir) vers_string -v
-+ CVSVERSIONDIR=$(top_srcdir) $(top_srcdir)/vers_string -v
- # Tell versions [3.59,3.63) of GNU make to not export all variables.
- # Otherwise a system limit (for SysV at least) may be exceeded.
- .NOEXPORT:
diff --git a/security/pam_ldap/files/patch-ab b/security/pam_ldap/files/patch-ab
index 637a129cb1cc..eeb031a603c4 100644
--- a/security/pam_ldap/files/patch-ab
+++ b/security/pam_ldap/files/patch-ab
@@ -1,10 +1,10 @@
---- pam_ldap.c.orig Sun Oct 31 02:42:54 2004
-+++ pam_ldap.c Sun Oct 31 02:48:03 2004
+--- pam_ldap.c.orig 2010-12-17 14:36:11.105528000 -0500
++++ pam_ldap.c 2010-12-17 14:38:42.000000000 -0500
@@ -131,12 +131,7 @@
#include "pam_ldap.h"
#include "md5.h"
--#if defined(HAVE_SECURITY_PAM_MISC_H) || defined(HAVE_PAM_PAM_MISC_H)
+-#if defined(HAVE_SECURITY_PAM_MISC_H) || defined(HAVE_PAM_PAM_MISC_H) || defined(OPENPAM)
- /* FIXME: is there something better to check? */
#define CONST_ARG const
-#else
@@ -13,7 +13,7 @@
#ifndef HAVE_LDAP_MEMFREE
#define ldap_memfree(x) free(x)
-@@ -3137,7 +3132,7 @@
+@@ -3411,7 +3406,7 @@ pam_sm_authenticate (pam_handle_t * pamh
int rc;
const char *username;
char *p;
@@ -22,7 +22,7 @@
int i;
pam_ldap_session_t *session = NULL;
const char *configFile = NULL;
-@@ -3158,6 +3153,8 @@
+@@ -3432,6 +3427,8 @@ pam_sm_authenticate (pam_handle_t * pamh
;
else if (!strcmp (argv[i], "debug"))
;
@@ -31,7 +31,7 @@
else
syslog (LOG_ERR, "illegal option %s", argv[i]);
}
-@@ -3171,6 +3168,22 @@
+@@ -3445,6 +3442,22 @@ pam_sm_authenticate (pam_handle_t * pamh
return rc;
rc = pam_get_item (pamh, PAM_AUTHTOK, (CONST_ARG void **) &p);
@@ -54,23 +54,7 @@
if (rc == PAM_SUCCESS && (use_first_pass || try_first_pass))
{
rc = _do_authentication (pamh, session, username, p);
-@@ -3419,11 +3432,11 @@
- {
- _conv_sendmsg (appconv, "Password change aborted",
- PAM_ERROR_MSG, no_warn);
--#ifdef PAM_AUTHTOK_RECOVERY_ERR
-- return PAM_AUTHTOK_RECOVERY_ERR;
--#else
-+#ifdef PAM_AUTHTOK_RECOVER_ERR
- return PAM_AUTHTOK_RECOVER_ERR;
--#endif /* PAM_AUTHTOK_RECOVERY_ERR */
-+#else
-+ return PAM_AUTHTOK_RECOVERY_ERR;
-+#endif
- }
- else
- {
-@@ -3437,7 +3450,7 @@
+@@ -3721,7 +3734,7 @@ pam_sm_chauthtok (pam_handle_t * pamh, i
if (curpass == NULL)
return PAM_MAXTRIES; /* maximum tries exceeded */
else
@@ -79,67 +63,3 @@
}
else
{
-@@ -3465,11 +3478,11 @@
- syslog (LOG_ERR,
- "pam_ldap: error getting old authentication token (%s)",
- pam_strerror (pamh, rc));
--#ifdef PAM_AUTHTOK_RECOVERY_ERR
-- return PAM_AUTHTOK_RECOVERY_ERR;
--#else
-+#ifdef PAM_AUTHTOK_RECOVER_ERR
- return PAM_AUTHTOK_RECOVER_ERR;
--#endif /* PAM_AUTHTOK_RECOVERY_ERR */
-+#else
-+ return PAM_AUTHTOK_RECOVERY_ERR;
-+#endif /* PAM_AUTHTOK_RECOVER_ERR */
- }
-
- if (try_first_pass || use_first_pass)
-@@ -3479,11 +3492,11 @@
- newpass = NULL;
-
- if (use_first_pass && newpass == NULL)
--#ifdef PAM_AUTHTOK_RECOVERY_ERR
-- return PAM_AUTHTOK_RECOVERY_ERR;
--#else
-+#ifdef PAM_AUTHTOK_RECOVER_ERR
- return PAM_AUTHTOK_RECOVER_ERR;
--#endif /* PAM_AUTHTOK_RECOVERY_ERR */
-+#else
-+ return PAM_AUTHTOK_RECOVERY_ERR;
-+#endif /* PAM_AUTHTOK_RECOVER_ERR */
- }
-
- tries = 0;
-@@ -3533,11 +3546,11 @@
- }
- else
- {
--#ifdef PAM_AUTHTOK_RECOVERY_ERR
-- return PAM_AUTHTOK_RECOVERY_ERR;
--#else
-+#ifdef PAM_AUTHTOK_RECOVER_ERR
- return PAM_AUTHTOK_RECOVER_ERR;
--#endif /* PAM_AUTHTOK_RECOVERY_ERR */
-+#else
-+ return PAM_AUTHTOK_RECOVERY_ERR;
-+#endif /* PAM_AUTHTOK_RECOVER_ERR */
- }
-
- if (cmiscptr == NULL)
-@@ -3569,11 +3582,11 @@
- {
- _conv_sendmsg (appconv, "Password change aborted",
- PAM_ERROR_MSG, no_warn);
--#ifdef PAM_AUTHTOK_RECOVERY_ERR
-- return PAM_AUTHTOK_RECOVERY_ERR;
--#else
-+#ifdef PAM_AUTHTOK_RECOVER_ERR
- return PAM_AUTHTOK_RECOVER_ERR;
--#endif /* PAM_AUTHTOK_RECOVERY_ERR */
-+#else
-+ return PAM_AUTHTOK_RECOVERY_ERR;
-+#endif /* PAM_AUTHTOK_RECOVER_ERR */
- }
- }
- else if (!strcmp (newpass, miscptr))