aboutsummaryrefslogtreecommitdiff
path: root/security/pam_p11/Makefile
diff options
context:
space:
mode:
authorAlex Dupre <ale@FreeBSD.org>2006-06-12 17:00:25 +0000
committerAlex Dupre <ale@FreeBSD.org>2006-06-12 17:00:25 +0000
commitacf7714db05f3204313d93cda1f633ee3753fe02 (patch)
treeb2514de05b74f6bb32e2e0e0a9de5c446393e606 /security/pam_p11/Makefile
parenta8e121cb3c7c2dbd6b7b27c116df00166f546fb4 (diff)
Notes
Diffstat (limited to 'security/pam_p11/Makefile')
-rw-r--r--security/pam_p11/Makefile35
1 files changed, 35 insertions, 0 deletions
diff --git a/security/pam_p11/Makefile b/security/pam_p11/Makefile
new file mode 100644
index 000000000000..d1b1bed63e0b
--- /dev/null
+++ b/security/pam_p11/Makefile
@@ -0,0 +1,35 @@
+# New ports collection makefile for: pam_p11
+# Date created: 1 Jun 2006
+# Whom: Alex Dupre <ale@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= pam_p11
+PORTVERSION= 0.1.2
+CATEGORIES= security
+MASTER_SITES= http://www.opensc-project.org/files/${PORTNAME}/
+
+MAINTAINER= ale@FreeBSD.org
+COMMENT= A PAM module using crypto tokens for auth
+
+LIB_DEPENDS= p11.1:${PORTSDIR}/security/libp11
+
+USE_OPENSSL= yes
+GNU_CONFIGURE= yes
+USE_GNOME= pkgconfig
+
+CONFIGURE_ENV= OPENSSL_CFLAGS="-I${OPENSSLINC}" \
+ OPENSSL_LIBS="-L${OPENSSLLIB} -lssl"
+
+DOC_FILES= README *.sh *.xsl *.css *.html
+
+PORTDOCS= *
+
+.ifndef(NOPORTDOCS)
+post-install:
+ @${MKDIR} ${DOCSDIR}
+ @(cd ${WRKSRC}/doc && ${CP} -R ${DOC_FILES} ${DOCSDIR})
+.endif
+
+.include <bsd.port.mk>