aboutsummaryrefslogtreecommitdiff
path: root/security/pam_pop3
diff options
context:
space:
mode:
authorYing-Chieh Liao <ijliao@FreeBSD.org>2002-07-15 16:48:37 +0000
committerYing-Chieh Liao <ijliao@FreeBSD.org>2002-07-15 16:48:37 +0000
commitdfc45f443213b16076e40937d952c74be1a0cb7a (patch)
tree860825f5cdd582584a07514fbbabbe9b56bfdfc0 /security/pam_pop3
parent10e00cf91e8a1e6b0d2a77b2a46e5150b1a4225f (diff)
downloadports-dfc45f443213b16076e40937d952c74be1a0cb7a.tar.gz
ports-dfc45f443213b16076e40937d952c74be1a0cb7a.zip
Notes
Diffstat (limited to 'security/pam_pop3')
-rw-r--r--security/pam_pop3/Makefile28
-rw-r--r--security/pam_pop3/distinfo1
-rw-r--r--security/pam_pop3/files/patch-pam_pop3.c37
-rw-r--r--security/pam_pop3/pkg-comment1
-rw-r--r--security/pam_pop3/pkg-descr6
-rw-r--r--security/pam_pop3/pkg-plist3
6 files changed, 76 insertions, 0 deletions
diff --git a/security/pam_pop3/Makefile b/security/pam_pop3/Makefile
new file mode 100644
index 000000000000..8b8ac0cb876f
--- /dev/null
+++ b/security/pam_pop3/Makefile
@@ -0,0 +1,28 @@
+# New ports collection makefile for: pam_pop3
+# Date created: 16 July 2002
+# Whom: Gea-Suan Lin <gslin@ccca.nctu.edu.tw>
+#
+# $FreeBSD$
+#
+
+PORTNAME= pam_pop3
+PORTVERSION= 1.0
+CATEGORIES= security
+MASTER_SITES= http://shum.huji.ac.il/~schapiro/linux/pam_pop3/
+
+MAINTAINER= gslin@ccca.nctu.edu.tw
+
+WRKSRC= ${WRKDIR}/${PORTNAME}
+
+do-build:
+ ${CC} ${CFLAGS} -DPIC -Wall -c ${WRKSRC}/pam_pop3.c -o ${WRKSRC}/pam_pop3.o
+ ${LD} -x --shared -o ${WRKSRC}/pam_pop3.so ${WRKSRC}/pam_pop3.o -lpam -lcrypt
+
+do-install:
+ @${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME}.so ${PREFIX}/lib
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/README ${DOCSDIR}
+.endif
+
+.include <bsd.port.mk>
diff --git a/security/pam_pop3/distinfo b/security/pam_pop3/distinfo
new file mode 100644
index 000000000000..678d4ab81b4d
--- /dev/null
+++ b/security/pam_pop3/distinfo
@@ -0,0 +1 @@
+MD5 (pam_pop3-1.0.tar.gz) = e9bfebe349f79e308ff8d329e5b25f91
diff --git a/security/pam_pop3/files/patch-pam_pop3.c b/security/pam_pop3/files/patch-pam_pop3.c
new file mode 100644
index 000000000000..6eff9e2bf73c
--- /dev/null
+++ b/security/pam_pop3/files/patch-pam_pop3.c
@@ -0,0 +1,37 @@
+--- pam_pop3.c.orig Tue Jul 16 00:14:29 2002
++++ pam_pop3.c Tue Jul 16 00:16:38 2002
+@@ -21,6 +21,7 @@
+ #include <errno.h>
+ #include <netdb.h>
+ #include <sys/types.h>
++#include <sys/time.h>
+ #include <netinet/in.h>
+ #include <sys/socket.h>
+
+@@ -85,7 +86,7 @@
+ close(sockfd);
+ return -1;
+ }
+- if ((numbytes=recv(sockfd,buf,BUFLEN-1,MSG_NOSIGNAL))<=0)
++ if ((numbytes=recv(sockfd,buf,BUFLEN-1,0))<=0)
+ {
+ if (numbytes==0)
+ /* other side closed connection */
+@@ -138,7 +139,7 @@
+ close(sockfd);
+ return -1;
+ }
+- if ((numbytes=send(sockfd,buf,strlen(buf),MSG_NOSIGNAL))<strlen(buf))
++ if ((numbytes=send(sockfd,buf,strlen(buf),0))<strlen(buf))
+ {
+ /* it did not send everything, try once more and then fail */
+ if (numbytes>0)
+@@ -153,7 +154,7 @@
+ return -1;
+ }
+ /* send remaining bytes */
+- numbytes+=send(sockfd,buf+numbytes,strlen(buf)-numbytes,MSG_NOSIGNAL);
++ numbytes+=send(sockfd,buf+numbytes,strlen(buf)-numbytes,0);
+ }
+ if (numbytes!=strlen(buf))
+ {
diff --git a/security/pam_pop3/pkg-comment b/security/pam_pop3/pkg-comment
new file mode 100644
index 000000000000..ddfed0da4a5a
--- /dev/null
+++ b/security/pam_pop3/pkg-comment
@@ -0,0 +1 @@
+This module authenticates a user against a POP3 server
diff --git a/security/pam_pop3/pkg-descr b/security/pam_pop3/pkg-descr
new file mode 100644
index 000000000000..9ffa70f21d9a
--- /dev/null
+++ b/security/pam_pop3/pkg-descr
@@ -0,0 +1,6 @@
+pam_pop3 by Schlomo Schapiro (schapiro@huji.ac.il)
+
+This module authenticates a user against a POP3 server.
+It supplies only the AUTH functions.
+
+WWW: http://shum.huji.ac.il/~schapiro/linux/
diff --git a/security/pam_pop3/pkg-plist b/security/pam_pop3/pkg-plist
new file mode 100644
index 000000000000..f84e6e016a45
--- /dev/null
+++ b/security/pam_pop3/pkg-plist
@@ -0,0 +1,3 @@
+lib/pam_pop3.so
+%%PORTDOCS%%share/doc/pam_pop3/README
+%%PORTDOCS%%@dirrm share/doc/pam_pop3