aboutsummaryrefslogtreecommitdiff
path: root/security/pam_require
diff options
context:
space:
mode:
authorSergey Matveychuk <sem@FreeBSD.org>2006-05-24 18:04:24 +0000
committerSergey Matveychuk <sem@FreeBSD.org>2006-05-24 18:04:24 +0000
commit6bbfcfd62b2e92e254d571ff53e6ade0b78e701d (patch)
treee377daf75f28d3ad050cf9c9c9a849e9d5245143 /security/pam_require
parent4def7d3133968e993df4aefc54972d157cdc7763 (diff)
downloadports-6bbfcfd62b2e92e254d571ff53e6ade0b78e701d.tar.gz
ports-6bbfcfd62b2e92e254d571ff53e6ade0b78e701d.zip
Notes
Diffstat (limited to 'security/pam_require')
-rw-r--r--security/pam_require/Makefile23
-rw-r--r--security/pam_require/distinfo3
-rw-r--r--security/pam_require/files/patch-Makefile.in20
-rw-r--r--security/pam_require/files/patch-pam_require.c12
-rw-r--r--security/pam_require/pkg-descr4
5 files changed, 62 insertions, 0 deletions
diff --git a/security/pam_require/Makefile b/security/pam_require/Makefile
new file mode 100644
index 000000000000..7274c6ee62f2
--- /dev/null
+++ b/security/pam_require/Makefile
@@ -0,0 +1,23 @@
+# New ports collection makefile for: pam_require
+# Date created: 30 March 2006
+# Whom: Chris Cowart <ccowart@rescomp.berkeley.edu>
+#
+# $FreeBSD$
+#
+
+PORTNAME= pam_require
+PORTVERSION= 0.6
+CATEGORIES= security
+MASTER_SITES= http://www.splitbrain.org/_media/projects/pamrequire/
+EXTRACT_SUFX= .tgz
+
+MAINTAINER= ccowart@rescomp.berkeley.edu
+COMMENT= A PAM module for restricting access based on unix group or username
+
+USE_GMAKE= yes
+GNU_CONFIGURE= yes
+CONFIGURE_ARGS= --prefix=${PREFIX}
+
+PLIST_FILES= lib/pam_require.so lib/pam_require.so.1
+
+.include <bsd.port.mk>
diff --git a/security/pam_require/distinfo b/security/pam_require/distinfo
new file mode 100644
index 000000000000..549516e6d403
--- /dev/null
+++ b/security/pam_require/distinfo
@@ -0,0 +1,3 @@
+MD5 (pam_require-0.6.tgz) = e18e3aeebf9dc32efcd1ea0925a13443
+SHA256 (pam_require-0.6.tgz) = 845108a7dc4601bbebec52cd3911db52903e20d9f54c3a809881dd77e5e5f191
+SIZE (pam_require-0.6.tgz) = 82695
diff --git a/security/pam_require/files/patch-Makefile.in b/security/pam_require/files/patch-Makefile.in
new file mode 100644
index 000000000000..a372514510ff
--- /dev/null
+++ b/security/pam_require/files/patch-Makefile.in
@@ -0,0 +1,20 @@
+diff -rub Makefile.in Makefile.in
+--- Makefile.in Wed Sep 22 23:33:17 2004
++++ Makefile.in Thu Mar 30 21:19:07 2006
+@@ -349,11 +349,11 @@
+
+ install-exec-local: pam_require.so
+ @$(NORMAL_INSTALL)
+- $(mkinstalldirs) $(DESTDIR)$(libdir)/security
+-@EXTENSION_SO_TRUE@ $(INSTALL_PROGRAM) -o root -g root pam_require.so $(DESTDIR)$(libdir)/security/pam_require.so
+-@EXTENSION_SO_FALSE@@EXTENSION_1_TRUE@ $(INSTALL_PROGRAM) -o root -g root pam_require.so $(DESTDIR)$(libdir)/security/libpam_require.1
+-@EXTENSION_SO_FALSE@@EXTENSION_1_FALSE@ $(INSTALL_PROGRAM) -o root -g root pam_require.so $(DESTDIR)$(libdir)/security/pam_require.so.1
+-@EXTENSION_SO_FALSE@@EXTENSION_1_FALSE@ (cd $(DESTDIR)$(libdir)/security; rm -f pam_require.so; ln -s pam_require.so.1 pam_require.so)
++ $(mkinstalldirs) $(DESTDIR)$(libdir)
++@EXTENSION_SO_TRUE@ $(INSTALL_PROGRAM) pam_require.so $(DESTDIR)$(libdir)/pam_require.so
++@EXTENSION_SO_FALSE@@EXTENSION_1_TRUE@ $(INSTALL_PROGRAM) pam_require.so $(DESTDIR)$(libdir)/libpam_require.1
++@EXTENSION_SO_FALSE@@EXTENSION_1_FALSE@ $(INSTALL_PROGRAM) pam_require.so $(DESTDIR)$(libdir)/pam_require.so.1
++@EXTENSION_SO_FALSE@@EXTENSION_1_FALSE@ (cd $(DESTDIR)$(libdir); rm -f pam_require.so; ln -s pam_require.so.1 pam_require.so)
+
+ uninstall-local:
+ @$(NORMAL_UNINSTALL)
diff --git a/security/pam_require/files/patch-pam_require.c b/security/pam_require/files/patch-pam_require.c
new file mode 100644
index 000000000000..b031c2517fe1
--- /dev/null
+++ b/security/pam_require/files/patch-pam_require.c
@@ -0,0 +1,12 @@
+diff -rub pam_require.c pam_require.c
+--- pam_require.c Wed Sep 22 23:32:27 2004
++++ pam_require.c Thu Mar 30 21:08:43 2006
+@@ -49,7 +49,7 @@
+ #include <grp.h>
+ #include <pwd.h>
+ #include <unistd.h>
+-#include <malloc.h>
++#include <stdlib.h>
+ #include <stdarg.h>
+
+ /* taken from pam_ldap */
diff --git a/security/pam_require/pkg-descr b/security/pam_require/pkg-descr
new file mode 100644
index 000000000000..ecd3b9e5f3a5
--- /dev/null
+++ b/security/pam_require/pkg-descr
@@ -0,0 +1,4 @@
+A PAM module that allows you to require a special group or
+user to access a service.
+
+WWW: http://www.splitbrain.org/projects/pam_require/