aboutsummaryrefslogtreecommitdiff
path: root/security/pam_ssh_agent_auth
diff options
context:
space:
mode:
authorEmanuel Haupt <ehaupt@FreeBSD.org>2016-12-06 08:00:34 +0000
committerEmanuel Haupt <ehaupt@FreeBSD.org>2016-12-06 08:00:34 +0000
commit4b7c6bd19c27841dda2a1f1272b33297b704e124 (patch)
tree6b834bf356cb1f675ce65ad84d3c954117ac8c60 /security/pam_ssh_agent_auth
parentb1854a6bf73508800f1975283a623cf217901e5e (diff)
Notes
Diffstat (limited to 'security/pam_ssh_agent_auth')
-rw-r--r--security/pam_ssh_agent_auth/Makefile3
-rw-r--r--security/pam_ssh_agent_auth/distinfo5
-rw-r--r--security/pam_ssh_agent_auth/files/patch-Makefile.in8
-rw-r--r--security/pam_ssh_agent_auth/files/patch-pam_user_authorized_keys.c14
4 files changed, 15 insertions, 15 deletions
diff --git a/security/pam_ssh_agent_auth/Makefile b/security/pam_ssh_agent_auth/Makefile
index 5c01b73fb4b4..432aa7815f9a 100644
--- a/security/pam_ssh_agent_auth/Makefile
+++ b/security/pam_ssh_agent_auth/Makefile
@@ -2,8 +2,7 @@
# $FreeBSD$
PORTNAME= pam_ssh_agent_auth
-PORTVERSION= 0.10.2
-PORTREVISION= 1
+PORTVERSION= 0.10.3
CATEGORIES= security
MASTER_SITES= SF/pamsshagentauth/${PORTNAME}/v${PORTVERSION}/
diff --git a/security/pam_ssh_agent_auth/distinfo b/security/pam_ssh_agent_auth/distinfo
index b735e7109161..ec6c578703d7 100644
--- a/security/pam_ssh_agent_auth/distinfo
+++ b/security/pam_ssh_agent_auth/distinfo
@@ -1,2 +1,3 @@
-SHA256 (pam_ssh_agent_auth-0.10.2.tar.bz2) = 99bbbae3494032e17b62ff3b9ff71e2d78e3c6809463649afe7bae79e4f81fcd
-SIZE (pam_ssh_agent_auth-0.10.2.tar.bz2) = 246412
+TIMESTAMP = 1479105140
+SHA256 (pam_ssh_agent_auth-0.10.3.tar.bz2) = 3c53d358d6eaed1b211239df017c27c6f9970995d14102ae67bae16d4f47a763
+SIZE (pam_ssh_agent_auth-0.10.3.tar.bz2) = 1066393
diff --git a/security/pam_ssh_agent_auth/files/patch-Makefile.in b/security/pam_ssh_agent_auth/files/patch-Makefile.in
index 1ed36c400418..bbf130cc40d0 100644
--- a/security/pam_ssh_agent_auth/files/patch-Makefile.in
+++ b/security/pam_ssh_agent_auth/files/patch-Makefile.in
@@ -1,6 +1,6 @@
---- Makefile.in.orig 2009-11-07 03:47:20.000000000 +0100
-+++ Makefile.in 2009-12-26 12:53:16.000000000 +0100
-@@ -13,7 +13,7 @@
+--- Makefile.in.orig 2016-11-13 03:24:32 UTC
++++ Makefile.in
+@@ -37,7 +37,7 @@ libexecdir=@libexecdir@
datadir=@datadir@
datarootdir=@datarootdir@
mandir=@mandir@
@@ -9,7 +9,7 @@
sysconfdir=@sysconfdir@
piddir=@piddir@
srcdir=@srcdir@
-@@ -130,7 +130,7 @@
+@@ -157,7 +157,7 @@ uninstallall: uninstall
uninstall:
-rm -f $(DESTDIR)$(libexecdir)/pam_ssh_agent_auth.so
diff --git a/security/pam_ssh_agent_auth/files/patch-pam_user_authorized_keys.c b/security/pam_ssh_agent_auth/files/patch-pam_user_authorized_keys.c
index 50b976e20687..d1a246094c9d 100644
--- a/security/pam_ssh_agent_auth/files/patch-pam_user_authorized_keys.c
+++ b/security/pam_ssh_agent_auth/files/patch-pam_user_authorized_keys.c
@@ -1,13 +1,13 @@
---- pam_user_authorized_keys.c.orig 2009-11-07 03:47:20.000000000 +0100
-+++ pam_user_authorized_keys.c 2009-12-26 12:49:29.000000000 +0100
-@@ -81,6 +81,10 @@
- extern uint8_t allow_user_owned_authorized_keys_file;
- uid_t authorized_keys_file_allowed_owner_uid;
+--- pam_user_authorized_keys.c.orig 2016-11-13 03:24:32 UTC
++++ pam_user_authorized_keys.c
+@@ -90,6 +90,10 @@ extern uint8_t allow_user_owned_authoriz
+
+ uid_t authorized_keys_file_allowed_owner_uid;
+#ifndef HOST_NAME_MAX
+#define HOST_NAME_MAX MAXHOSTNAMELEN
+#endif
+
void
- parse_authorized_key_file(const char *user, const char *authorized_keys_file_input)
- {
+ parse_authorized_key_file(const char *user,
+ const char *authorized_keys_file_input)