aboutsummaryrefslogtreecommitdiff
path: root/security/pam_yubico
diff options
context:
space:
mode:
authorPawel Pekala <pawel@FreeBSD.org>2013-11-30 17:26:30 +0000
committerPawel Pekala <pawel@FreeBSD.org>2013-11-30 17:26:30 +0000
commit71c9676bb633244891b32c59b73ba040578ed30c (patch)
treecca171d8ac1e203bc0fa8ab83174ffa33695ed69 /security/pam_yubico
parent7a0e3f5994a37d99a336e4aa39a795dc321f3502 (diff)
downloadports-71c9676bb633244891b32c59b73ba040578ed30c.tar.gz
ports-71c9676bb633244891b32c59b73ba040578ed30c.zip
Notes
Diffstat (limited to 'security/pam_yubico')
-rw-r--r--security/pam_yubico/Makefile48
-rw-r--r--security/pam_yubico/distinfo4
-rw-r--r--security/pam_yubico/pkg-descr2
3 files changed, 20 insertions, 34 deletions
diff --git a/security/pam_yubico/Makefile b/security/pam_yubico/Makefile
index 1c42551eac5c..991a15701c8c 100644
--- a/security/pam_yubico/Makefile
+++ b/security/pam_yubico/Makefile
@@ -1,62 +1,48 @@
# $FreeBSD$
PORTNAME= pam_yubico
-PORTVERSION= 2.13
-PORTREVISION= 1
+PORTVERSION= 2.14
CATEGORIES= security
-MASTER_SITES= GOOGLE_CODE
+MASTER_SITES= http://opensource.yubico.com/yubico-pam/releases/
MAINTAINER= matt@mjslabs.com
COMMENT= PAM module for authenticating with a Yubico YubiKey
LICENSE= BSD
-LIB_DEPENDS= ykclient:${PORTSDIR}/security/ykclient \
- ykpers-1:${PORTSDIR}/security/ykpers \
- yubikey:${PORTSDIR}/security/libyubikey
+LIB_DEPENDS= libykclient.so:${PORTSDIR}/security/ykclient \
+ libykpers-1.so:${PORTSDIR}/security/ykpers \
+ libyubikey.so:${PORTSDIR}/security/libyubikey
GNU_CONFIGURE= yes
USES= pkgconfig
-PLIST_FILES= include/drop_privs.h \
- include/util.h \
- lib/security/pam_yubico.la \
+PLIST_FILES= lib/security/pam_yubico.la \
lib/security/pam_yubico.so
PLIST_DIRS= lib/security
SUB_FILES= pkg-message
PORTDOCS= *
-PROJECTHOST= yubico-pam
-
-OPTIONS_DEFINE= CR LDAP DOCS
+OPTIONS_DEFINE= CR LDAP DOCS STATIC
CR_DESC= Include Challenge/response support
OPTIONS_DEFAULT= CR LDAP
-NO_STAGE= yes
-.include <bsd.port.options.mk>
+CR_CONFIGURE_WITH= cr
+CR_PLIST_FILES= bin/ykpamcfg \
+ man/man1/ykpamcfg.1.gz
-.if ${PORT_OPTIONS:MCR}
-CONFIGURE_ARGS+= --with-cr
-MAN1= ykpamcfg.1
-PLIST_FILES+= bin/ykpamcfg
-.else
-CONFIGURE_ARGS+= --without-cr
-.endif
+LDAP_CONFIGURE_WITH= ldap
+LDAP_USE= OPENLDAP=yes
+LDAP_LDFLAGS= -L${LOCALBASE}/lib
-.if ${PORT_OPTIONS:MLDAP}
-CONFIGURE_ARGS+= --with-ldap
-.else
-CONFIGURE_ARGS+= --without-ldap
-.endif
+STATIC_CONFIGURE_ENABLE= static
+STATIC_PLIST_FILES= lib/security/pam_yubico.a
regression-test: build
@(cd ${WRKSRC}; ${MAKE} check)
post-install:
-.if ${PORT_OPTIONS:MDOCS}
- @${MKDIR} ${DOCSDIR}
- ${INSTALL_DATA} ${WRKSRC}/README ${DOCSDIR}
-.endif
- @${CAT} ${PKGMESSAGE}
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/README ${STAGEDIR}${DOCSDIR}
.include <bsd.port.mk>
diff --git a/security/pam_yubico/distinfo b/security/pam_yubico/distinfo
index e3ed1f45671e..156df563aa11 100644
--- a/security/pam_yubico/distinfo
+++ b/security/pam_yubico/distinfo
@@ -1,2 +1,2 @@
-SHA256 (pam_yubico-2.13.tar.gz) = 0d06294f82c3286397fe52044d4b9b8d96045c3f9939fc7bbf0b45c4463e89c0
-SIZE (pam_yubico-2.13.tar.gz) = 375151
+SHA256 (pam_yubico-2.14.tar.gz) = 77bf0bce4cf7aedcfe5e65d8ee4a5f191c0346a809952f87080bfe71ea3b0c32
+SIZE (pam_yubico-2.14.tar.gz) = 380023
diff --git a/security/pam_yubico/pkg-descr b/security/pam_yubico/pkg-descr
index cbbf69e65b66..94f834415e86 100644
--- a/security/pam_yubico/pkg-descr
+++ b/security/pam_yubico/pkg-descr
@@ -2,4 +2,4 @@ The Yubico authentication device Yubikey generates one-time passwords that can
be used for authentication. This module allows you to use the Yubikey device to
authenticate to the PAM system.
-WWW: https://code.google.com/p/yubico-pam/
+WWW: http://opensource.yubico.com/yubico-pam/