aboutsummaryrefslogtreecommitdiff
path: root/security/pbc/Makefile
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2013-07-15 14:51:29 +0000
committerMartin Wilke <miwi@FreeBSD.org>2013-07-15 14:51:29 +0000
commit0793ce7ca5ef38d586e64b36470caab74db7d0e5 (patch)
treebbb133228360d9b908260b3f098e9bd1d7d65fe3 /security/pbc/Makefile
parent0c0911aab0f276e2d7e669885cb1cd626bead7df (diff)
Notes
Diffstat (limited to 'security/pbc/Makefile')
-rw-r--r--security/pbc/Makefile13
1 files changed, 11 insertions, 2 deletions
diff --git a/security/pbc/Makefile b/security/pbc/Makefile
index 1bfb0e77e262..8b8fe8c5090d 100644
--- a/security/pbc/Makefile
+++ b/security/pbc/Makefile
@@ -2,18 +2,27 @@
# $FreeBSD$
PORTNAME= pbc
-PORTVERSION= 0.5.13
+PORTVERSION= 0.5.14
CATEGORIES= security
MASTER_SITES= http://crypto.stanford.edu/pbc/files/
MAINTAINER= ports@FreeBSD.org
COMMENT= Library of pairing-based cryptosystems
+LICENSE= LGPL3
+
LIB_DEPENDS= gmp:${PORTSDIR}/math/gmp
+USES= bison
GNU_CONFIGURE= yes
-USE_GCC= 4.6+
USE_LDCONFIG= yes
+
+CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
+post-patch:
+ @${REINPLACE_CMD} -e \
+ 's|^CFLAGS=$$|| ; \
+ s|-O3||' ${WRKSRC}/configure
+
.include <bsd.port.mk>