aboutsummaryrefslogtreecommitdiff
path: root/security/pbc
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2009-03-31 09:39:12 +0000
committerMartin Wilke <miwi@FreeBSD.org>2009-03-31 09:39:12 +0000
commit2d04fc9d63dd19da95b904ddf9782ebac140d20e (patch)
tree3f3f737304eb9d0e0959df42f67ec2a5a4a0bcf8 /security/pbc
parente47fed2d3909f843bf3ec5bd56411f416143dce3 (diff)
downloadports-2d04fc9d63dd19da95b904ddf9782ebac140d20e.tar.gz
ports-2d04fc9d63dd19da95b904ddf9782ebac140d20e.zip
Notes
Diffstat (limited to 'security/pbc')
-rw-r--r--security/pbc/Makefile21
-rw-r--r--security/pbc/distinfo3
-rw-r--r--security/pbc/pkg-descr15
-rw-r--r--security/pbc/pkg-plist31
4 files changed, 70 insertions, 0 deletions
diff --git a/security/pbc/Makefile b/security/pbc/Makefile
new file mode 100644
index 000000000000..d4a604971dbf
--- /dev/null
+++ b/security/pbc/Makefile
@@ -0,0 +1,21 @@
+# New ports collection makefile for: pbc
+# Date created: 28 March, 2009
+# Whom: Wen Heping <wenheping@gmail.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= pbc
+PORTVERSION= 0.4.19
+CATEGORIES= security
+MASTER_SITES= http://crypto.stanford.edu/pbc/files/
+
+MAINTAINER= wenheping@gmail.com
+COMMENT= Library of pairing-based cryptosystems
+
+LIB_DEPENDS= gmp.7:${PORTSDIR}/math/libgmp4
+
+USE_CMAKE= yes
+USE_LDCONFIG= yes
+
+.include <bsd.port.mk>
diff --git a/security/pbc/distinfo b/security/pbc/distinfo
new file mode 100644
index 000000000000..d58196d204fb
--- /dev/null
+++ b/security/pbc/distinfo
@@ -0,0 +1,3 @@
+MD5 (pbc-0.4.19.tar.gz) = 4515d7fb22ac3d844536bf82b427dd3c
+SHA256 (pbc-0.4.19.tar.gz) = e7b4fd5a27985d89ad33daff08cda413ac37285a9af65e71e041646eed8d0e87
+SIZE (pbc-0.4.19.tar.gz) = 474807
diff --git a/security/pbc/pkg-descr b/security/pbc/pkg-descr
new file mode 100644
index 000000000000..3bd7cd6a0eeb
--- /dev/null
+++ b/security/pbc/pkg-descr
@@ -0,0 +1,15 @@
+Pairing-based cryptography is a relatively young area of cryptography
+that revolves around a certain function with special properties.
+
+The PBC (Pairing-Based Cryptography) library is a free C library
+(released under the GNU Public License) built on the GMP library that
+performs the mathematical operations underlying pairing-based
+cryptosystems.
+
+The PBC library is designed to be the backbone of implementations of
+pairing-based cryptosystems, thus speed and portability are important
+goals. It provides routines such as elliptic curve generation, elliptic
+curve arithmetic and pairing computation. Thanks to the GMP library,
+despite being written in C, pairings times are reasonable.
+
+WWW: http://crypto.stanford.edu/pbc/
diff --git a/security/pbc/pkg-plist b/security/pbc/pkg-plist
new file mode 100644
index 000000000000..c9f484908fe1
--- /dev/null
+++ b/security/pbc/pkg-plist
@@ -0,0 +1,31 @@
+lib/libpbc.a
+include/pbc/pbc.h
+include/pbc/pbc_a1_param.h
+include/pbc/pbc_a_param.h
+include/pbc/pbc_assert.h
+include/pbc/pbc_curve.h
+include/pbc/pbc_d_param.h
+include/pbc/pbc_darray.h
+include/pbc/pbc_e_param.h
+include/pbc/pbc_f_param.h
+include/pbc/pbc_field.h
+include/pbc/pbc_fieldmpz.h
+include/pbc/pbc_fieldquadratic.h
+include/pbc/pbc_fops.h
+include/pbc/pbc_fp.h
+include/pbc/pbc_g_param.h
+include/pbc/pbc_hilbert.h
+include/pbc/pbc_memory.h
+include/pbc/pbc_mnt.h
+include/pbc/pbc_mpc.h
+include/pbc/pbc_pairing.h
+include/pbc/pbc_param.h
+include/pbc/pbc_parse.h
+include/pbc/pbc_poly.h
+include/pbc/pbc_random.h
+include/pbc/pbc_singular.h
+include/pbc/pbc_symtab.h
+include/pbc/pbc_time.h
+include/pbc/pbc_tracker.h
+include/pbc/pbc_utils.h
+@dirrm include/pbc