aboutsummaryrefslogtreecommitdiff
path: root/security/pbnj/Makefile
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2006-09-30 07:30:18 +0000
committerMartin Wilke <miwi@FreeBSD.org>2006-09-30 07:30:18 +0000
commitacfcbd1c4c2c441ec56adaf551954dc1b70b64f5 (patch)
treeea2ba1786a8b09f58693b5c0b92728f63cd25de6 /security/pbnj/Makefile
parente2d0511a84684d3ccdf4c5f42d394752df7514a2 (diff)
downloadports-acfcbd1c4c2c441ec56adaf551954dc1b70b64f5.tar.gz
ports-acfcbd1c4c2c441ec56adaf551954dc1b70b64f5.zip
Notes
Diffstat (limited to 'security/pbnj/Makefile')
-rw-r--r--security/pbnj/Makefile36
1 files changed, 36 insertions, 0 deletions
diff --git a/security/pbnj/Makefile b/security/pbnj/Makefile
new file mode 100644
index 000000000000..b4d317222f53
--- /dev/null
+++ b/security/pbnj/Makefile
@@ -0,0 +1,36 @@
+# New ports collection makefile for: pbnj
+# Date created: July 26, 2006
+# Whom: Joshua D. Abraham <jabra@ccs.neu.edu>
+#
+# $FreeBSD$
+#
+
+PORTNAME= pbnj
+PORTVERSION= 2.02
+CATEGORIES= security
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE_EXTENDED}
+MASTER_SITE_SUBDIR= ${PORTNAME}
+PKGNAMEPREFIX=
+
+MAINTAINER= jabra@ccs.neu.edu
+COMMENT= A suite of tools to monitor changes on a network
+
+BUILD_DEPENDS= ${SITE_PERL}/XML/Twig.pm:${PORTSDIR}/textproc/p5-XML-Twig \
+ ${SITE_PERL}/Nmap/Parser.pm:${PORTSDIR}/security/p5-Nmap-Parser \
+ ${SITE_PERL}/mach/DBD/SQLite.pm:${PORTSDIR}/databases/p5-DBD-SQLite \
+ ${SITE_PERL}/mach/Text/CSV_XS.pm:${PORTSDIR}/textproc/p5-Text-CSV_XS \
+ ${SITE_PERL}/File/HomeDir.pm:${PORTSDIR}/devel/p5-File-HomeDir \
+ ${SITE_PERL}/File/Which.pm:${PORTSDIR}/sysutils/p5-File-Which
+RUN_DEPENDS= ${BUILD_DEPENDS} \
+ nmap:${PORTSDIR}/security/nmap
+
+PERL_CONFIGURE= yes
+
+MAN1= scanpbnj.1 \
+ outputpbnj.1 \
+ genlist.1
+
+post-configure:
+ @${PERL} -pi -e 's/^(POD2MAN_EXE.*)$$/\1 --lax/;' ${WRKSRC}/Makefile
+
+.include <bsd.port.mk>