aboutsummaryrefslogtreecommitdiff
path: root/security/pcsc-tools
diff options
context:
space:
mode:
authorTilman Keskinoz <arved@FreeBSD.org>2014-04-14 08:28:25 +0000
committerTilman Keskinoz <arved@FreeBSD.org>2014-04-14 08:28:25 +0000
commit49f3f4159d82ce9f4c85550ff9c699b808a1d432 (patch)
tree69ca51614397f2838f47df18d0722950406e7582 /security/pcsc-tools
parente9882ff1c46f3034a2d951b09fa54fd8f74a784d (diff)
downloadports-49f3f4159d82ce9f4c85550ff9c699b808a1d432.tar.gz
ports-49f3f4159d82ce9f4c85550ff9c699b808a1d432.zip
Notes
Diffstat (limited to 'security/pcsc-tools')
-rw-r--r--security/pcsc-tools/Makefile34
-rw-r--r--security/pcsc-tools/distinfo4
-rw-r--r--security/pcsc-tools/files/patch-Makefile21
-rw-r--r--security/pcsc-tools/pkg-plist4
4 files changed, 26 insertions, 37 deletions
diff --git a/security/pcsc-tools/Makefile b/security/pcsc-tools/Makefile
index f567a93ab34f..827d35917d93 100644
--- a/security/pcsc-tools/Makefile
+++ b/security/pcsc-tools/Makefile
@@ -2,8 +2,7 @@
# $FreeBSD$
PORTNAME= pcsc-tools
-PORTVERSION= 1.4.21
-PORTREVISION= 1
+PORTVERSION= 1.4.22
CATEGORIES= security
MASTER_SITES= http://ludovic.rousseau.free.fr/softwares/pcsc-tools/
@@ -18,15 +17,22 @@ RUN_DEPENDS= p5-PCSC-Card>=0:${PORTSDIR}/devel/p5-PCSC-Card \
USES= gmake pkgconfig
-MAN1= pcsc_scan.1 gscriptor.1p scriptor.1p ATR_analysis.1p
-
-NO_STAGE= yes
-post-patch:
- ${REINPLACE_CMD} -e "s,DESTDIR,PREFIX,g" ${WRKSRC}/Makefile
-
-post-install:
-.for i in ${MAN1}
- ${INSTALL_MAN} ${WRKSRC}/$i ${MAN1PREFIX}/man/man1
-.endfor
-
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/pcsc_scan \
+ ${STAGEDIR}${PREFIX}/bin/
+ ${INSTALL_SCRIPT} ${WRKSRC}/ATR_analysis \
+ ${WRKSRC}/gscriptor \
+ ${WRKSRC}/scriptor \
+ ${STAGEDIR}${PREFIX}/bin/
+ ${INSTALL_MAN} ${WRKSRC}/pcsc_scan.1 \
+ ${WRKSRC}/gscriptor.1p \
+ ${WRKSRC}/scriptor.1p \
+ ${WRKSRC}/ATR_analysis.1p \
+ ${STAGEDIR}${MAN1PREFIX}/man/man1
+ ${MKDIR} ${STAGEDIR}/${PREFIX}/share/pcsc
+ ${INSTALL_DATA} ${WRKSRC}/smartcard_list.txt \
+ ${STAGEDIR}/${PREFIX}/share/pcsc
+
+.include <bsd.port.post.mk>
diff --git a/security/pcsc-tools/distinfo b/security/pcsc-tools/distinfo
index a0b080ec6e39..31d384f3f914 100644
--- a/security/pcsc-tools/distinfo
+++ b/security/pcsc-tools/distinfo
@@ -1,2 +1,2 @@
-SHA256 (pcsc-tools-1.4.21.tar.gz) = bab20f441e4f853429ebb1823f92b99a50612db7c28f808a7490c7b30617de01
-SIZE (pcsc-tools-1.4.21.tar.gz) = 101331
+SHA256 (pcsc-tools-1.4.22.tar.gz) = 615592dd56627bd0ff3650608bb7eefe3e9f43cc18ca2d805ebf0bf74d30f307
+SIZE (pcsc-tools-1.4.22.tar.gz) = 109458
diff --git a/security/pcsc-tools/files/patch-Makefile b/security/pcsc-tools/files/patch-Makefile
deleted file mode 100644
index d2eb1b9db691..000000000000
--- a/security/pcsc-tools/files/patch-Makefile
+++ /dev/null
@@ -1,21 +0,0 @@
---- Makefile.bak 2009-05-14 20:39:23.000000000 +0200
-+++ Makefile 2012-01-20 13:44:11.000000000 +0100
-@@ -20,7 +20,7 @@
- BIN_SCRIPT = ATR_analysis gscriptor scriptor
- MAN = pcsc_scan.1.gz gscriptor.1p.gz scriptor.1p.gz ATR_analysis.1p.gz
-
--all: $(BIN) $(MAN)
-+all: $(BIN)
-
- pcsc_scan: pcsc_scan.o
-
-@@ -33,9 +33,6 @@
- install -d $(DESTDIR)/share/pcsc
- install -m 644 smartcard_list.txt $(DESTDIR)/share/pcsc
-
-- install -d $(DESTDIR)/share/man/man1/
-- install -m 644 $(MAN) $(DESTDIR)/share/man/man1/
--
- clean:
- rm -f pcsc_scan.o $(BIN) $(MAN)
-
diff --git a/security/pcsc-tools/pkg-plist b/security/pcsc-tools/pkg-plist
index 16a5f31cec71..a1548fc97bd8 100644
--- a/security/pcsc-tools/pkg-plist
+++ b/security/pcsc-tools/pkg-plist
@@ -2,5 +2,9 @@ bin/pcsc_scan
bin/ATR_analysis
bin/gscriptor
bin/scriptor
+man/man1/ATR_analysis.1p.gz
+man/man1/gscriptor.1p.gz
+man/man1/pcsc_scan.1.gz
+man/man1/scriptor.1p.gz
share/pcsc/smartcard_list.txt
@dirrm share/pcsc