aboutsummaryrefslogtreecommitdiff
path: root/security/pear-Auth/Makefile
diff options
context:
space:
mode:
authorNorikatsu Shigemura <nork@FreeBSD.org>2003-06-07 23:00:46 +0000
committerNorikatsu Shigemura <nork@FreeBSD.org>2003-06-07 23:00:46 +0000
commit077b4b53b0d0814df73a850dfa8625101c7b8404 (patch)
tree1635d75a5b1ebd11d644c2d01607580c9063de35 /security/pear-Auth/Makefile
parent95cfdcc8b6a9c07b40477662aa446e3bdd99525b (diff)
Notes
Diffstat (limited to 'security/pear-Auth/Makefile')
-rw-r--r--security/pear-Auth/Makefile24
1 files changed, 3 insertions, 21 deletions
diff --git a/security/pear-Auth/Makefile b/security/pear-Auth/Makefile
index b27185860141..d14676343a87 100644
--- a/security/pear-Auth/Makefile
+++ b/security/pear-Auth/Makefile
@@ -7,31 +7,17 @@
PORTNAME= Auth
PORTVERSION= 1.2.0
+PORTREVISION= 1
CATEGORIES= security www
-MASTER_SITES= http://pear.php.net/get/
-PKGNAMEPREFIX= pear-
-EXTRACT_SUFX= .tgz
-DIST_SUBDIR= PEAR
MAINTAINER= ports@FreeBSD.org
COMMENT= PEAR authentication methods
-BUILD_DEPENDS= ${PEARDIR}/PEAR.php.dist:${PORTSDIR}/devel/pear-PEAR
+BUILD_DEPENDS= ${PEARDIR}/PEAR.php:${PORTSDIR}/devel/pear-PEAR
RUN_DEPENDS= ${BUILD_DEPENDS}
-NO_BUILD= yes
-
.include <bsd.port.pre.mk>
-
-.if exists(${LOCALBASE}/bin/php-config)
-PHP_BASE!= ${LOCALBASE}/bin/php-config --prefix
-.else
-PHP_BASE= ${LOCALBASE}
-.endif
-PEAR= ${LOCALBASE}/bin/pear
-LPHP_LIB= lib/php
-PEARDIR= ${PHP_BASE}/${LPHP_LIB}
-PLIST_SUB= PEARDIR=${LPHP_LIB}
+.include "${.CURDIR}/../../devel/pear-PEAR/Makefile.common"
MANIFEST= Auth.php Container Container.php
@@ -43,8 +29,4 @@ do-install:
@${CHOWN} -R ${SHAREOWN}:${SHAREGRP} ${PEARDIR}/Auth
@${CHMOD} -R a-x ${PEARDIR}/Auth/Container/*.php
-post-install:
-# Register a new package
- @${PEAR} install -r -f ${WRKDIR}/package.xml
-
.include <bsd.port.post.mk>