aboutsummaryrefslogtreecommitdiff
path: root/security/pear-Auth/Makefile
diff options
context:
space:
mode:
authorCheng-Lung Sung <clsung@FreeBSD.org>2006-09-19 08:27:08 +0000
committerCheng-Lung Sung <clsung@FreeBSD.org>2006-09-19 08:27:08 +0000
commit0f5f6c8d57314e29747d878a38a62f0ae0931d81 (patch)
tree1ff6b9cd01e5db0e1721480617dca78ce6eb92a6 /security/pear-Auth/Makefile
parent430879567d98de57b3fbce04b6f6e7690378cb30 (diff)
downloadports-0f5f6c8d57314e29747d878a38a62f0ae0931d81.tar.gz
ports-0f5f6c8d57314e29747d878a38a62f0ae0931d81.zip
Notes
Diffstat (limited to 'security/pear-Auth/Makefile')
-rw-r--r--security/pear-Auth/Makefile21
1 files changed, 14 insertions, 7 deletions
diff --git a/security/pear-Auth/Makefile b/security/pear-Auth/Makefile
index 4fd2f8eee938..2455ba35bfa4 100644
--- a/security/pear-Auth/Makefile
+++ b/security/pear-Auth/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= Auth
-PORTVERSION= 1.2.4
+PORTVERSION= 1.3.0
CATEGORIES= security pear
MAINTAINER= antonio@php.net
@@ -20,19 +20,22 @@ OPTIONS= PEAR_FILE_PASSWD "PEAR::File_Passwd support" off \
PEAR_NET_POP3 "PEAR::Net_POP3 support" off \
PEAR_DB "PEAR::DB support" off \
PEAR_MDB "PEAR::MDB support" off \
- PEAR_AUTH_RADIUS "PEAR::Auth_RADIUS support" off \
+ PEAR_MDB2 "PEAR::MDB2 support" off \
PEAR_FILE_SMBPASSWD "PEAR::File_SMBPasswd support" off
CATEGORY= Auth
FILES= Auth.php Auth/Auth.php Container.php Container/DB.php \
- Container/File.php Container/IMAP.php Container/POP3.php \
- Container/LDAP.php Container/MDB.php Container/RADIUS.php \
- Container/SMBPasswd.php Container/SOAP.php Container/vpopmail.php
+ Container/DBLite.php Container/File.php Container/IMAP.php \
+ Container/POP3.php Container/LDAP.php Container/MDB.php \
+ Container/MDB2.php Container/RADIUS.php Container/SMBPasswd.php \
+ Container/SOAP.php Container/vpopmail.php
TESTS= auth_container_db_options.php DBContainer.php \
auth_container_file_options.php FileContainer.php \
auth_container_pop3_options.php POP3Container.php \
- auth_container_pop3a_options.php POP3aContainer.php \
- TestAuthContainer.php users tests.php
+ auth_container_mdb_options.php MDBContainer.php \
+ auth_container_mdb2_options.php MDB2Container.php \
+ POP3Container.php auth_container_pop3a_options.php \
+ POP3aContainer.php TestAuthContainer.php users tests.php
DOCS= README.Auth
_DOCSDIR= .
@@ -57,6 +60,10 @@ RUN_DEPENDS+= ${PEARDIR}/DB.php:${PORTSDIR}/databases/pear-DB
RUN_DEPENDS+= ${PEARDIR}/MDB.php:${PORTSDIR}/databases/pear-MDB
.endif
+.if defined(WITH_PEAR_MDB2)
+RUN_DEPENDS+= ${PEARDIR}/MDB2.php:${PORTSDIR}/databases/pear-MDB2
+.endif
+
.if defined(WITH_PEAR_AUTH_RADIUS)
RUN_DEPENDS+= ${PEARDIR}/Auth/RADIUS.php:${PORTSDIR}/net/pear-Auth_RADIUS
.endif