aboutsummaryrefslogtreecommitdiff
path: root/security/pear-Auth
diff options
context:
space:
mode:
authorBaptiste Daroussin <bapt@FreeBSD.org>2014-09-26 09:05:59 +0000
committerBaptiste Daroussin <bapt@FreeBSD.org>2014-09-26 09:05:59 +0000
commitb34b62504270f2292763071ad4b569292d128eab (patch)
treebd48bdb15c434819e5cee08284fec6bc335e2120 /security/pear-Auth
parent3e566dc59013cd5a8f50ca845c296fc562148fbb (diff)
Notes
Diffstat (limited to 'security/pear-Auth')
-rw-r--r--security/pear-Auth/Makefile64
1 files changed, 13 insertions, 51 deletions
diff --git a/security/pear-Auth/Makefile b/security/pear-Auth/Makefile
index 6fa1fffc560b..bd6e70a282ba 100644
--- a/security/pear-Auth/Makefile
+++ b/security/pear-Auth/Makefile
@@ -8,11 +8,8 @@ CATEGORIES= security pear
MAINTAINER= miwi@FreeBSD.org
COMMENT= PEAR class for creating an authentication system
-BUILD_DEPENDS= ${PEARDIR}/PEAR.php:${PORTSDIR}/devel/pear
-RUN_DEPENDS= ${PEARDIR}/PEAR.php:${PORTSDIR}/devel/pear
+USES= pear
-PEAR_AUTOINSTALL= yes
-LATEST_LINK= pear-Auth
OPTIONS_DEFINE= PEAR_LOG PEAR_FILE_PASSWD PEAR_NET_POP3 PEAR_DB PEAR_MDB \
PEAR_MDB2 PEAR_AUTH_RADIUS PEAR_CRYPT_CHAP PEAR_FILE_SMBPASSWD \
PEAR_SOAP PEAR_NET_VPOPMAILD
@@ -28,54 +25,19 @@ PEAR_FILE_SMBPASSWD_DESC= PEAR::File_SMBPasswd support
PEAR_SOAP_DESC= PEAR::SOAP support
PEAR_NET_VPOPMAILD_DESC= PEAR::Net_Vpopmaild support
+PEAR_LOG_RUN_DEPENDS= ${PEARDIR}/Log/syslog.php:${PORTSDIR}/sysutils/pear-Log
+PEAR_FILE_PASSWD_RUN_DEPENDS= ${PEARDIR}/File/Passwd.php:${PORTSDIR}/security/pear-File_Passwd
+PEAR_CRYPT_CHAP_RUN_DEPENDS= ${PEARDIR}/Crypt/CHAP.php:${PORTSDIR}/security/pear-Crypt_CHAP
+PEAR_NET_POP3_RUN_DEPENDS= ${PEARDIR}/Net/POP3.php:${PORTSDIR}/net/pear-Net_POP3
+PEAR_DB_RUN_DEPENDS= ${PEARDIR}/DB.php:${PORTSDIR}/databases/pear-DB
+PEAR_MDB_RUN_DEPENDS= ${PEARDIR}/MDB.php:${PORTSDIR}/databases/pear-MDB
+PEAR_MDB2_RUN_DEPENDS= ${PEARDIR}/MDB2.php:${PORTSDIR}/databases/pear-MDB2
+PEAR_AUTH_RADIUS_RUN_DEPENDS= ${PEARDIR}/Auth/RADIUS.php:${PORTSDIR}/net/pear-Auth_RADIUS
+PEAR_FILE_SMBPASSWD_RUN_DEPENDS= ${PEARDIR}/File/SMBPasswd.php:${PORTSDIR}/security/pear-File_SMBPasswd
+PEAR_SOAP_RUN_DEPENDS= ${PEARDIR}/SOAP/Base.php:${PORTSDIR}/net/pear-SOAP
+PEAR_NET_VPOPMAILD_RUN_DEPENDS= ${PEARDIR}/Net/Vpopmaild.php:${PORTSDIR}/net/pear-Net_Vpopmaild
+
post-extract:
@${REINPLACE_CMD} -e "s|@version@|${PORTVERSION}|" ${WRKSRC}/Auth.php
-.include <bsd.port.options.mk>
-
-.if ${PORT_OPTIONS:MPEAR_LOG}
-RUN_DEPENDS+= ${PEARDIR}/Log/syslog.php:${PORTSDIR}/sysutils/pear-Log
-.endif
-
-.if ${PORT_OPTIONS:MPEAR_FILE_PASSWD}
-RUN_DEPENDS+= ${PEARDIR}/File/Passwd.php:${PORTSDIR}/security/pear-File_Passwd
-.endif
-
-.if ${PORT_OPTIONS:MPEAR_CRYPT_CHAP}
-RUN_DEPENDS+= ${PEARDIR}/Crypt/CHAP.php:${PORTSDIR}/security/pear-Crypt_CHAP
-.endif
-
-.if ${PORT_OPTIONS:MPEAR_NET_POP3}
-RUN_DEPENDS+= ${PEARDIR}/Net/POP3.php:${PORTSDIR}/net/pear-Net_POP3
-.endif
-
-.if ${PORT_OPTIONS:MPEAR_DB}
-RUN_DEPENDS+= ${PEARDIR}/DB.php:${PORTSDIR}/databases/pear-DB
-.endif
-
-.if ${PORT_OPTIONS:MPEAR_MDB}
-RUN_DEPENDS+= ${PEARDIR}/MDB.php:${PORTSDIR}/databases/pear-MDB
-.endif
-
-.if ${PORT_OPTIONS:MPEAR_MDB2}
-RUN_DEPENDS+= ${PEARDIR}/MDB2.php:${PORTSDIR}/databases/pear-MDB2
-.endif
-
-.if ${PORT_OPTIONS:MPEAR_AUTH_RADIUS}
-RUN_DEPENDS+= ${PEARDIR}/Auth/RADIUS.php:${PORTSDIR}/net/pear-Auth_RADIUS
-.endif
-
-.if ${PORT_OPTIONS:MPEAR_FILE_SMBPASSWD}
-RUN_DEPENDS+= ${PEARDIR}/File/SMBPasswd.php:${PORTSDIR}/security/pear-File_SMBPasswd
-.endif
-
-.if ${PORT_OPTIONS:MPEAR_SOAP}
-RUN_DEPENDS+= ${PEARDIR}/SOAP/Base.php:${PORTSDIR}/net/pear-SOAP
-.endif
-
-.if ${PORT_OPTIONS:MPEAR_NET_VPOPMAILD}
-RUN_DEPENDS+= ${PEARDIR}/Net/Vpopmaild.php:${PORTSDIR}/net/pear-Net_Vpopmaild
-.endif
-
-.include "${PORTSDIR}/devel/pear/bsd.pear.mk"
.include <bsd.port.mk>