aboutsummaryrefslogtreecommitdiff
path: root/security/pear-Auth
diff options
context:
space:
mode:
authorEdwin Groothuis <edwin@FreeBSD.org>2003-08-25 01:21:45 +0000
committerEdwin Groothuis <edwin@FreeBSD.org>2003-08-25 01:21:45 +0000
commit52b8ee7ee031e786f5f889cdf70771dc2fe24d60 (patch)
tree4bdee77759426e37a0b52447edc33c6c69407978 /security/pear-Auth
parent2ac923e84d928b3c14d2b0abfea9dbe93fdaebfa (diff)
downloadports-52b8ee7ee031e786f5f889cdf70771dc2fe24d60.tar.gz
ports-52b8ee7ee031e786f5f889cdf70771dc2fe24d60.zip
Notes
Diffstat (limited to 'security/pear-Auth')
-rw-r--r--security/pear-Auth/Makefile12
-rw-r--r--security/pear-Auth/distinfo2
-rw-r--r--security/pear-Auth/pkg-descr4
-rw-r--r--security/pear-Auth/pkg-plist16
4 files changed, 29 insertions, 5 deletions
diff --git a/security/pear-Auth/Makefile b/security/pear-Auth/Makefile
index d14676343a87..e276a9ae5c6c 100644
--- a/security/pear-Auth/Makefile
+++ b/security/pear-Auth/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= Auth
-PORTVERSION= 1.2.0
-PORTREVISION= 1
+PORTVERSION= 1.2.2
CATEGORIES= security www
MAINTAINER= ports@FreeBSD.org
@@ -20,6 +19,7 @@ RUN_DEPENDS= ${BUILD_DEPENDS}
.include "${.CURDIR}/../../devel/pear-PEAR/Makefile.common"
MANIFEST= Auth.php Container Container.php
+TESTDIR= ${PEARDIR}/tests/${PORTNAME}
do-install:
@${MKDIR} ${PEARDIR}/Auth
@@ -28,5 +28,13 @@ do-install:
.endfor
@${CHOWN} -R ${SHAREOWN}:${SHAREGRP} ${PEARDIR}/Auth
@${CHMOD} -R a-x ${PEARDIR}/Auth/Container/*.php
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${TESTDIR}
+ @${CP} -Rp ${WRKSRC}/tests/* ${TESTDIR}
+ @${CHOWN} -R ${SHAREOWN}:${SHAREGRP} ${TESTDIR}
+ @${ECHO_MSG} "===> Examples installed in ${TESTDIR}."
+ @${ECHO_MSG} " (These tests require PHPUnit - see"
+ @${ECHO_MSG} " <http://pear.php.net/package-info.php?package=PHPUnit>;)."
+.endif
.include <bsd.port.post.mk>
diff --git a/security/pear-Auth/distinfo b/security/pear-Auth/distinfo
index 42c13ccdb5ee..8a7b3593f988 100644
--- a/security/pear-Auth/distinfo
+++ b/security/pear-Auth/distinfo
@@ -1 +1 @@
-MD5 (PEAR/Auth-1.2.0.tgz) = aadd95475e7ecd22a2f17143027ee0c1
+MD5 (PEAR/Auth-1.2.2.tgz) = 6f8b343bf0ee9aef1bb063c9600898f8
diff --git a/security/pear-Auth/pkg-descr b/security/pear-Auth/pkg-descr
index 062b49bfaa7c..b8b178416090 100644
--- a/security/pear-Auth/pkg-descr
+++ b/security/pear-Auth/pkg-descr
@@ -5,12 +5,14 @@ Currently it supports the following storage containers to read/write
the login data:
* All databases supported by the PEAR database layer
+* All databases supported by the MDB database layer
* Plaintext files
* LDAP servers
* POP3 servers
* IMAP servers
* vpopmail accounts
* RADIUS
+* SAMBA password files
* SOAP.
-WWW: http://pear.php.net/manual/en/packages.auth.auth.php
+WWW: http://pear.php.net/package-info.php?package=Auth
diff --git a/security/pear-Auth/pkg-plist b/security/pear-Auth/pkg-plist
index eaf0cdd3898c..ab42e6427ccd 100644
--- a/security/pear-Auth/pkg-plist
+++ b/security/pear-Auth/pkg-plist
@@ -4,11 +4,25 @@
%%PEARDIR%%/Auth/Container/File.php
%%PEARDIR%%/Auth/Container/IMAP.php
%%PEARDIR%%/Auth/Container/LDAP.php
+%%PEARDIR%%/Auth/Container/MDB.php
%%PEARDIR%%/Auth/Container/POP3.php
%%PEARDIR%%/Auth/Container/RADIUS.php
+%%PEARDIR%%/Auth/Container/SMBPasswd.php
%%PEARDIR%%/Auth/Container/SOAP.php
%%PEARDIR%%/Auth/Container/vpopmail.php
%%PKGREGDIR%%/package.xml
+%%PORTDOCS%%%%PEARDIR%%/tests/Auth/DBContainer.php
+%%PORTDOCS%%%%PEARDIR%%/tests/Auth/FileContainer.php
+%%PORTDOCS%%%%PEARDIR%%/tests/Auth/POP3Container.php
+%%PORTDOCS%%%%PEARDIR%%/tests/Auth/POP3aContainer.php
+%%PORTDOCS%%%%PEARDIR%%/tests/Auth/TestAuthContainer.php
+%%PORTDOCS%%%%PEARDIR%%/tests/Auth/auth_container_db_options.php
+%%PORTDOCS%%%%PEARDIR%%/tests/Auth/auth_container_file_options.php
+%%PORTDOCS%%%%PEARDIR%%/tests/Auth/auth_container_pop3_options.php
+%%PORTDOCS%%%%PEARDIR%%/tests/Auth/auth_container_pop3a_options.php
+%%PORTDOCS%%%%PEARDIR%%/tests/Auth/tests.php
+%%PORTDOCS%%%%PEARDIR%%/tests/Auth/users
@dirrm %%PEARDIR%%/Auth/Container
-@dirrm %%PEARDIR%%/Auth
+@unexec rmdir %D/%%PEARDIR%%/Auth 2>/dev/null || true
@dirrm %%PKGREGDIR%%
+%%PORTDOCS%%@dirrm %%PEARDIR%%/tests/Auth