aboutsummaryrefslogtreecommitdiff
path: root/security/pear-Auth
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2006-10-31 13:33:22 +0000
committerMartin Wilke <miwi@FreeBSD.org>2006-10-31 13:33:22 +0000
commit81434d83ba188be311021d95372d53dc3744c557 (patch)
treeefaa68dc684ad1256a464898b10f63e2a294544f /security/pear-Auth
parentc6ed9ff0a700b194f979bfe7fe41607e64eb70a8 (diff)
downloadports-81434d83ba188be311021d95372d53dc3744c557.tar.gz
ports-81434d83ba188be311021d95372d53dc3744c557.zip
Notes
Diffstat (limited to 'security/pear-Auth')
-rw-r--r--security/pear-Auth/Makefile43
-rw-r--r--security/pear-Auth/distinfo6
2 files changed, 31 insertions, 18 deletions
diff --git a/security/pear-Auth/Makefile b/security/pear-Auth/Makefile
index 253bc76b2d94..2819e1bbd409 100644
--- a/security/pear-Auth/Makefile
+++ b/security/pear-Auth/Makefile
@@ -6,10 +6,10 @@
#
PORTNAME= Auth
-PORTVERSION= 1.3.0
+PORTVERSION= 1.4.0
CATEGORIES= security pear
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= chinsan@FreeBSD.org
COMMENT= PEAR class for creating an authentication system
BUILD_DEPENDS= ${PEARDIR}/PEAR.php:${PORTSDIR}/devel/pear
@@ -18,24 +18,29 @@ RUN_DEPENDS= ${BUILD_DEPENDS}
LATEST_LINK= pear-Auth
OPTIONS= PEAR_FILE_PASSWD "PEAR::File_Passwd support" off \
PEAR_NET_POP3 "PEAR::Net_POP3 support" off \
+ PEAR_CRYPT_CHAP "PEAR::CRYPT_CHAP support" off \
PEAR_DB "PEAR::DB support" off \
PEAR_MDB "PEAR::MDB support" off \
PEAR_MDB2 "PEAR::MDB2 support" off \
- PEAR_FILE_SMBPASSWD "PEAR::File_SMBPasswd support" off
+ PEAR_AUTH_RADIUS "PEAR::AUTH_RADIUS support" off \
+ PEAR_FILE_SMBPASSWD "PEAR::File_SMBPasswd support" off \
+ PEAR_SOAP "PEAR::SOAP support" off
CATEGORY= Auth
-FILES= Auth.php Auth/Auth.php Container.php Container/DB.php \
- Container/DBLite.php Container/File.php Container/IMAP.php \
- Container/POP3.php Container/LDAP.php Container/MDB.php \
- Container/MDB2.php Container/RADIUS.php Container/SMBPasswd.php \
- Container/SOAP.php Container/vpopmail.php
-TESTS= auth_container_db_options.php DBContainer.php \
- auth_container_file_options.php FileContainer.php \
- auth_container_pop3_options.php POP3Container.php \
- auth_container_mdb_options.php MDBContainer.php \
- auth_container_mdb2_options.php MDB2Container.php \
- POP3Container.php auth_container_pop3a_options.php \
- POP3aContainer.php TestAuthContainer.php users tests.php
+FILES= Auth.php Container.php Auth/Anonymous.php Auth/Auth.php \
+ Auth/Controller.php Container/DB.php Container/DBLite.php \
+ Container/File.php Container/IMAP.php Container/KADM5.php\
+ Container/LDAP.php Container/MDB.php Container/MDB2.php \
+ Container/PEAR.php Container/POP3.php Container/RADIUS.php \
+ Container/SMBPasswd.php Container/SOAP.php Container/SOAP5.php \
+ Container/vpopmail.php Frontend/Html.php Frontend/md5.js
+TESTS= auth_container_db_options.php auth_container_file_options.php \
+ auth_container_mdb2_options.php auth_container_mdb_options.php \
+ auth_container_pop3a_options.php auth_container_pop3_options.php \
+ DBContainer.php FileContainer.php MDB2Container.php \
+ MDBContainer.php mysql_test_db.sql POP3aContainer.php \
+ POP3Container.php TestAuthContainer.php tests.php users \
+ bug8735.passwd bug8735.phpt
DOCS= README.Auth
_DOCSDIR= .
@@ -48,6 +53,10 @@ post-extract:
RUN_DEPENDS+= ${PEARDIR}/File/Passwd.php:${PORTSDIR}/security/pear-File_Passwd
.endif
+.if defined(WITH_PEAR_CRYPT_CHAP)
+RUN_DEPENDS+= ${PEARDIR}/Crypt/CHAP.php:${PORTSDIR}/security/pear-Crypt_CHAP
+.endif
+
.if defined(WITH_PEAR_NET_POP3)
RUN_DEPENDS+= ${PEARDIR}/Net/POP3.php:${PORTSDIR}/net/pear-Net_POP3
.endif
@@ -72,5 +81,9 @@ RUN_DEPENDS+= ${PEARDIR}/Auth/RADIUS.php:${PORTSDIR}/net/pear-Auth_RADIUS
RUN_DEPENDS+= ${PEARDIR}/File/SMBPasswd.php:${PORTSDIR}/security/pear-File_SMBPasswd
.endif
+.if defined(WITH_PEAR_SOAP)
+RUN_DEPENDS+= ${PEARDIR}/SOAP/Base.php:${PORTSDIR}/net/pear-SOAP
+.endif
+
.include "${PORTSDIR}/devel/pear/bsd.pear.mk"
.include <bsd.port.post.mk>
diff --git a/security/pear-Auth/distinfo b/security/pear-Auth/distinfo
index ca8365e8a0a6..27ce278f14e9 100644
--- a/security/pear-Auth/distinfo
+++ b/security/pear-Auth/distinfo
@@ -1,3 +1,3 @@
-MD5 (PEAR/Auth-1.3.0.tgz) = bdeda8b053d87b948c2cea44378581b8
-SHA256 (PEAR/Auth-1.3.0.tgz) = e99158651c9a9b44096198653d2e5b4f845c41144b735fcb84ee21565196892a
-SIZE (PEAR/Auth-1.3.0.tgz) = 39759
+MD5 (PEAR/Auth-1.4.0.tgz) = 111c97d5f3ece28d57119526214e23ef
+SHA256 (PEAR/Auth-1.4.0.tgz) = c7a2e0647a40f29bfbecc30c4ec208c3ae5f4f6301172e6b022ba9cf8866cfb9
+SIZE (PEAR/Auth-1.4.0.tgz) = 52830