aboutsummaryrefslogtreecommitdiff
path: root/security/pear-Auth_PrefManager
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2005-04-09 22:52:32 +0000
committerPav Lucistnik <pav@FreeBSD.org>2005-04-09 22:52:32 +0000
commit9e5f3ca861ea13bbf1820802367705a91d24ac08 (patch)
tree4ec01b6d6a6950e665d563cdfc5ec8f619c1dfe7 /security/pear-Auth_PrefManager
parent80b9d9837cb2a9d9bf0c43ef34354213108176b7 (diff)
downloadports-9e5f3ca861ea13bbf1820802367705a91d24ac08.tar.gz
ports-9e5f3ca861ea13bbf1820802367705a91d24ac08.zip
Notes
Diffstat (limited to 'security/pear-Auth_PrefManager')
-rw-r--r--security/pear-Auth_PrefManager/Makefile24
-rw-r--r--security/pear-Auth_PrefManager/distinfo2
-rw-r--r--security/pear-Auth_PrefManager/pkg-descr9
3 files changed, 35 insertions, 0 deletions
diff --git a/security/pear-Auth_PrefManager/Makefile b/security/pear-Auth_PrefManager/Makefile
new file mode 100644
index 000000000000..32166c2399fe
--- /dev/null
+++ b/security/pear-Auth_PrefManager/Makefile
@@ -0,0 +1,24 @@
+# Ports collection makefile for: pear-Auth_PrefManager
+# Date created: 05 April 2005
+# Whom: Antonio Carlos Venancio Junior (<antonio@inf.ufsc.br>)
+#
+# $FreeBSD$
+#
+
+PORTNAME= Auth_PrefManager
+PORTVERSION= 1.1.4
+CATEGORIES= security www pear
+
+MAINTAINER= antonio@php.net
+COMMENT= PEAR preferences management class
+
+BUILD_DEPENDS= ${PEARDIR}/DB.php:${PORTSDIR}/databases/pear-DB
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+CATEGORY= Auth
+FILES= PrefManager.php
+DOCS= PM_Example.php
+
+.include <bsd.port.pre.mk>
+.include "${PORTSDIR}/devel/pear-PEAR/Makefile.common"
+.include <bsd.port.post.mk>
diff --git a/security/pear-Auth_PrefManager/distinfo b/security/pear-Auth_PrefManager/distinfo
new file mode 100644
index 000000000000..50abd6c8a2fc
--- /dev/null
+++ b/security/pear-Auth_PrefManager/distinfo
@@ -0,0 +1,2 @@
+MD5 (PEAR/Auth_PrefManager-1.1.4.tgz) = b29c2f95475fbc4970e2fa2d93715ae7
+SIZE (PEAR/Auth_PrefManager-1.1.4.tgz) = 4911
diff --git a/security/pear-Auth_PrefManager/pkg-descr b/security/pear-Auth_PrefManager/pkg-descr
new file mode 100644
index 000000000000..d638805fa7e4
--- /dev/null
+++ b/security/pear-Auth_PrefManager/pkg-descr
@@ -0,0 +1,9 @@
+Preference Manager is a class to handle user preferences in a web application,
+looking them up in a table using a combination of their userid, and the
+preference name to get a value, and (optionally) returning a default value for
+the preference if no value could be found for that user.
+
+It is designed to be used alongside the PEAR Auth class, but can be used with
+anything that allows you to obtain the user's id - including your own code.
+
+WWW: http://pear.php.net/package/Auth_PrefManager/