aboutsummaryrefslogtreecommitdiff
path: root/security/pear-LiveUser/Makefile
diff options
context:
space:
mode:
authorBaptiste Daroussin <bapt@FreeBSD.org>2014-09-26 09:05:59 +0000
committerBaptiste Daroussin <bapt@FreeBSD.org>2014-09-26 09:05:59 +0000
commitb34b62504270f2292763071ad4b569292d128eab (patch)
treebd48bdb15c434819e5cee08284fec6bc335e2120 /security/pear-LiveUser/Makefile
parent3e566dc59013cd5a8f50ca845c296fc562148fbb (diff)
downloadports-b34b62504270f2292763071ad4b569292d128eab.tar.gz
ports-b34b62504270f2292763071ad4b569292d128eab.zip
Notes
Diffstat (limited to 'security/pear-LiveUser/Makefile')
-rw-r--r--security/pear-LiveUser/Makefile36
1 files changed, 7 insertions, 29 deletions
diff --git a/security/pear-LiveUser/Makefile b/security/pear-LiveUser/Makefile
index a34bf53174a0..b7f5021f348a 100644
--- a/security/pear-LiveUser/Makefile
+++ b/security/pear-LiveUser/Makefile
@@ -13,7 +13,7 @@ RUN_DEPENDS= ${PEARDIR}/Event/Dispatcher.php:${PORTSDIR}/devel/pear-Event_Dispat
PORTSCOUT= skipv:0.61
-LATEST_LINK= pear-LiveUser
+USES= pear
OPTIONS_DEFINE= PEAD_DB PEAR_MDB PEAR_MDB2 PEAR_LOG PEAR_XML_TREE PEAR_CRYPT_RC4
PEAR_DB_DESC= PEAR::DB support
@@ -23,33 +23,11 @@ PEAR_LOG_DESC= PEAR::Log support
PEAR_XML_TREE_DESC= PEAR::XML_Tree support
PEAR_CRYPT_RC4_DESC= PEAR::Crypt_RC4 support
-PEAR_AUTOINSTALL=yes
+PEAR_DB_RUN_DEPENDS= ${PEARDIR}/DB.php:${PORTSDIR}/databases/pear-DB
+PEAR_MDB_RUN_DEPENDS= ${PEARDIR}/MDB.php:${PORTSDIR}/databases/pear-MDB
+PEAR_MDB2_RUN_DEPENDS= ${PEARDIR}/MDB2.php:${PORTSDIR}/databases/pear-MDB2
+PEAR_LOG_RUN_DEPENDS= ${PEARDIR}/Log/null.php:${PORTSDIR}/sysutils/pear-Log
+PEAR_XML_TREE_RUN_DEPENDS= ${PEARDIR}/XML/Tree.php:${PORTSDIR}/devel/pear-XML_Tree
+PEAR_CRYPT_RC4_RUN_DEPENDS= ${PEARDIR}/Crypt/Rc4.php:${PORTSDIR}/security/pear-Crypt_RC4
-.include <bsd.port.options.mk>
-
-.if ${PORT_OPTIONS:MPEAR_DB}
-RUN_DEPENDS+= ${PEARDIR}/DB.php:${PORTSDIR}/databases/pear-DB
-.endif
-
-.if ${PORT_OPTIONS:MPEAR_MDB}
-RUN_DEPENDS+= ${PEARDIR}/MDB.php:${PORTSDIR}/databases/pear-MDB
-.endif
-
-.if ${PORT_OPTIONS:MPEAR_MDB2}
-RUN_DEPENDS+= ${PEARDIR}/MDB2.php:${PORTSDIR}/databases/pear-MDB2
-.endif
-
-.if ${PORT_OPTIONS:MPEAR_LOG}
-RUN_DEPENDS+= ${PEARDIR}/Log/null.php:${PORTSDIR}/sysutils/pear-Log
-.endif
-
-.if ${PORT_OPTIONS:MPEAR_XML_TREE}
-RUN_DEPENDS+= ${PEARDIR}/XML/Tree.php:${PORTSDIR}/devel/pear-XML_Tree
-.endif
-
-.if ${PORT_OPTIONS:MPEAR_CRYPT_RC4}
-RUN_DEPENDS+= ${PEARDIR}/Crypt/Rc4.php:${PORTSDIR}/security/pear-Crypt_RC4
-.endif
-
-.include "${PORTSDIR}/devel/pear/bsd.pear.mk"
.include <bsd.port.mk>