aboutsummaryrefslogtreecommitdiff
path: root/security/pear-LiveUser_Admin
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2005-01-29 18:43:19 +0000
committerPav Lucistnik <pav@FreeBSD.org>2005-01-29 18:43:19 +0000
commita6a49547c9b661edb1a0b17e450e1d755933c201 (patch)
treea26cf6690107198311c4be5dac44b0122635d9a5 /security/pear-LiveUser_Admin
parentdf6b6e4fb9fd50ff2eb15f61267635cc2adb3897 (diff)
downloadports-a6a49547c9b661edb1a0b17e450e1d755933c201.tar.gz
ports-a6a49547c9b661edb1a0b17e450e1d755933c201.zip
Notes
Diffstat (limited to 'security/pear-LiveUser_Admin')
-rw-r--r--security/pear-LiveUser_Admin/Makefile81
-rw-r--r--security/pear-LiveUser_Admin/distinfo2
-rw-r--r--security/pear-LiveUser_Admin/pkg-descr5
3 files changed, 88 insertions, 0 deletions
diff --git a/security/pear-LiveUser_Admin/Makefile b/security/pear-LiveUser_Admin/Makefile
new file mode 100644
index 000000000000..3250f4a7f0eb
--- /dev/null
+++ b/security/pear-LiveUser_Admin/Makefile
@@ -0,0 +1,81 @@
+# Ports collection makefile for: pear-LiveUser_Admin
+# Date created: 25 January 2005
+# Whom: Antonio Carlos Venancio Junior (<antonio@inf.ufsc.br>)
+#
+# $FreeBSD$
+#
+
+PORTNAME= LiveUser_Admin
+PORTVERSION= 0.1.0
+CATEGORIES= security www pear
+
+MAINTAINER= antonio@php.net
+COMMENT= PEAR user authentication and permission management framework
+
+BUILD_DEPENDS= ${PEARDIR}/LiveUser/LiveUser.php:${PORTSDIR}/security/pear-LiveUser
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+USE_PHP= yes
+
+LATEST_LINK= pear-LiveUser_Admin
+OPTIONS= PEAR_DB "PEAR::DB support" on \
+ PEAR_MDB "PEAR::MDB support" off \
+ PEAR_MDB2 "PEAR::MDB2 support" off \
+ PEAR_LOG "PEAR::Log support" off \
+ PEAR_XML_TREE "PEAR::XML_Tree support" off \
+ PEAR_CRYPT_RC4 "PEAR::Crypt_RC4 support" off
+
+CATEGORY= LiveUser
+FILES= Admin/Auth/Common.php Admin/Auth/DB.php Admin/Auth/MDB.php \
+ Admin/Auth/MDB2.php Admin/Perm/Complex.php Admin/Perm/Medium.php \
+ Admin/Perm/Simple.php Admin/Perm/Storage/MDB2.php \
+ Admin/Storage/MDB2.php Admin/Storage/SQL.php \
+ Admin.php Admin/Storage.php
+EXAMPLES= Auth_XML.xml test.php example1/Application.php \
+ example1/Area.php example1/config.inc.php \
+ example1/create_db.sql example1/extra_sql.sql \
+ example1/Group.php example1/GroupRights.php \
+ example1/ImplyRights.php example1/index.php \
+ example1/OutputRightsConstants.php example1/Rights.php \
+ example1/Subgroups.php example1/User.php \
+ example1/UserGroup.php example1/UserRights.php \
+ example3/area51.php example3/coffeemaker.php example3/conf.php \
+ example3/demodata.sql example3/example.php example3/index.html \
+ example3/loginscreen.php example3/main.php example3/nav.php \
+ example3/testarea.php
+_EXAMPLESDIR= docs/examples
+
+post-extract:
+ @${MKDIR} ${WRKSRC}/Admin
+ @${MV} ${WRKSRC}/Auth ${WRKSRC}/Admin/
+ @${MV} ${WRKSRC}/[P-S]* ${WRKSRC}/Admin/
+ @${MV} ${WRKSRC}/docs/examples/example\ 1 ${WRKSRC}/docs/examples/example1
+
+.include <bsd.port.pre.mk>
+
+.if !defined(WITHOUT_PEAR_DB)
+BUILD_DEPENDS+= ${PEARDIR}/DB.php:${PORTSDIR}/databases/pear-DB
+.endif
+
+.if defined(WITH_PEAR_MDB)
+BUILD_DEPENDS+= ${PEARDIR}/MDB.php:${PORTSDIR}/databases/pear-MDB
+.endif
+
+.if defined(WITH_PEAR_MDB2)
+BUILD_DEPENDS+= ${PEARDIR}/MDB2.php:${PORTSDIR}/databases/pear-MDB2
+.endif
+
+.if defined(WITH_PEAR_LOG)
+BUILD_DEPENDS+= ${PEARDIR}/Log.php:${PORTSDIR}/sysutils/pear-Log
+.endif
+
+.if defined(WITH_PEAR_XML_TREE)
+BUILD_DEPENDS+= ${PEARDIR}/XML/Tree.php:${PORTSDIR}/devel/pear-XML_Tree
+.endif
+
+.if defined(WITH_PEAR_CRYPT_RC4)
+BUILD_DEPENDS+= ${PEARDIR}/Crypt/Rc4.php:${PORTSDIR}/security/pear-Crypt_RC4
+.endif
+
+.include "${PORTSDIR}/devel/pear-PEAR/Makefile.common"
+.include <bsd.port.post.mk>
diff --git a/security/pear-LiveUser_Admin/distinfo b/security/pear-LiveUser_Admin/distinfo
new file mode 100644
index 000000000000..fb15c6157ef3
--- /dev/null
+++ b/security/pear-LiveUser_Admin/distinfo
@@ -0,0 +1,2 @@
+MD5 (PEAR/LiveUser_Admin-0.1.0.tgz) = 918cea831fe15027e4fa8ce368e6950b
+SIZE (PEAR/LiveUser_Admin-0.1.0.tgz) = 35391
diff --git a/security/pear-LiveUser_Admin/pkg-descr b/security/pear-LiveUser_Admin/pkg-descr
new file mode 100644
index 000000000000..c28bbd31fb49
--- /dev/null
+++ b/security/pear-LiveUser_Admin/pkg-descr
@@ -0,0 +1,5 @@
+LiveUser_Admin is meant to be used with the LiveUser package.
+It is composed of all the classes necessary to administrate
+data used by LiveUser.
+
+WWW: http://pear.php.net/package/LiveUser_Admin/