aboutsummaryrefslogtreecommitdiff
path: root/security/pear-LiveUser_Admin
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2005-03-17 00:05:15 +0000
committerPav Lucistnik <pav@FreeBSD.org>2005-03-17 00:05:15 +0000
commit38d7ef161bc83ca095fbb8d37a93916ed0918f8c (patch)
tree27d94f6d5965c513f2f8bfa9bf0dce4e47c78e67 /security/pear-LiveUser_Admin
parent23488656044dc184f357418fb42025bf898924ad (diff)
downloadports-38d7ef161bc83ca095fbb8d37a93916ed0918f8c.tar.gz
ports-38d7ef161bc83ca095fbb8d37a93916ed0918f8c.zip
Notes
Diffstat (limited to 'security/pear-LiveUser_Admin')
-rw-r--r--security/pear-LiveUser_Admin/Makefile54
-rw-r--r--security/pear-LiveUser_Admin/distinfo4
2 files changed, 25 insertions, 33 deletions
diff --git a/security/pear-LiveUser_Admin/Makefile b/security/pear-LiveUser_Admin/Makefile
index 3250f4a7f0eb..ad50523ccb1c 100644
--- a/security/pear-LiveUser_Admin/Makefile
+++ b/security/pear-LiveUser_Admin/Makefile
@@ -6,8 +6,8 @@
#
PORTNAME= LiveUser_Admin
-PORTVERSION= 0.1.0
-CATEGORIES= security www pear
+PORTVERSION= 0.2.0
+CATEGORIES= security pear
MAINTAINER= antonio@php.net
COMMENT= PEAR user authentication and permission management framework
@@ -15,66 +15,58 @@ COMMENT= PEAR user authentication and permission management framework
BUILD_DEPENDS= ${PEARDIR}/LiveUser/LiveUser.php:${PORTSDIR}/security/pear-LiveUser
RUN_DEPENDS= ${BUILD_DEPENDS}
-USE_PHP= yes
-
LATEST_LINK= pear-LiveUser_Admin
-OPTIONS= PEAR_DB "PEAR::DB support" on \
+OPTIONS= PEAR_DB "PEAR::DB support" off \
PEAR_MDB "PEAR::MDB support" off \
PEAR_MDB2 "PEAR::MDB2 support" off \
PEAR_LOG "PEAR::Log support" off \
PEAR_XML_TREE "PEAR::XML_Tree support" off \
PEAR_CRYPT_RC4 "PEAR::Crypt_RC4 support" off
-CATEGORY= LiveUser
-FILES= Admin/Auth/Common.php Admin/Auth/DB.php Admin/Auth/MDB.php \
- Admin/Auth/MDB2.php Admin/Perm/Complex.php Admin/Perm/Medium.php \
- Admin/Perm/Simple.php Admin/Perm/Storage/MDB2.php \
- Admin/Storage/MDB2.php Admin/Storage/SQL.php \
- Admin.php Admin/Storage.php
-EXAMPLES= Auth_XML.xml test.php example1/Application.php \
- example1/Area.php example1/config.inc.php \
- example1/create_db.sql example1/extra_sql.sql \
- example1/Group.php example1/GroupRights.php \
+CATEGORY= LiveUser/Admin
+FILES= Auth/Common.php Auth/DB.php Auth/MDB.php Auth/MDB2.php Perm/Complex.php \
+ Perm/Medium.php Perm/Simple.php Perm/Storage/DB.php Perm/Storage/MDB.php \
+ Perm/Storage/MDB2.php Storage/DB.php Storage/MDB.php Storage/MDB2.php \
+ Storage/SQL.php Admin.php Storage.php
+EXAMPLES= Auth_XML.xml test.php example1/Application.php example1/Area.php \
+ example1/Area_Admin_Areas.php example1/config.inc.php \
+ example1/extra_sql.sql example1/Group.php example1/GroupRights.php \
example1/ImplyRights.php example1/index.php \
example1/OutputRightsConstants.php example1/Rights.php \
- example1/Subgroups.php example1/User.php \
- example1/UserGroup.php example1/UserRights.php \
- example3/area51.php example3/coffeemaker.php example3/conf.php \
- example3/demodata.sql example3/example.php example3/index.html \
- example3/loginscreen.php example3/main.php example3/nav.php \
- example3/testarea.php
+ example1/Subgroups.php example1/Translation.php example1/User.php \
+ example1/UserGroup.php example1/UserRights.php example3/area51.php \
+ example3/coffeemaker.php example3/conf.php example3/demodata.sql \
+ example3/example.php example3/index.html example3/loginscreen.php \
+ example3/main.php example3/nav.php example3/testarea.php
_EXAMPLESDIR= docs/examples
post-extract:
- @${MKDIR} ${WRKSRC}/Admin
- @${MV} ${WRKSRC}/Auth ${WRKSRC}/Admin/
- @${MV} ${WRKSRC}/[P-S]* ${WRKSRC}/Admin/
@${MV} ${WRKSRC}/docs/examples/example\ 1 ${WRKSRC}/docs/examples/example1
.include <bsd.port.pre.mk>
-.if !defined(WITHOUT_PEAR_DB)
-BUILD_DEPENDS+= ${PEARDIR}/DB.php:${PORTSDIR}/databases/pear-DB
+.if defined(WITH_PEAR_DB)
+RUN_DEPENDS+= ${PEARDIR}/DB.php:${PORTSDIR}/databases/pear-DB
.endif
.if defined(WITH_PEAR_MDB)
-BUILD_DEPENDS+= ${PEARDIR}/MDB.php:${PORTSDIR}/databases/pear-MDB
+RUN_DEPENDS+= ${PEARDIR}/MDB.php:${PORTSDIR}/databases/pear-MDB
.endif
.if defined(WITH_PEAR_MDB2)
-BUILD_DEPENDS+= ${PEARDIR}/MDB2.php:${PORTSDIR}/databases/pear-MDB2
+RUN_DEPENDS+= ${PEARDIR}/MDB2.php:${PORTSDIR}/databases/pear-MDB2
.endif
.if defined(WITH_PEAR_LOG)
-BUILD_DEPENDS+= ${PEARDIR}/Log.php:${PORTSDIR}/sysutils/pear-Log
+RUN_DEPENDS+= ${PEARDIR}/Log.php:${PORTSDIR}/sysutils/pear-Log
.endif
.if defined(WITH_PEAR_XML_TREE)
-BUILD_DEPENDS+= ${PEARDIR}/XML/Tree.php:${PORTSDIR}/devel/pear-XML_Tree
+RUN_DEPENDS+= ${PEARDIR}/XML/Tree.php:${PORTSDIR}/devel/pear-XML_Tree
.endif
.if defined(WITH_PEAR_CRYPT_RC4)
-BUILD_DEPENDS+= ${PEARDIR}/Crypt/Rc4.php:${PORTSDIR}/security/pear-Crypt_RC4
+RUN_DEPENDS+= ${PEARDIR}/Crypt/Rc4.php:${PORTSDIR}/security/pear-Crypt_RC4
.endif
.include "${PORTSDIR}/devel/pear-PEAR/Makefile.common"
diff --git a/security/pear-LiveUser_Admin/distinfo b/security/pear-LiveUser_Admin/distinfo
index fb15c6157ef3..bb8087e24ab1 100644
--- a/security/pear-LiveUser_Admin/distinfo
+++ b/security/pear-LiveUser_Admin/distinfo
@@ -1,2 +1,2 @@
-MD5 (PEAR/LiveUser_Admin-0.1.0.tgz) = 918cea831fe15027e4fa8ce368e6950b
-SIZE (PEAR/LiveUser_Admin-0.1.0.tgz) = 35391
+MD5 (PEAR/LiveUser_Admin-0.2.0.tgz) = 444da8abad9f33f6ac655d9e2ceb49a9
+SIZE (PEAR/LiveUser_Admin-0.2.0.tgz) = 44337