aboutsummaryrefslogtreecommitdiff
path: root/security/pecl-crypto
diff options
context:
space:
mode:
authorJason Unovitch <junovitch@FreeBSD.org>2015-11-20 03:55:34 +0000
committerJason Unovitch <junovitch@FreeBSD.org>2015-11-20 03:55:34 +0000
commitc862bdb809bf00e073af89bb88629a712f8cac96 (patch)
tree8af4a66feaa887aca6f25c01769230421d969c86 /security/pecl-crypto
parentc2776ba097ab62a7bdfe249333cb2c980602dd45 (diff)
Notes
Diffstat (limited to 'security/pecl-crypto')
-rw-r--r--security/pecl-crypto/Makefile4
-rw-r--r--security/pecl-crypto/distinfo4
-rw-r--r--security/pecl-crypto/files/patch-config.m46
3 files changed, 7 insertions, 7 deletions
diff --git a/security/pecl-crypto/Makefile b/security/pecl-crypto/Makefile
index 6b6c631b9268..3388481d105c 100644
--- a/security/pecl-crypto/Makefile
+++ b/security/pecl-crypto/Makefile
@@ -2,11 +2,10 @@
# $FreeBSD$
PORTNAME= crypto
-PORTVERSION= 0.1.1
+PORTVERSION= 0.2.1
CATEGORIES= security
MASTER_SITES= http://pecl.php.net/get/
PKGNAMEPREFIX= pecl-
-EXTRACT_SUFX= .tgz
DIST_SUBDIR= PECL
MAINTAINER= gasol.wu@gmail.com
@@ -14,6 +13,7 @@ COMMENT= Objective wrapper for OpenSSL Crypto Library
LICENSE= PHP301
+USES= tar:tgz
CONFIGURE_ARGS= --with-crypto
USE_OPENSSL= yes
USE_PHP= yes
diff --git a/security/pecl-crypto/distinfo b/security/pecl-crypto/distinfo
index 9775492859fc..cea9a226dfc9 100644
--- a/security/pecl-crypto/distinfo
+++ b/security/pecl-crypto/distinfo
@@ -1,2 +1,2 @@
-SHA256 (PECL/crypto-0.1.1.tgz) = 9844e93078ac165255bdba6944abf6ec196be9964f9807df9f8f7d792a18807b
-SIZE (PECL/crypto-0.1.1.tgz) = 31097
+SHA256 (PECL/crypto-0.2.1.tgz) = de43f7616ebb604ea8dee21ce7a8219d57aaf400b4651fd55cab9198c2666bca
+SIZE (PECL/crypto-0.2.1.tgz) = 66286
diff --git a/security/pecl-crypto/files/patch-config.m4 b/security/pecl-crypto/files/patch-config.m4
index 20120bc9846b..632dd37fb1a8 100644
--- a/security/pecl-crypto/files/patch-config.m4
+++ b/security/pecl-crypto/files/patch-config.m4
@@ -1,6 +1,6 @@
---- ./config.m4.orig 2014-01-06 13:47:54.000000000 +0800
-+++ ./config.m4 2014-01-06 13:48:11.000000000 +0800
-@@ -17,6 +17,8 @@
+--- config.m4.orig 2015-11-15 21:36:25 UTC
++++ config.m4
+@@ -17,6 +17,8 @@ if test "$PHP_CRYPTO" != "no"; then
PHP_ADD_INCLUDE($OPENSSL_INCDIR)
CRYPTO_LIBS=`$PKG_CONFIG --libs openssl`
PHP_EVAL_LIBLINE($CRYPTO_LIBS, CRYPTO_SHARED_LIBADD)