aboutsummaryrefslogtreecommitdiff
path: root/security/pecl-crypto
diff options
context:
space:
mode:
authorMark Linimon <linimon@FreeBSD.org>2018-11-18 18:24:44 +0000
committerMark Linimon <linimon@FreeBSD.org>2018-11-18 18:24:44 +0000
commit27a56e3bdf9b2a765895f95cb2af452c9efba386 (patch)
tree71afae03594b147b5ab4e15122a4286999e99c9b /security/pecl-crypto
parentff48342d45d3289c344fe18ce6d575bd95f86cb3 (diff)
downloadports-27a56e3bdf9b2a765895f95cb2af452c9efba386.tar.gz
ports-27a56e3bdf9b2a765895f95cb2af452c9efba386.zip
Add compiler:c++11-lang to fix compiler detection on powerpc64.
May also fix build on other archs (not yet tested). Approved by: portmgr (tier-2 blanket)
Notes
Notes: svn path=/head/; revision=485238
Diffstat (limited to 'security/pecl-crypto')
-rw-r--r--security/pecl-crypto/Makefile3
1 files changed, 1 insertions, 2 deletions
diff --git a/security/pecl-crypto/Makefile b/security/pecl-crypto/Makefile
index 96f23630e5f9..34042c77f4a8 100644
--- a/security/pecl-crypto/Makefile
+++ b/security/pecl-crypto/Makefile
@@ -15,9 +15,8 @@ BROKEN_armv6= fails to configure: C compiler cannot create executables
BROKEN_armv7= fails to configure: C compiler cannot create executables
BROKEN_mips= fails to configure: C compiler cannot create executables
BROKEN_mips64= fails to configure: C compiler cannot create executables
-BROKEN_powerpc64= fails to configure: C compiler cannot create executables
-USES= php:pecl
+USES= compiler:c++11-lang php:pecl
CONFIGURE_ARGS= --with-crypto
CFLAGS+= -I${OPENSSLINC}
LDFLAGS+= -L${OPENSSLLIB}