aboutsummaryrefslogtreecommitdiff
path: root/security/pecl-gnupg/Makefile
diff options
context:
space:
mode:
authorMarcus Alves Grando <mnag@FreeBSD.org>2006-03-16 21:40:45 +0000
committerMarcus Alves Grando <mnag@FreeBSD.org>2006-03-16 21:40:45 +0000
commit701e124a49266fc86c09ac07ba8ef025dcd2531f (patch)
tree9927cf0d1a019e453408b1339eba2be2e93e0eb4 /security/pecl-gnupg/Makefile
parent3f0436f7710b52484945b793d4aaab23cf89af4e (diff)
Notes
Diffstat (limited to 'security/pecl-gnupg/Makefile')
-rw-r--r--security/pecl-gnupg/Makefile53
1 files changed, 53 insertions, 0 deletions
diff --git a/security/pecl-gnupg/Makefile b/security/pecl-gnupg/Makefile
new file mode 100644
index 000000000000..d7e345233d56
--- /dev/null
+++ b/security/pecl-gnupg/Makefile
@@ -0,0 +1,53 @@
+# Ports collection makefile for: pear-gnupg
+# Date created: 16 March 2006
+# Whom: mnag@FreeBSD.org
+#
+# $FreeBSD$
+#
+
+PORTNAME= gnupg
+PORTVERSION= 1.1
+CATEGORIES= security
+MASTER_SITES= http://pecl.php.net/get/
+PKGNAMEPREFIX= pecl-
+EXTRACT_SUFX= .tgz
+DIST_SUBDIR= PECL
+
+MAINTAINER= mnag@FreeBSD.org
+COMMENT= A pecl wrapper around the gpgme library
+
+LIB_DEPENDS= gpgme.15:${PORTSDIR}/security/gpgme
+
+USE_PHP= yes
+USE_PHPEXT= yes
+PHP_MODNAME= gnupg
+
+CONFIGURE_ARGS= --with-gnupg=${LOCALBASE}/include/gpgme
+CFLAGS= -I${LOCALBASE}/include
+LDFLAGS= -L${LOCALBASE}/lib
+
+EXAMPLESDIR= ${PREFIX}/share/examples/${PKGNAMEPREFIX}${PORTNAME}
+
+PLIST_FILES= %%EXAMPLESDIR%%/clearsign.php %%EXAMPLESDIR%%/decrypt.php \
+ %%EXAMPLESDIR%%/encrypt.php %%EXAMPLESDIR%%/encryptsign.php \
+ %%EXAMPLESDIR%%/export.php %%EXAMPLESDIR%%/import.php \
+ %%EXAMPLESDIR%%/keyinfo.php %%EXAMPLESDIR%%/main.php \
+ %%EXAMPLESDIR%%/verify.php
+PLIST_DIRS= %%EXAMPLESDIR%%
+
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} < 500000 && ${PHP_VER} == 5
+USE_GCC= 3.2+
+.endif
+
+post-patch:
+ @${REINPLACE_CMD} -e "s|\$$GNUPG_DIR/include|${LOCALBASE}/include/gpgme|" \
+ -e "s|\$$GNUPG_DIR/lib|${LOCALBASE}/lib|" -e "s|-ldl||g" \
+ ${WRKSRC}/config.m4
+
+post-install:
+ @${MKDIR} ${EXAMPLESDIR}
+ ${INSTALL_DATA} ${WRKSRC}/examples/*.php ${EXAMPLESDIR}
+
+.include <bsd.port.post.mk>