aboutsummaryrefslogtreecommitdiff
path: root/security/pf
diff options
context:
space:
mode:
authorFoxfair Hu <foxfair@FreeBSD.org>2003-07-18 01:51:24 +0000
committerFoxfair Hu <foxfair@FreeBSD.org>2003-07-18 01:51:24 +0000
commitb21f67a66cf49fc9eab660b3fa4e09a37d66ae7a (patch)
treeb1f1ce0aa42e4061a387edb6a66b5d9614e614f7 /security/pf
parent5bffd2da7649b13b496d802156b0b34623c1279c (diff)
downloadports-b21f67a66cf49fc9eab660b3fa4e09a37d66ae7a.tar.gz
ports-b21f67a66cf49fc9eab660b3fa4e09a37d66ae7a.zip
Notes
Diffstat (limited to 'security/pf')
-rw-r--r--security/pf/Makefile2
-rw-r--r--security/pf/files/patch-af19
2 files changed, 20 insertions, 1 deletions
diff --git a/security/pf/Makefile b/security/pf/Makefile
index cbe8f9623a67..9aba498e9c1f 100644
--- a/security/pf/Makefile
+++ b/security/pf/Makefile
@@ -7,7 +7,7 @@
PORTNAME= pf_freebsd
PORTVERSION= 1.0
-PORTREVISION= 5
+PORTREVISION= 6
CATEGORIES= security ipv6
MASTER_SITES= http://pf4freebsd.love2party.net/
.if defined(WITH_ALTQ) && (${WITH_ALTQ} == "yes")
diff --git a/security/pf/files/patch-af b/security/pf/files/patch-af
new file mode 100644
index 000000000000..9ae4ad0066b7
--- /dev/null
+++ b/security/pf/files/patch-af
@@ -0,0 +1,19 @@
+--- pf/pf_norm.c 3 Jul 2003 02:40:10 -0000 1.2.16.1
++++ pf/pf_norm.c 14 Jul 2003 07:11:17 -0000 1.2.16.2
+@@ -1050,12 +1050,12 @@
+ goto bad;
+ }
+
+- max = fragoff + ip_len;
+ /* Respect maximum length */
+- if (max > IP_MAXPACKET) {
+- DPFPRINTF(("max packet %d\n", max));
++ if (fragoff + ip_len > IP_MAXPACKET) {
++ DPFPRINTF(("max packet %d\n", fragoff + ip_len));
+ goto bad;
+ }
++ max = fragoff + ip_len;
+
+ if ((r->rule_flag & (PFRULE_FRAGCROP|PFRULE_FRAGDROP)) == 0) {
+ /* Fully buffer all of the fragments */
+