aboutsummaryrefslogtreecommitdiff
path: root/security/pgp
diff options
context:
space:
mode:
authorPietro Cerutti <gahr@FreeBSD.org>2008-09-11 22:59:23 +0000
committerPietro Cerutti <gahr@FreeBSD.org>2008-09-11 22:59:23 +0000
commitc2ef790ae103d1971dbe7d765606065e5ac7279c (patch)
tree31b32dbf303706343b0867950bd309099cb89a14 /security/pgp
parente497d7caf77b7178bf8c5c359392e43d76ee4a4c (diff)
Notes
Diffstat (limited to 'security/pgp')
-rw-r--r--security/pgp/Makefile2
-rw-r--r--security/pgp/files/patch-aa16
2 files changed, 12 insertions, 6 deletions
diff --git a/security/pgp/Makefile b/security/pgp/Makefile
index 9075a5f3aa97..0327eb542ab6 100644
--- a/security/pgp/Makefile
+++ b/security/pgp/Makefile
@@ -23,7 +23,7 @@ ALL_TARGET= freebsd-${MACHINE_ARCH}
MAKE_ENV= OS_CFLAGS="${CFLAGS}"
PGPLIB= ${PREFIX}/share/pgp
MAN1= pgp.1 pgp2.1
-ONLY_FOR_ARCHS= i386 alpha
+ONLY_FOR_ARCHS= i386 alpha amd64 sparc64
do-install:
cd ${WRKSRC}; ${INSTALL_PROGRAM} -c -o bin -g bin -m 555 pgp ${PREFIX}/bin
diff --git a/security/pgp/files/patch-aa b/security/pgp/files/patch-aa
index 6dd2d25e0b55..7b1b4fe2d972 100644
--- a/security/pgp/files/patch-aa
+++ b/security/pgp/files/patch-aa
@@ -1,5 +1,5 @@
---- makefile Thu Jan 18 05:42:36 1996
-+++ makefile.new Wed Jun 11 20:50:13 2003
+--- makefile 1996-01-18 04:42:36.000000000 -0600
++++ makefile.patched 2008-09-12 01:55:27.000000000 -0500
@@ -50,7 +50,8 @@
# -DUSE_SELECT to use select() system call
# -DUSE_NBIO to use non-blocking read()
@@ -15,11 +15,11 @@
@echo " 386bsd, 3b1, 3b1_asm, aix370, aix386, amix-68k-gcc, apollo,"
@echo " apollo-gcc, atari,aux(*), aux-gcc, bsd, bsdgcc, convexos,"
- @echo " dgux, djgpp, encore, freebsd, hpux-68k(*), hpux-68k-ansi,"
-+ @echo " dgux, djgpp, encore, freebsd-{alpha,i386}, hpux-68k(*), hpux-68k-ansi,"
++ @echo " dgux, djgpp, encore, freebsd-{alpha,amd64,i386,sparc64}, hpux-68k(*), hpux-68k-ansi,"
@echo " hpux-68k-gcc, hpux-pa(*), hpux-pa-ansi, hpux-pa-gcc,"
@echo " hpux9-pa-ansi, irix, irix_asm, isc, isc_asm, linux, linux-68k,"
@echo " machten, mach_386, mips-ultrix, netbsd, netbsd_68k, newsasm,"
-@@ -171,10 +172,15 @@
+@@ -171,10 +172,21 @@
$(MAKE) all CC=gcc LD=gcc \
CFLAGS="$(RSAINCDIR) -O2 -DHIGHFIRST -DUNIX -DPORTABLE -DIDEA32"
@@ -31,7 +31,13 @@
+ CFLAGS="-DPREFIX=\\\"$(PREFIX)\\\" $(RSAINCDIR) $(OS_CFLAGS) -DUNIX \
+ -DIDEA32 -DASM -DMAX_NAMELEN=255"
+
-+freebsd-alpha:
++freebsd-alpha: freebsd
++
++freebsd-amd64: freebsd
++
++freebsd-sparc64: freebsd
++
++freebsd:
+ $(MAKE) all LD="$(CC) -s" \
+ CFLAGS="-DPREFIX=\\\"$(PREFIX)\\\" $(RSAINCDIR) $(OS_CFLAGS) \
+ -DPORTABLE -DUNIX -DIDEA32 -DMAX_NAMELEN=255"