aboutsummaryrefslogtreecommitdiff
path: root/security/php-Auth_OpenID/Makefile
diff options
context:
space:
mode:
authorCheng-Lung Sung <clsung@FreeBSD.org>2007-06-14 02:41:41 +0000
committerCheng-Lung Sung <clsung@FreeBSD.org>2007-06-14 02:41:41 +0000
commitbf7b398dfa9636dd3671bf0d231e6e91868a53dd (patch)
tree3dd66ba8dd3a1fde4aaf8c2b204c5317ae08b6e6 /security/php-Auth_OpenID/Makefile
parent7e5801288845edf4b7a61b385cfba9f82b06cacd (diff)
downloadports-bf7b398dfa9636dd3671bf0d231e6e91868a53dd.tar.gz
ports-bf7b398dfa9636dd3671bf0d231e6e91868a53dd.zip
Notes
Diffstat (limited to 'security/php-Auth_OpenID/Makefile')
-rw-r--r--security/php-Auth_OpenID/Makefile58
1 files changed, 58 insertions, 0 deletions
diff --git a/security/php-Auth_OpenID/Makefile b/security/php-Auth_OpenID/Makefile
new file mode 100644
index 000000000000..61c6995c17d6
--- /dev/null
+++ b/security/php-Auth_OpenID/Makefile
@@ -0,0 +1,58 @@
+# New ports collection makefile for: php-Auth_OpenID
+# Date created: 2007-04-24
+# Whom: Gea-Suan Lin <gslin@gslin.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Auth_OpenID
+PORTVERSION= 1.2.2
+CATEGORIES= security www pear
+MASTER_SITES= http://www.openidenabled.com/resources/downloads/php-openid/pear/
+PKGNAMEPREFIX= php-
+EXTRACT_SUFX= .tgz
+
+MAINTAINER= gslin@gslin.org
+COMMENT= PHP OpenID library
+
+RUN_DEPENDS= pear:${PORTSDIR}/devel/pear
+BUILD_DEPENDS= ${RUN_DEPENDS}
+
+NO_BUILD= yes
+OPTIONS= BCMATH "Use bcmath instead of libgmp" off \
+ MYSQL "Use mysql" off \
+ PGSQL "Use pgsql" off \
+ SQLITE "Use sqlite" off
+
+USE_PHP= curl
+
+.include <bsd.port.pre.mk>
+
+.ifdef(WITH_BCMATH)
+USE_PHP+= bcmath
+.else
+USE_PHP+= gmp
+.endif
+
+.ifdef(WITH_MYSQL)
+USE_PHP+= mysql
+.endif
+
+.ifdef(WITH_PGSQL)
+USE_PHP+= pgsql
+.endif
+
+.ifdef(WITH_SQLITE)
+USE_PHP+= sqlite
+.endif
+
+do-install:
+ ${MKDIR} ${PREFIX}/share/pear/Auth/OpenID
+ ${CP} ${WRKSRC}/Auth/OpenID.php ${PREFIX}/share/pear/Auth
+ ${CP} ${WRKSRC}/Auth/OpenID/* ${PREFIX}/share/pear/Auth/OpenID
+ ${MKDIR} ${PREFIX}/share/pear/Services/Yadis
+ ${CP} ${WRKSRC}/Services/Yadis/* ${PREFIX}/share/pear/Services/Yadis
+ ${MKDIR} ${EXAMPLESDIR}
+ ${CP} -R ${WRKSRC}/examples/ ${EXAMPLESDIR}
+
+.include <bsd.port.post.mk>