aboutsummaryrefslogtreecommitdiff
path: root/security/php-Auth_OpenID2/Makefile
diff options
context:
space:
mode:
authorBaptiste Daroussin <bapt@FreeBSD.org>2013-04-28 21:02:39 +0000
committerBaptiste Daroussin <bapt@FreeBSD.org>2013-04-28 21:02:39 +0000
commit0b881b0ecebc9440a559f1c2b27758488a1188fa (patch)
tree933fd11da647dda8c169bc24693094174bdc0355 /security/php-Auth_OpenID2/Makefile
parent928d434bd206738b7213dd9b5802c680794a9b10 (diff)
Notes
Diffstat (limited to 'security/php-Auth_OpenID2/Makefile')
-rw-r--r--security/php-Auth_OpenID2/Makefile22
1 files changed, 8 insertions, 14 deletions
diff --git a/security/php-Auth_OpenID2/Makefile b/security/php-Auth_OpenID2/Makefile
index 1a26c1fe6e52..ccefc4cf5041 100644
--- a/security/php-Auth_OpenID2/Makefile
+++ b/security/php-Auth_OpenID2/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: php-Auth_OpenID
-# Date created: 2007-04-24
-# Whom: Gea-Suan Lin <gslin@gslin.org>
-#
+# Created by: Gea-Suan Lin <gslin@gslin.org>
# $FreeBSD$
-#
PORTNAME= Auth_OpenID2
PORTVERSION= 2.1.3
@@ -22,30 +18,28 @@ CONFLICTS= pear-Auth_OpenID-2.*
USE_BZIP2= yes
NO_BUILD= yes
-OPTIONS= BCMATH "Use bcmath instead of libgmp" off \
- MYSQL "Use mysql" off \
- PGSQL "Use pgsql" off \
- SQLITE "Use sqlite" off
+OPTIONS_DEFINE= BCMATH MYSQL PGSQL SQLITE EXAMPLES
+BCMATH_DESC= Use bcmath instead of libgmp
USE_PHP= curl dom
.include <bsd.port.pre.mk>
-.ifdef(WITH_BCMATH)
+.if ${PORT_OPTIONS:MBCMATH}
USE_PHP+= bcmath
.else
USE_PHP+= gmp
.endif
-.ifdef(WITH_MYSQL)
+.if ${PORT_OPTIONS:MMYSQL}
USE_PHP+= mysql
.endif
-.ifdef(WITH_PGSQL)
+.if ${PORT_OPTIONS:MPGSQL}
USE_PHP+= pgsql
.endif
-.ifdef(WITH_SQLITE)
+.if ${PORT_OPTIONS:MSQLITE}
USE_PHP+= sqlite
.endif
@@ -55,7 +49,7 @@ do-install:
${CP} ${WRKSRC}/Auth/OpenID/* ${PREFIX}/share/pear/Auth/OpenID
${MKDIR} ${PREFIX}/share/pear/Auth/Yadis
${CP} -R ${WRKSRC}/Auth/Yadis/* ${PREFIX}/share/pear/Auth/Yadis
-.if !defined(NOPORTEXAMPLES)
+.if ${PORT_OPTIONS:MEXAMPLES}
${MKDIR} ${EXAMPLESDIR}
${CP} -R ${WRKSRC}/examples/ ${EXAMPLESDIR}
.endif