aboutsummaryrefslogtreecommitdiff
path: root/security/php-Auth_OpenID
diff options
context:
space:
mode:
authorCheng-Lung Sung <clsung@FreeBSD.org>2007-06-14 02:41:41 +0000
committerCheng-Lung Sung <clsung@FreeBSD.org>2007-06-14 02:41:41 +0000
commitbf7b398dfa9636dd3671bf0d231e6e91868a53dd (patch)
tree3dd66ba8dd3a1fde4aaf8c2b204c5317ae08b6e6 /security/php-Auth_OpenID
parent7e5801288845edf4b7a61b385cfba9f82b06cacd (diff)
downloadports-bf7b398dfa9636dd3671bf0d231e6e91868a53dd.tar.gz
ports-bf7b398dfa9636dd3671bf0d231e6e91868a53dd.zip
Notes
Diffstat (limited to 'security/php-Auth_OpenID')
-rw-r--r--security/php-Auth_OpenID/Makefile58
-rw-r--r--security/php-Auth_OpenID/distinfo3
-rw-r--r--security/php-Auth_OpenID/pkg-descr5
-rw-r--r--security/php-Auth_OpenID/pkg-plist62
4 files changed, 128 insertions, 0 deletions
diff --git a/security/php-Auth_OpenID/Makefile b/security/php-Auth_OpenID/Makefile
new file mode 100644
index 000000000000..61c6995c17d6
--- /dev/null
+++ b/security/php-Auth_OpenID/Makefile
@@ -0,0 +1,58 @@
+# New ports collection makefile for: php-Auth_OpenID
+# Date created: 2007-04-24
+# Whom: Gea-Suan Lin <gslin@gslin.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Auth_OpenID
+PORTVERSION= 1.2.2
+CATEGORIES= security www pear
+MASTER_SITES= http://www.openidenabled.com/resources/downloads/php-openid/pear/
+PKGNAMEPREFIX= php-
+EXTRACT_SUFX= .tgz
+
+MAINTAINER= gslin@gslin.org
+COMMENT= PHP OpenID library
+
+RUN_DEPENDS= pear:${PORTSDIR}/devel/pear
+BUILD_DEPENDS= ${RUN_DEPENDS}
+
+NO_BUILD= yes
+OPTIONS= BCMATH "Use bcmath instead of libgmp" off \
+ MYSQL "Use mysql" off \
+ PGSQL "Use pgsql" off \
+ SQLITE "Use sqlite" off
+
+USE_PHP= curl
+
+.include <bsd.port.pre.mk>
+
+.ifdef(WITH_BCMATH)
+USE_PHP+= bcmath
+.else
+USE_PHP+= gmp
+.endif
+
+.ifdef(WITH_MYSQL)
+USE_PHP+= mysql
+.endif
+
+.ifdef(WITH_PGSQL)
+USE_PHP+= pgsql
+.endif
+
+.ifdef(WITH_SQLITE)
+USE_PHP+= sqlite
+.endif
+
+do-install:
+ ${MKDIR} ${PREFIX}/share/pear/Auth/OpenID
+ ${CP} ${WRKSRC}/Auth/OpenID.php ${PREFIX}/share/pear/Auth
+ ${CP} ${WRKSRC}/Auth/OpenID/* ${PREFIX}/share/pear/Auth/OpenID
+ ${MKDIR} ${PREFIX}/share/pear/Services/Yadis
+ ${CP} ${WRKSRC}/Services/Yadis/* ${PREFIX}/share/pear/Services/Yadis
+ ${MKDIR} ${EXAMPLESDIR}
+ ${CP} -R ${WRKSRC}/examples/ ${EXAMPLESDIR}
+
+.include <bsd.port.post.mk>
diff --git a/security/php-Auth_OpenID/distinfo b/security/php-Auth_OpenID/distinfo
new file mode 100644
index 000000000000..211ee4b93349
--- /dev/null
+++ b/security/php-Auth_OpenID/distinfo
@@ -0,0 +1,3 @@
+MD5 (Auth_OpenID-1.2.2.tgz) = b8b95892245f39454ac630262993db52
+SHA256 (Auth_OpenID-1.2.2.tgz) = 7ef563e878ee447176bc87ad160a93114610bdc3454beb06bb48176b9701c6bd
+SIZE (Auth_OpenID-1.2.2.tgz) = 87304
diff --git a/security/php-Auth_OpenID/pkg-descr b/security/php-Auth_OpenID/pkg-descr
new file mode 100644
index 000000000000..50787d6f0e3c
--- /dev/null
+++ b/security/php-Auth_OpenID/pkg-descr
@@ -0,0 +1,5 @@
+The PHP OpenID library lets you enable OpenID authentication on sites
+built using PHP. It features the OpenID consumer, Store
+implementations, and an OpenID server.
+
+WWW: http://www.openidenabled.com/openid/libraries/php/
diff --git a/security/php-Auth_OpenID/pkg-plist b/security/php-Auth_OpenID/pkg-plist
new file mode 100644
index 000000000000..805c02e9e1d3
--- /dev/null
+++ b/security/php-Auth_OpenID/pkg-plist
@@ -0,0 +1,62 @@
+@comment $FreeBSD$
+%%EXAMPLESDIR%%/README
+%%EXAMPLESDIR%%/consumer/common.php
+%%EXAMPLESDIR%%/consumer/finish_auth.php
+%%EXAMPLESDIR%%/consumer/index.php
+%%EXAMPLESDIR%%/consumer/try_auth.php
+%%EXAMPLESDIR%%/detect.php
+%%EXAMPLESDIR%%/server/index.php
+%%EXAMPLESDIR%%/server/lib/actions.php
+%%EXAMPLESDIR%%/server/lib/common.php
+%%EXAMPLESDIR%%/server/lib/render.php
+%%EXAMPLESDIR%%/server/lib/render/about.php
+%%EXAMPLESDIR%%/server/lib/render/login.php
+%%EXAMPLESDIR%%/server/lib/render/sites.php
+%%EXAMPLESDIR%%/server/lib/render/trust.php
+%%EXAMPLESDIR%%/server/lib/session.php
+%%EXAMPLESDIR%%/server/openid-server.css
+%%EXAMPLESDIR%%/server/server.php
+%%EXAMPLESDIR%%/server/setup.php
+share/pear/Auth/OpenID.php
+share/pear/Auth/OpenID/Association.php
+share/pear/Auth/OpenID/BigMath.php
+share/pear/Auth/OpenID/Consumer.php
+share/pear/Auth/OpenID/CryptUtil.php
+share/pear/Auth/OpenID/DatabaseConnection.php
+share/pear/Auth/OpenID/DiffieHellman.php
+share/pear/Auth/OpenID/Discover.php
+share/pear/Auth/OpenID/DumbStore.php
+share/pear/Auth/OpenID/FileStore.php
+share/pear/Auth/OpenID/HMACSHA1.php
+share/pear/Auth/OpenID/Interface.php
+share/pear/Auth/OpenID/KVForm.php
+share/pear/Auth/OpenID/MySQLStore.php
+share/pear/Auth/OpenID/Parse.php
+share/pear/Auth/OpenID/PostgreSQLStore.php
+share/pear/Auth/OpenID/SQLStore.php
+share/pear/Auth/OpenID/SQLiteStore.php
+share/pear/Auth/OpenID/Server.php
+share/pear/Auth/OpenID/ServerRequest.php
+share/pear/Auth/OpenID/TrustRoot.php
+share/pear/Auth/OpenID/URINorm.php
+share/pear/Services/Yadis/HTTPFetcher.php
+share/pear/Services/Yadis/Manager.php
+share/pear/Services/Yadis/Misc.php
+share/pear/Services/Yadis/ParanoidHTTPFetcher.php
+share/pear/Services/Yadis/ParseHTML.php
+share/pear/Services/Yadis/PlainHTTPFetcher.php
+share/pear/Services/Yadis/XML.php
+share/pear/Services/Yadis/XRDS.php
+share/pear/Services/Yadis/XRI.php
+share/pear/Services/Yadis/XRIRes.php
+share/pear/Services/Yadis/Yadis.php
+@dirrmtry share/pear/Services/Yadis
+@dirrmtry share/pear/Services
+@dirrmtry share/pear/Auth/OpenID
+@dirrmtry share/pear/Auth
+@dirrmtry share/pear
+@dirrmtry %%EXAMPLESDIR%%/server/lib/render
+@dirrmtry %%EXAMPLESDIR%%/server/lib
+@dirrmtry %%EXAMPLESDIR%%/server
+@dirrmtry %%EXAMPLESDIR%%/consumer
+@dirrmtry %%EXAMPLESDIR%%