aboutsummaryrefslogtreecommitdiff
path: root/security/php-suhosin
diff options
context:
space:
mode:
authorAlex Dupre <ale@FreeBSD.org>2014-03-26 13:20:50 +0000
committerAlex Dupre <ale@FreeBSD.org>2014-03-26 13:20:50 +0000
commit7c2af9fa636c0a8e05a998a7408274ae34fc2253 (patch)
tree5edf30da971d9c32e2c368ba601204d40dfad670 /security/php-suhosin
parent3a4c21aab6a383ed4116a62e92d12543ebdd058a (diff)
downloadports-7c2af9fa636c0a8e05a998a7408274ae34fc2253.tar.gz
ports-7c2af9fa636c0a8e05a998a7408274ae34fc2253.zip
Notes
Diffstat (limited to 'security/php-suhosin')
-rw-r--r--security/php-suhosin/Makefile14
-rw-r--r--security/php-suhosin/distinfo4
-rw-r--r--security/php-suhosin/files/patch-execute.c20
-rw-r--r--security/php-suhosin/files/patch-post_handler.c10
4 files changed, 10 insertions, 38 deletions
diff --git a/security/php-suhosin/Makefile b/security/php-suhosin/Makefile
index 5ab9766266c3..f654a133bd62 100644
--- a/security/php-suhosin/Makefile
+++ b/security/php-suhosin/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= suhosin
-PORTVERSION= 0.9.33
+PORTVERSION= 0.9.35
CATEGORIES= security
MASTER_SITES= http://download.suhosin.org/
PKGNAMEPREFIX= php-
@@ -11,16 +11,18 @@ EXTRACT_SUFX= .tgz
MAINTAINER= ale@FreeBSD.org
COMMENT= A PHP extension that implements high-level protections
+LICENSE= PHP301
+
+OPTIONS_DEFINE= EXAMPLES
+
USE_PHP= yes
USE_PHPEXT= yes
-DEFAULT_PHP_VER=53
-IGNORE_WITH_PHP=5 55
+IGNORE_WITH_PHP=53
CONFIGURE_ARGS= --enable-suhosin
-NO_STAGE= yes
post-install:
- ${MKDIR} ${EXAMPLESDIR}
- ${INSTALL_DATA} ${WRKSRC}/suhosin.ini ${EXAMPLESDIR}
+ ${MKDIR} ${STAGEDIR}${EXAMPLESDIR}
+ ${INSTALL_DATA} ${WRKSRC}/suhosin.ini ${STAGEDIR}${EXAMPLESDIR}
.include <bsd.port.mk>
diff --git a/security/php-suhosin/distinfo b/security/php-suhosin/distinfo
index b5efd265dcc6..7ff8d1606ab2 100644
--- a/security/php-suhosin/distinfo
+++ b/security/php-suhosin/distinfo
@@ -1,2 +1,2 @@
-SHA256 (suhosin-0.9.33.tgz) = 865b1c72bae9a5a710fe0b07a0635556ce6c838653ec364d2a2a6e6f594529c5
-SIZE (suhosin-0.9.33.tgz) = 104488
+SHA256 (suhosin-0.9.35.tgz) = 19de2eb1b6060bd09fda18bb2402dbcc14bd55aa366a482f37a55501b9980f21
+SIZE (suhosin-0.9.35.tgz) = 129287
diff --git a/security/php-suhosin/files/patch-execute.c b/security/php-suhosin/files/patch-execute.c
deleted file mode 100644
index 579d04967bd1..000000000000
--- a/security/php-suhosin/files/patch-execute.c
+++ /dev/null
@@ -1,20 +0,0 @@
---- execute.c.orig 2011-06-21 12:07:15.000000000 +0200
-+++ execute.c 2011-06-21 12:08:30.000000000 +0200
-@@ -1087,7 +1087,7 @@
- zend_str_tolower(lcname, func_name_len);
- #else
- if (zend_parse_parameters(ZEND_NUM_ARGS() TSRMLS_CC, "s", &lcname, &func_name_len) == FAILURE) {
-- return;
-+ return 0;
- }
-
- /* Ignore leading "\" */
-@@ -1501,7 +1501,7 @@
- {
- #ifdef PHP_ATLEAST_5_3
- if (zend_parse_parameters_none() == FAILURE) {
-- return;
-+ return 0;
- }
- #else
- int argc = ZEND_NUM_ARGS();
diff --git a/security/php-suhosin/files/patch-post_handler.c b/security/php-suhosin/files/patch-post_handler.c
deleted file mode 100644
index 33c9b7da76c9..000000000000
--- a/security/php-suhosin/files/patch-post_handler.c
+++ /dev/null
@@ -1,10 +0,0 @@
---- post_handler.c.orig 2012-02-09 17:17:35.000000000 +0100
-+++ post_handler.c 2012-02-09 17:17:58.000000000 +0100
-@@ -165,6 +165,7 @@
- void suhosin_unhook_post_handlers()
- {
- zend_ini_entry *ini_entry;
-+ TSRMLS_FETCH();
-
- /* Restore to an empty destructor */
- SG(known_post_content_types).pDestructor = NULL;