aboutsummaryrefslogtreecommitdiff
path: root/security/php-suhosin
diff options
context:
space:
mode:
authorAlex Dupre <ale@FreeBSD.org>2006-09-04 08:02:04 +0000
committerAlex Dupre <ale@FreeBSD.org>2006-09-04 08:02:04 +0000
commitbcfcdf474c0fd3c83fd4e718754c62131152729f (patch)
treecb63ce1695b96613ccbf978627067ad8ef941181 /security/php-suhosin
parent22d7767b09faaf3c56940f3ec68360257a326124 (diff)
downloadports-bcfcdf474c0fd3c83fd4e718754c62131152729f.tar.gz
ports-bcfcdf474c0fd3c83fd4e718754c62131152729f.zip
Notes
Diffstat (limited to 'security/php-suhosin')
-rw-r--r--security/php-suhosin/Makefile26
-rw-r--r--security/php-suhosin/distinfo3
-rw-r--r--security/php-suhosin/pkg-descr18
3 files changed, 47 insertions, 0 deletions
diff --git a/security/php-suhosin/Makefile b/security/php-suhosin/Makefile
new file mode 100644
index 000000000000..57cb71acde37
--- /dev/null
+++ b/security/php-suhosin/Makefile
@@ -0,0 +1,26 @@
+# New ports collection makefile for: suhosin
+# Date created: 4 Sep 2006
+# Whom: ale
+#
+# $FreeBSD$
+#
+
+PORTNAME= suhosin
+PORTVERSION= 0.9.0
+CATEGORIES= security
+MASTER_SITES= http://www.hardened-php.net/suhosin/_media/
+PKGNAMEPREFIX= php-
+DISTNAME= ${PORTNAME}-200609031730
+EXTRACT_SUFX= .tgz
+
+MAINTAINER= ale@FreeBSD.org
+COMMENT= A PHP extension that implements high-level protections
+
+WRKSRC= ${WRKDIR}/${PORTNAME}
+
+USE_PHP= yes
+USE_PHPEXT= yes
+
+CONFIGURE_ARGS= --enable-suhosin
+
+.include <bsd.port.mk>
diff --git a/security/php-suhosin/distinfo b/security/php-suhosin/distinfo
new file mode 100644
index 000000000000..8f31d5ac3d7c
--- /dev/null
+++ b/security/php-suhosin/distinfo
@@ -0,0 +1,3 @@
+MD5 (suhosin-200609031730.tgz) = b6da7979406d38a0f5bdd890b26d2033
+SHA256 (suhosin-200609031730.tgz) = 18c09f2e172b08519094a71b7431bf4142cfa5607ed7b52cf67599b5ab18d6bd
+SIZE (suhosin-200609031730.tgz) = 60661
diff --git a/security/php-suhosin/pkg-descr b/security/php-suhosin/pkg-descr
new file mode 100644
index 000000000000..28b7d777d751
--- /dev/null
+++ b/security/php-suhosin/pkg-descr
@@ -0,0 +1,18 @@
+Suhosin is an advanced protection system for PHP installations.
+It was designed to protect servers and users from known and
+unknown flaws in PHP applications and the PHP core.
+Suhosin comes in two independent parts, that can be used
+separately or in combination. The first part is a small patch
+against the PHP core, that implements a few low-level
+protections against bufferoverflows or format string
+vulnerabilities and the second part is a powerful PHP extension
+that implements all the other protections.
+
+Suhosin is binary compatible to normal PHP installation,
+which means it is compatible to 3rd party binary extension
+like ZendOptimizer.
+
+WWW: http://www.suhosin.org/
+
+- Alex Dupre
+ale@FreeBSD.org