aboutsummaryrefslogtreecommitdiff
path: root/security/pidgin-encryption
diff options
context:
space:
mode:
authorTijl Coosemans <tijl@FreeBSD.org>2014-05-17 16:57:14 +0000
committerTijl Coosemans <tijl@FreeBSD.org>2014-05-17 16:57:14 +0000
commit5795addbba9b9a79c66ce201661b96c571e7ef40 (patch)
treeeae79d4f3cebba3d0e91ecad3c25f200503106b5 /security/pidgin-encryption
parent6462719ce3f9f3a042e8bf6ca531e9b2e8211d5c (diff)
downloadports-5795addbba9b9a79c66ce201661b96c571e7ef40.tar.gz
ports-5795addbba9b9a79c66ce201661b96c571e7ef40.zip
Notes
Diffstat (limited to 'security/pidgin-encryption')
-rw-r--r--security/pidgin-encryption/Makefile31
-rw-r--r--security/pidgin-encryption/pkg-plist3
2 files changed, 11 insertions, 23 deletions
diff --git a/security/pidgin-encryption/Makefile b/security/pidgin-encryption/Makefile
index 539d6eec1d9a..e2d0d89f16ca 100644
--- a/security/pidgin-encryption/Makefile
+++ b/security/pidgin-encryption/Makefile
@@ -3,7 +3,7 @@
PORTNAME= pidgin
PORTVERSION= 3.1
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= security
MASTER_SITES= SF/${PORTNAME}-encrypt/Releases/${PORTVERSION}
PKGNAMESUFFIX= -encryption
@@ -13,37 +13,28 @@ MAINTAINER= perlfu@gmail.com
COMMENT= Encryption Plugin for the Pidgin instant messenger client
BUILD_DEPENDS= ${LOCALBASE}/bin/pidgin:${PORTSDIR}/net-im/pidgin
-LIB_DEPENDS= purple.10:${PORTSDIR}/net-im/libpurple \
- nss3:${PORTSDIR}/security/nss
+RUN_DEPENDS= ${LOCALBASE}/bin/pidgin:${PORTSDIR}/net-im/pidgin
+LIB_DEPENDS= libpurple.so:${PORTSDIR}/net-im/libpurple \
+ libnss3.so:${PORTSDIR}/security/nss
USE_GNOME= gtk20
USES= gettext gmake pkgconfig
GNU_CONFIGURE= yes
-CPPFLAGS+= ${PTHREAD_CFLAGS} -I${LOCALBASE}/include
-LDFLAGS+= -L${LOCALBASE}/lib ${PTHREAD_LIBS}
-CONFIGURE_ARGS= --with-nspr-includes=${LOCALBASE}/include/nspr \
+CPPFLAGS+= -I${LOCALBASE}/include
+LDFLAGS+= -L${LOCALBASE}/lib
+CONFIGURE_ARGS= --disable-static \
+ --with-nspr-includes=${LOCALBASE}/include/nspr \
--with-nspr-libs=${LOCALBASE}/lib \
--with-nss-includes=${LOCALBASE}/include/nss/nss \
--with-nss-libs=${LOCALBASE}/lib/nss
-NO_STAGE= yes
-
OPTIONS_DEFINE= NLS
-
-.include <bsd.port.options.mk>
-
-.if ${PORT_OPTIONS:MNLS}
-USES+= gettext
-CONFIGURE_ARGS+= --with-libintl-prefix=${LOCALBASE}
-PLIST_SUB+= NLS=""
-.else
-CONFIGURE_ARGS+= --disable-nls
-PLIST_SUB+= NLS="@comment "
-.endif
+OPTIONS_SUB= yes
+NLS_CONFIGURE_ENABLE= nls
+NLS_USES= gettext
post-extract:
- @${REINPLACE_CMD} -e 's|echo aout|echo elf|' ${WRKSRC}/configure
@${REINPLACE_CMD} -e 's|glib/.*\.h"|glib.h"|g' ${WRKSRC}/rsa_nss.c
.include <bsd.port.mk>
diff --git a/security/pidgin-encryption/pkg-plist b/security/pidgin-encryption/pkg-plist
index e5ed4e6f0e6e..5b644ff03ceb 100644
--- a/security/pidgin-encryption/pkg-plist
+++ b/security/pidgin-encryption/pkg-plist
@@ -1,5 +1,3 @@
-lib/pidgin/encrypt.a
-lib/pidgin/encrypt.la
lib/pidgin/encrypt.so
%%NLS%%share/locale/cs/LC_MESSAGES/pidgin-encryption.mo
%%NLS%%share/locale/da/LC_MESSAGES/pidgin-encryption.mo
@@ -32,4 +30,3 @@ share/pixmaps/pidgin-encryption/icon_out_capable.png
share/pixmaps/pidgin-encryption/icon_out_lock.png
share/pixmaps/pidgin-encryption/icon_out_unlock.png
@dirrm share/pixmaps/pidgin-encryption
-@dirrmtry lib/pidgin