aboutsummaryrefslogtreecommitdiff
path: root/security/pidgin-encryption
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2007-06-18 11:25:15 +0000
committerMartin Wilke <miwi@FreeBSD.org>2007-06-18 11:25:15 +0000
commit13f2b96a02b89c2b3a87779318b7ee36fdcc18ad (patch)
tree4f3e075d579d7a907bdb84bbcc6d3742874e7913 /security/pidgin-encryption
parent08bd529b3ebec594fa030ebf7483f8f6483c93c5 (diff)
downloadports-13f2b96a02b89c2b3a87779318b7ee36fdcc18ad.tar.gz
ports-13f2b96a02b89c2b3a87779318b7ee36fdcc18ad.zip
Notes
Diffstat (limited to 'security/pidgin-encryption')
-rw-r--r--security/pidgin-encryption/Makefile42
-rw-r--r--security/pidgin-encryption/distinfo6
-rw-r--r--security/pidgin-encryption/pkg-descr23
-rw-r--r--security/pidgin-encryption/pkg-plist45
4 files changed, 50 insertions, 66 deletions
diff --git a/security/pidgin-encryption/Makefile b/security/pidgin-encryption/Makefile
index b438bec3dfd6..2b9436244941 100644
--- a/security/pidgin-encryption/Makefile
+++ b/security/pidgin-encryption/Makefile
@@ -1,52 +1,46 @@
-# New ports collection makefile for: gaim-encryption
+# New ports collection Makefile for: pidgen-encryption
# Date created: 2004-05-01
-# Whom: ports@c0decafe.net
+# Whom: ports@c0decafe.net
#
# $FreeBSD$
#
-PORTNAME= encryption
-PORTVERSION= 2.39
-PORTREVISION= 2
-CATEGORIES= security net
+PORTNAME= pidgin
+PORTVERSION= 3.0
+CATEGORIES= security
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
-MASTER_SITE_SUBDIR= ${PKGNAMEPREFIX}${PORTNAME}
-PKGNAMEPREFIX= gaim-
-DISTNAME= ${PKGNAMEPREFIX}${PORTNAME}-${PORTVERSION}
+MASTER_SITE_SUBDIR= pidgin-encrypt
+PKGNAMESUFFIX= -encryption
+DISTNAME= ${PORTNAME}${PKGNAMESUFFIX}-${PORTVERSION}
-MAINTAINER= ports@c0decafe.net
-COMMENT= Provides transparent RSA encryption as a Gaim plugin
+MAINTAINER= perlfu@gmail.com
+COMMENT= Encryption Plugin for the Pidgin instant messenger client
-BUILD_DEPENDS= ${LOCALBASE}/include/gaim/config.h:${PORTSDIR}/net-im/gaim
-RUN_DEPENDS= gaim:${PORTSDIR}/net-im/gaim
-LIB_DEPENDS= nss3:${PORTSDIR}/security/nss
+BUILD_DEPENDS= ${LOCALBASE}/bin/pidgin:${PORTSDIR}/net-im/pidgin
+LIB_DEPENDS= purple.0:${PORTSDIR}/net-im/libpurple \
+ nss3:${PORTSDIR}/security/nss
USE_XLIB= yes
USE_GMAKE= yes
USE_GNOME= gtk20
GNU_CONFIGURE= yes
+
CONFIGURE_ENV= CPPFLAGS="${PTHREAD_CFLAGS} -I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib ${PTHREAD_LIBS}"
-CONFIGURE_ARGS= --with-nspr-includes=${LOCALBASE}/include/nspr \
- --with-nspr-libs=${LOCALBASE}/lib \
+CONFIGURE_ARGS= --with-nspr-includes=${LOCALBASE}/include/nspr \
+ --with-nspr-libs=${LOCALBASE}/lib \
--with-nss-includes=${LOCALBASE}/include/nss/nss \
--with-nss-libs=${LOCALBASE}/lib/nss
.if !defined(WITHOUT_NLS)
USE_GETTEXT= yes
-CONFIGURE_ARGS+=--with-libintl-prefix=${LOCALBASE}
+CONFIGURE_ARGS+= --with-libintl-prefix=${LOCALBASE}
PLIST_SUB+= NLS=""
.else
-CONFIGURE_ARGS+=--disable-nls
+CONFIGURE_ARGS+= --disable-nls
PLIST_SUB+= NLS="@comment "
.endif
-pre-everything::
- @${ECHO_MSG} ""
- @${ECHO_MSG} "WARNING: make sure net-im/gaim is built with NSS support (it is, by default)"
- @${ECHO_MSG} ""
- @${ECHO_MSG} ""
-
post-extract:
@${REINPLACE_CMD} -e 's|echo aout|echo elf|' ${WRKSRC}/configure
diff --git a/security/pidgin-encryption/distinfo b/security/pidgin-encryption/distinfo
index 2c2af1ee4fe7..e20038773a41 100644
--- a/security/pidgin-encryption/distinfo
+++ b/security/pidgin-encryption/distinfo
@@ -1,3 +1,3 @@
-MD5 (gaim-encryption-2.39.tar.gz) = 2319273397a7970fe149253bdd132465
-SHA256 (gaim-encryption-2.39.tar.gz) = 2fc1848597ae6e1ce74e96bda1c4acfe5ce5493cf78944efeec876e775adf257
-SIZE (gaim-encryption-2.39.tar.gz) = 544306
+MD5 (pidgin-encryption-3.0.tar.gz) = 3f3f8e9a15d19e084d54bfbbd2db9d77
+SHA256 (pidgin-encryption-3.0.tar.gz) = ae754eb1a43d8d2341083187d6f9e2f396b5b521f87a62060369a55516896594
+SIZE (pidgin-encryption-3.0.tar.gz) = 586394
diff --git a/security/pidgin-encryption/pkg-descr b/security/pidgin-encryption/pkg-descr
index 2083c7cc5370..2534a8fd00c2 100644
--- a/security/pidgin-encryption/pkg-descr
+++ b/security/pidgin-encryption/pkg-descr
@@ -1,22 +1,3 @@
-Gaim-Encryption uses NSS to provide transparent RSA encryption as a Gaim plugin.
+Encryption plugin for Pidgin instant messaging client.
-Features include:
- * Automatically creates a public/private key pair for you upon loading
- the plugin
- * Automatically transmits your public key to other users.
- * Supports 512 - 4096 bit keys.
- * Saves keys of known users, and warns you if their public key has
- changed.
- * Embeds all encryption and keys inside HTML, so if the other user
- doesn't have the plugin, they will get a little message telling them
- about the plugin, and won't get a screen full of garbage.
- * Stores keys in human readable files in your .gaim directory, in case
- you ever need to copy/edit them by hand. Which you really shouldn't
- have to do.
- * Automatically recognizes if you are chatting with someone who has the
- plugin- see the Preferences dialog.
- * Modular and extensible. If you want to define a different type of
- encryption, you can use this plugin as a wrapper to take care of
- transporting the encrypted binary over the IM pipe.
-
-WWW: http://gaim-encryption.sourceforge.net/
+WWW: http://pidgin-encrypt.sf.net
diff --git a/security/pidgin-encryption/pkg-plist b/security/pidgin-encryption/pkg-plist
index b0931c89959d..bba06a7b6fa9 100644
--- a/security/pidgin-encryption/pkg-plist
+++ b/security/pidgin-encryption/pkg-plist
@@ -1,18 +1,27 @@
-lib/gaim/encrypt.a
-lib/gaim/encrypt.la
-lib/gaim/encrypt.so
-%%NLS%%share/locale/cs/LC_MESSAGES/gaim-encryption.mo
-%%NLS%%share/locale/da/LC_MESSAGES/gaim-encryption.mo
-%%NLS%%share/locale/de/LC_MESSAGES/gaim-encryption.mo
-%%NLS%%share/locale/es/LC_MESSAGES/gaim-encryption.mo
-%%NLS%%share/locale/fr/LC_MESSAGES/gaim-encryption.mo
-%%NLS%%share/locale/hu/LC_MESSAGES/gaim-encryption.mo
-%%NLS%%share/locale/it/LC_MESSAGES/gaim-encryption.mo
-%%NLS%%share/locale/ja/LC_MESSAGES/gaim-encryption.mo
-%%NLS%%share/locale/nl/LC_MESSAGES/gaim-encryption.mo
-%%NLS%%share/locale/pl/LC_MESSAGES/gaim-encryption.mo
-%%NLS%%share/locale/pt_BR/LC_MESSAGES/gaim-encryption.mo
-%%NLS%%share/locale/ru/LC_MESSAGES/gaim-encryption.mo
-%%NLS%%share/locale/sl/LC_MESSAGES/gaim-encryption.mo
-%%NLS%%share/locale/uk/LC_MESSAGES/gaim-encryption.mo
-%%NLS%%share/locale/zh_TW/LC_MESSAGES/gaim-encryption.mo
+lib/pidgin/encrypt.a
+lib/pidgin/encrypt.la
+lib/pidgin/encrypt.so
+%%NLS%%share/locale/cs/LC_MESSAGES/pidgin-encryption.mo
+%%NLS%%share/locale/da/LC_MESSAGES/pidgin-encryption.mo
+%%NLS%%share/locale/de/LC_MESSAGES/pidgin-encryption.mo
+%%NLS%%share/locale/es/LC_MESSAGES/pidgin-encryption.mo
+%%NLS%%share/locale/fr/LC_MESSAGES/pidgin-encryption.mo
+%%NLS%%share/locale/hu/LC_MESSAGES/pidgin-encryption.mo
+%%NLS%%share/locale/it/LC_MESSAGES/pidgin-encryption.mo
+%%NLS%%share/locale/ja/LC_MESSAGES/pidgin-encryption.mo
+%%NLS%%share/locale/lt/LC_MESSAGES/pidgin-encryption.mo
+%%NLS%%share/locale/nl/LC_MESSAGES/pidgin-encryption.mo
+%%NLS%%share/locale/nn/LC_MESSAGES/pidgin-encryption.mo
+%%NLS%%share/locale/pl/LC_MESSAGES/pidgin-encryption.mo
+%%NLS%%share/locale/pt_BR/LC_MESSAGES/pidgin-encryption.mo
+%%NLS%%share/locale/ro/LC_MESSAGES/pidgin-encryption.mo
+%%NLS%%share/locale/ru/LC_MESSAGES/pidgin-encryption.mo
+%%NLS%%share/locale/sl/LC_MESSAGES/pidgin-encryption.mo
+%%NLS%%share/locale/sv/LC_MESSAGES/pidgin-encryption.mo
+%%NLS%%share/locale/tr/LC_MESSAGES/pidgin-encryption.mo
+%%NLS%%share/locale/uk/LC_MESSAGES/pidgin-encryption.mo
+%%NLS%%share/locale/zh_TW/LC_MESSAGES/pidgin-encryption.mo
+share/pixmaps/pidgin/pidgin-encryption/crypto.png
+@dirrm share/pixmaps/pidgin/pidgin-encryption
+@dirrmtry share/pixmaps/pidgin/
+@dirrmtry lib/pidgin/