aboutsummaryrefslogtreecommitdiff
path: root/security/pidgin-otr/files
diff options
context:
space:
mode:
authorAlexey Dokuchaev <danfe@FreeBSD.org>2005-03-20 10:31:05 +0000
committerAlexey Dokuchaev <danfe@FreeBSD.org>2005-03-20 10:31:05 +0000
commit5b9ca1709b02dd3b254e45bb54b6897912555359 (patch)
treefb4bf31d85205e2ace28ece80b47d4288add82ac /security/pidgin-otr/files
parente9f5f9e5a46d132229955703b1bb864c105bc639 (diff)
downloadports-5b9ca1709b02dd3b254e45bb54b6897912555359.tar.gz
ports-5b9ca1709b02dd3b254e45bb54b6897912555359.zip
Notes
Diffstat (limited to 'security/pidgin-otr/files')
-rw-r--r--security/pidgin-otr/files/patch-Makefile10
-rw-r--r--security/pidgin-otr/files/patch-gaim-otr-Makefile22
-rw-r--r--security/pidgin-otr/files/patch-libotr-Makefile9
-rw-r--r--security/pidgin-otr/files/patch-libotr-context11
-rw-r--r--security/pidgin-otr/files/patch-libotr-privkey11
-rw-r--r--security/pidgin-otr/files/patch-tools-Makefile44
6 files changed, 107 insertions, 0 deletions
diff --git a/security/pidgin-otr/files/patch-Makefile b/security/pidgin-otr/files/patch-Makefile
new file mode 100644
index 000000000000..61a09b299f92
--- /dev/null
+++ b/security/pidgin-otr/files/patch-Makefile
@@ -0,0 +1,10 @@
+--- Makefile.bak Fri Dec 17 16:19:08 2004
++++ Makefile Fri Dec 17 16:19:16 2004
+@@ -1,4 +1,4 @@
+ all install clean distclean:
+- make -C libotr $@
+- make -C gaim-otr $@
+- make -C tools $@
++ gmake -C libotr $@
++ gmake -C gaim-otr $@
++ gmake -C tools $@
diff --git a/security/pidgin-otr/files/patch-gaim-otr-Makefile b/security/pidgin-otr/files/patch-gaim-otr-Makefile
new file mode 100644
index 000000000000..a8f0ce0348c7
--- /dev/null
+++ b/security/pidgin-otr/files/patch-gaim-otr-Makefile
@@ -0,0 +1,22 @@
+--- gaim-otr/Makefile.bak Fri Dec 17 17:11:49 2004
++++ gaim-otr/Makefile Fri Dec 17 17:12:57 2004
+@@ -1,5 +1,5 @@
+ # Replace this with the path to the GAIM headers
+-GAIM_SOURCE ?= /usr/include/gaim
++GAIM_SOURCE ?= %%X11BASE%%/include/gaim
+
+ # If you don't have pkg-config, put the appropriate -I entry on the next line
+ GTK_HDRS ?= `pkg-config --cflags glib-2.0 gtk+-2.0`
+@@ -19,10 +19,10 @@
+ all: $(TARGET)
+
+ $(TARGET): otr-plugin.o ui.o dialogs.o $(LIBOTR_DIR)/libotr.a
+- $(CC) -g -shared -module -avoid-version $^ -o $@ -lgcrypt
++ $(CC) -g -shared -module -avoid-version -L %%LOCALBASE%%/lib $^ -o $@ -lgcrypt
+
+ $(LIBOTR_DIR)/libotr.a: FORCE
+- make -C $(LIBOTR_DIR) libotr.a
++ gmake -C $(LIBOTR_DIR) libotr.a
+
+ install: all
+ install -d $(INSTALLDIR)
diff --git a/security/pidgin-otr/files/patch-libotr-Makefile b/security/pidgin-otr/files/patch-libotr-Makefile
new file mode 100644
index 000000000000..1fb1dc7167ad
--- /dev/null
+++ b/security/pidgin-otr/files/patch-libotr-Makefile
@@ -0,0 +1,9 @@
+--- libotr/Makefile.bak Fri Dec 17 16:31:14 2004
++++ libotr/Makefile Fri Dec 17 16:31:53 2004
+@@ -1,5 +1,5 @@
+ CC ?= gcc
+-override CFLAGS += -g -Wall -fPIC
++CFLAGS += -g -Wall -fPIC -I %%LOCALBASE%%/include
+ LDFLAGS ?= -lgcrypt -g
+
+ all: libotr.a
diff --git a/security/pidgin-otr/files/patch-libotr-context b/security/pidgin-otr/files/patch-libotr-context
new file mode 100644
index 000000000000..63c6ea038f9f
--- /dev/null
+++ b/security/pidgin-otr/files/patch-libotr-context
@@ -0,0 +1,11 @@
+--- libotr/context.h.bak Fri Dec 17 17:14:42 2004
++++ libotr/context.h Fri Dec 17 17:14:53 2004
+@@ -20,7 +20,7 @@
+ #ifndef __CONTEXT_H__
+ #define __CONTEXT_H__
+
+-#include "gcrypt.h"
++#include <gcrypt.h>
+ #include "dh.h"
+
+ typedef enum {
diff --git a/security/pidgin-otr/files/patch-libotr-privkey b/security/pidgin-otr/files/patch-libotr-privkey
new file mode 100644
index 000000000000..f5a7f5be53c6
--- /dev/null
+++ b/security/pidgin-otr/files/patch-libotr-privkey
@@ -0,0 +1,11 @@
+--- libotr/privkey.c.bak Fri Dec 17 16:24:41 2004
++++ libotr/privkey.c Fri Dec 17 16:24:54 2004
+@@ -24,7 +24,7 @@
+ #include <sys/stat.h>
+
+ /* libgcrypt headers */
+-#include "gcrypt.h"
++#include <gcrypt.h>
+
+ /* libotr headers */
+ #include "proto.h"
diff --git a/security/pidgin-otr/files/patch-tools-Makefile b/security/pidgin-otr/files/patch-tools-Makefile
new file mode 100644
index 000000000000..8e538a7c082a
--- /dev/null
+++ b/security/pidgin-otr/files/patch-tools-Makefile
@@ -0,0 +1,44 @@
+--- tools/Makefile.bak Fri Dec 17 17:18:13 2004
++++ tools/Makefile Fri Dec 17 17:20:57 2004
+@@ -9,7 +9,7 @@
+ INSTALLMANDIR = $(DESTDIR)/usr/share/man/man1
+
+ CC ?= gcc
+-override CFLAGS += -g -Wall -I$(LIBOTR_DIR) -fPIC
++override CFLAGS += -g -Wall -I$(LIBOTR_DIR) -I%%LOCALBASE%%/include -L%%LOCALBASE%%/lib -fPIC
+
+ TARGETS = $(TARGET_DIR)/otr_parse \
+ $(TARGET_DIR)/otr_sesskeys \
+@@ -21,25 +21,25 @@
+ all: $(TARGETS)
+
+ $(TARGET_DIR)/otr_parse: otr_parse.o readotr.o parse.o sha1hmac.o $(LIBOTR_DIR)/libotr.a
+- $(CC) -g $^ -o $@ -lgcrypt
++ $(CC) $(CFLAGS) $^ -o $@ -lgcrypt
+
+ $(TARGET_DIR)/otr_sesskeys: otr_sesskeys.o sesskeys.o parse.o sha1hmac.o $(LIBOTR_DIR)/libotr.a
+- $(CC) -g $^ -o $@ -lgcrypt
++ $(CC) $(CFLAGS) $^ -o $@ -lgcrypt
+
+ $(TARGET_DIR)/otr_mackey: otr_mackey.o sesskeys.o parse.o sha1hmac.o $(LIBOTR_DIR)/libotr.a
+- $(CC) -g $^ -o $@ -lgcrypt
++ $(CC) $(CFLAGS) $^ -o $@ -lgcrypt
+
+ $(TARGET_DIR)/otr_readforge: otr_readforge.o readotr.o sesskeys.o parse.o sha1hmac.o aes.o ctrmode.o $(LIBOTR_DIR)/libotr.a
+- $(CC) -g $^ -o $@ -lgcrypt
++ $(CC) $(CFLAGS) $^ -o $@ -lgcrypt
+
+ $(TARGET_DIR)/otr_modify: otr_modify.o readotr.o parse.o sha1hmac.o $(LIBOTR_DIR)/libotr.a
+- $(CC) -g $^ -o $@ -lgcrypt
++ $(CC) $(CFLAGS) $^ -o $@ -lgcrypt
+
+ $(TARGET_DIR)/otr_remac: otr_remac.o parse.o sha1hmac.o $(LIBOTR_DIR)/libotr.a
+- $(CC) -g $^ -o $@ -lgcrypt
++ $(CC) $(CFLAGS) $^ -o $@ -lgcrypt
+
+ $(LIBOTR_DIR)/libotr.a: FORCE
+- make -C $(LIBOTR_DIR) libotr.a
++ gmake -C $(LIBOTR_DIR) libotr.a
+
+ install: all
+ install -d $(INSTALLBINDIR)