aboutsummaryrefslogtreecommitdiff
path: root/security/pinentry
diff options
context:
space:
mode:
authorMichael Nottebrock <lofi@FreeBSD.org>2004-11-04 17:19:01 +0000
committerMichael Nottebrock <lofi@FreeBSD.org>2004-11-04 17:19:01 +0000
commit2cd0b8fd561d824f588dbaa3cf975fbbc49dd958 (patch)
treeb2bcc7e1071127427d799edced1fda75c86d2fe0 /security/pinentry
parent7f352fc47f2842d406f05f5ec1606c78eee3e224 (diff)
downloadports-2cd0b8fd561d824f588dbaa3cf975fbbc49dd958.tar.gz
ports-2cd0b8fd561d824f588dbaa3cf975fbbc49dd958.zip
Notes
Diffstat (limited to 'security/pinentry')
-rw-r--r--security/pinentry/Makefile13
1 files changed, 7 insertions, 6 deletions
diff --git a/security/pinentry/Makefile b/security/pinentry/Makefile
index f4f8186770c9..004db67af283 100644
--- a/security/pinentry/Makefile
+++ b/security/pinentry/Makefile
@@ -34,13 +34,14 @@ CONFIGURE_ARGS+=--with-libiconv-prefix=${LOCALBASE}
.if defined(PINENTRY_QT)
USE_QT_VER= 3
PLIST_SUB+= WITH_QT=""
-.else
-CONFIGURE_ARGS+=--disable-pinentry-qt
-PLIST_SUB+= WITH_QT="@comment "
pre-configure:
- ${REINPLACE_CMD} -e "s@-lpthread@${PTHREAD_LIBS}@g" \
+ @${REINPLACE_CMD} -e "s@-lpthread@${PTHREAD_LIBS}@g" \
${WRKSRC}/acinclude.m4 ${WRKSRC}/configure
+
+.else
+CONFIGURE_ARGS+=--disable-pinentry-qt
+PLIST_SUB+= WITH_QT="@comment "
.endif
.if defined(PINENTRY_GTK)
@@ -90,14 +91,14 @@ PLIST_SUB+= WITH_CURSES=""
pre-configure:
@cd ${WRKSRC}; ${ACLOCAL}
-.endif
run-autotools:
@(cd ${CONFIGURE_WRKSRC} && ${SETENV} ${AUTOTOOLS_ENV} ${AUTOMAKE} \
${AUTOMAKE_ARGS})
@(cd ${CONFIGURE_WRKSRC} && ${SETENV} ${AUTOTOOLS_ENV} ${AUTOCONF} \
${AUTOCONF_ARGS})
- ${REINPLACE_CMD} -e "s@-lpthread@${PTHREAD_LIBS}@g" \
+ @${REINPLACE_CMD} -e "s@-lpthread@${PTHREAD_LIBS}@g" \
${WRKSRC}/acinclude.m4 ${WRKSRC}/configure
+.endif
.include <bsd.port.mk>