aboutsummaryrefslogtreecommitdiff
path: root/security/pks/Makefile
diff options
context:
space:
mode:
authorKris Kennaway <kris@FreeBSD.org>2001-01-15 04:40:11 +0000
committerKris Kennaway <kris@FreeBSD.org>2001-01-15 04:40:11 +0000
commit04665ddc392f7965fe98a2d34c10ac90bbe3e0a7 (patch)
tree9d6c8d5d9f5f37a93739230be282fcb6005017c2 /security/pks/Makefile
parent96e66a00cdba0d8dcc81f94a32f365a5ef26f9ac (diff)
downloadports-04665ddc392f7965fe98a2d34c10ac90bbe3e0a7.tar.gz
ports-04665ddc392f7965fe98a2d34c10ac90bbe3e0a7.zip
Notes
Diffstat (limited to 'security/pks/Makefile')
-rw-r--r--security/pks/Makefile44
1 files changed, 44 insertions, 0 deletions
diff --git a/security/pks/Makefile b/security/pks/Makefile
new file mode 100644
index 000000000000..2adaf529f424
--- /dev/null
+++ b/security/pks/Makefile
@@ -0,0 +1,44 @@
+# New ports collection makefile for: pks
+# Date created: 15 Jan 2001
+# Whom: kris@FreeBSD.org
+#
+# $FreeBSD$
+#
+
+PORTNAME= pks
+PORTVERSION= 0.9.4
+CATEGORIES= security www
+MASTER_SITES+= http://www.mit.edu/people/marc/pks/ \
+ ftp://ftp.neonramp.com/pub/pksd/
+
+PATCH_SITES= http://www.mit.edu/people/marc/pks/ \
+ ftp://ftp.neonramp.com/pub/pksd/
+PATCHFILES= pks094-patch2 \
+ x509patch
+PATCH_DIST_STRIP=-p1
+
+MAINTAINER= kris@FreeBSD.org
+
+LIB_DEPENDS= db2.0:${PORTSDIR}/databases/db
+
+GNU_CONFIGURE= yes
+CONFIGURE_ARGS= --datadir=${PREFIX}/share/pks --localstatedir=/var/pks \
+ --sysconfdir=${PREFIX}/share/examples \
+ --libdir=${LOCALBASE}/lib
+CONFIGURE_ENV= LDFLAGS=-L${LOCALBASE}/lib
+
+MAN5= pksd.conf.5
+MAN8= pks-intro.8 pksclient.8 pksd.8 pksdctl.8
+
+post-build:
+ ${SED} -e "s,@PREFIX@,${PREFIX},g" \
+ < ${FILESDIR}/pksd.sh > ${WRKDIR}/pksd.sh
+
+post-install:
+ ${INSTALL_SCRIPT} ${WRKDIR}/pksd.sh ${PREFIX}/etc/rc.d/pksd.sh
+.if !exists(${PREFIX}/etc/pksd.conf)
+ ${INSTALL_DATA} ${WRKSRC}/pksd.conf ${PREFIX}/etc/pksd.conf
+.endif
+ PKG_PREFIX=${PREFIX} ${SH} ${PKGINSTALL} ${PKGNAME} POST-INSTALL
+
+.include <bsd.port.mk>