aboutsummaryrefslogtreecommitdiff
path: root/security/pks/Makefile
diff options
context:
space:
mode:
authorSam Lawrance <lawrance@FreeBSD.org>2005-10-08 07:44:07 +0000
committerSam Lawrance <lawrance@FreeBSD.org>2005-10-08 07:44:07 +0000
commit2b05516cd2a353ff7c29c0b0b52102df141c02ef (patch)
treec040b1152a5e781a377c166f51339728fea46fee /security/pks/Makefile
parentef8a4adcd396cb44bdcffd9880de30b5258bb2f8 (diff)
downloadports-2b05516cd2a353ff7c29c0b0b52102df141c02ef.tar.gz
ports-2b05516cd2a353ff7c29c0b0b52102df141c02ef.zip
Notes
Diffstat (limited to 'security/pks/Makefile')
-rw-r--r--security/pks/Makefile11
1 files changed, 6 insertions, 5 deletions
diff --git a/security/pks/Makefile b/security/pks/Makefile
index c06ff6935899..e24a21309dfa 100644
--- a/security/pks/Makefile
+++ b/security/pks/Makefile
@@ -18,24 +18,25 @@ LIB_DEPENDS= db2.0:${PORTSDIR}/databases/db2
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --datadir=${PREFIX}/share/pks --localstatedir=/var/pks \
- --sysconfdir=${PREFIX}/share/examples \
+ --sysconfdir=${EXAMPLESDIR} \
--libdir=${LOCALBASE}/lib --with-libwrap
-CFLAGS+= -I/usr/local/include/db2
+CFLAGS+= -I${LOCALBASE}/include/db2
MAKE_ENV+= LDFLAGS=-L${LOCALBASE}/lib SUBDIRS=
USE_RC_SUBR= pksd.sh
MAN5= pksd.conf.5
MAN8= pks-intro.8 pksclient.8 pksd.8 pksdctl.8
USE_REINPLACE= yes
+SUB_FILES= pkg-message pkg-deinstall
# remove embedded sleepycat, remove associated build commands, make
# the build use the headers and libraries from the db2 port
post-patch:
${RM} -rf ${WRKSRC}/db2-sleepycat
${REINPLACE_CMD} 's|SUBDIRS =.*|SUBDIRS =|; \
- s|LIBDB =.*|LIBDB = -L/usr/local/lib -ldb2|; \
- s|DBDIR =.*|DBDIR = /usr/local/include/db2|' \
- ${WRKSRC}/Makefile.in
+ s|LIBDB =.*|LIBDB = -L${LOCALBASE}/lib -ldb2|; \
+ s|DBDIR =.*|DBDIR = ${LOCALBASE}/include/db2|' \
+ ${WRKSRC}/Makefile.in
post-install:
${INSTALL_SCRIPT} ${WRKDIR}/pksd.sh ${PREFIX}/etc/rc.d/pksd.sh