aboutsummaryrefslogtreecommitdiff
path: root/security/pks
diff options
context:
space:
mode:
authorSam Lawrance <lawrance@FreeBSD.org>2005-10-08 07:44:07 +0000
committerSam Lawrance <lawrance@FreeBSD.org>2005-10-08 07:44:07 +0000
commit2b05516cd2a353ff7c29c0b0b52102df141c02ef (patch)
treec040b1152a5e781a377c166f51339728fea46fee /security/pks
parentef8a4adcd396cb44bdcffd9880de30b5258bb2f8 (diff)
downloadports-2b05516cd2a353ff7c29c0b0b52102df141c02ef.tar.gz
ports-2b05516cd2a353ff7c29c0b0b52102df141c02ef.zip
Notes
Diffstat (limited to 'security/pks')
-rw-r--r--security/pks/Makefile11
-rw-r--r--security/pks/files/pkg-deinstall.in (renamed from security/pks/pkg-deinstall)4
-rw-r--r--security/pks/files/pkg-message.in (renamed from security/pks/pkg-message)2
-rw-r--r--security/pks/pkg-plist4
4 files changed, 12 insertions, 9 deletions
diff --git a/security/pks/Makefile b/security/pks/Makefile
index c06ff6935899..e24a21309dfa 100644
--- a/security/pks/Makefile
+++ b/security/pks/Makefile
@@ -18,24 +18,25 @@ LIB_DEPENDS= db2.0:${PORTSDIR}/databases/db2
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --datadir=${PREFIX}/share/pks --localstatedir=/var/pks \
- --sysconfdir=${PREFIX}/share/examples \
+ --sysconfdir=${EXAMPLESDIR} \
--libdir=${LOCALBASE}/lib --with-libwrap
-CFLAGS+= -I/usr/local/include/db2
+CFLAGS+= -I${LOCALBASE}/include/db2
MAKE_ENV+= LDFLAGS=-L${LOCALBASE}/lib SUBDIRS=
USE_RC_SUBR= pksd.sh
MAN5= pksd.conf.5
MAN8= pks-intro.8 pksclient.8 pksd.8 pksdctl.8
USE_REINPLACE= yes
+SUB_FILES= pkg-message pkg-deinstall
# remove embedded sleepycat, remove associated build commands, make
# the build use the headers and libraries from the db2 port
post-patch:
${RM} -rf ${WRKSRC}/db2-sleepycat
${REINPLACE_CMD} 's|SUBDIRS =.*|SUBDIRS =|; \
- s|LIBDB =.*|LIBDB = -L/usr/local/lib -ldb2|; \
- s|DBDIR =.*|DBDIR = /usr/local/include/db2|' \
- ${WRKSRC}/Makefile.in
+ s|LIBDB =.*|LIBDB = -L${LOCALBASE}/lib -ldb2|; \
+ s|DBDIR =.*|DBDIR = ${LOCALBASE}/include/db2|' \
+ ${WRKSRC}/Makefile.in
post-install:
${INSTALL_SCRIPT} ${WRKDIR}/pksd.sh ${PREFIX}/etc/rc.d/pksd.sh
diff --git a/security/pks/pkg-deinstall b/security/pks/files/pkg-deinstall.in
index 9fc2e9fddf84..5b748ca2d78a 100644
--- a/security/pks/pkg-deinstall
+++ b/security/pks/files/pkg-deinstall.in
@@ -1,6 +1,6 @@
#!/bin/sh
#
-# $FreeBSD$
+# $FreeBSD: /tmp/pcvs/ports/security/pks/files/pkg-deinstall.in,v 1.1 2005-10-08 07:44:07 lawrance Exp $
PKGNAME=$1
STAGE=$2
@@ -14,7 +14,7 @@ POST-DEINSTALL)
If you won't be using ${PKGNAME} any longer, you may want to remove the
following directories and files:
- ${PREFIX}/etc/pksd.conf
+ %%PREFIX%%/etc/pksd.conf
/var/pks
===========================================================================
EOF
diff --git a/security/pks/pkg-message b/security/pks/files/pkg-message.in
index b96a749917f7..7e72db0ec54f 100644
--- a/security/pks/pkg-message
+++ b/security/pks/files/pkg-message.in
@@ -6,6 +6,6 @@
web interface please edit the
configuration file at:
- /usr/local/etc/pks/pksd.conf
+ %%PREFIX%%/etc/pks/pksd.conf
##################################
diff --git a/security/pks/pkg-plist b/security/pks/pkg-plist
index d533db70c3d0..b81ba6ea7a9a 100644
--- a/security/pks/pkg-plist
+++ b/security/pks/pkg-plist
@@ -5,7 +5,7 @@ bin/pksclient
sbin/pksd
bin/pksdctl
etc/pksd.conf.sample
-share/pks/mail_intro
+%%DATADIR%%/mail_intro
%%PORTDOCS%%%%DOCSDIR%%/mail_intro
%%PORTDOCS%%%%DOCSDIR%%/pks_help.en
%%PORTDOCS%%%%DOCSDIR%%/pks_help.es
@@ -14,4 +14,6 @@ share/pks/mail_intro
%%PORTDOCS%%%%DOCSDIR%%/pks_help.cz
%%PORTDOCS%%%%DOCSDIR%%/pks_help.ja
%%PORTDOCS%%@dirrm %%DOCSDIR%%
+%%EXAMPLESDIR%%/pksd.conf
+@dirrm %%EXAMPLESDIR%%
@dirrm share/pks